X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Unable to install FireFox because it closes right after "Extraction".

Posted

I uninstalled FireFox because there was a prompt that says "unable to install patch" or something. I downloaded the version 19.0 exe file, but it only 'extracted' it. It closes right after that. How can i solve this?

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.57 Safari/537.17

More Information

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

Helpful Reply

hello, please make sure that your security software isn't interfering with the installation process...

if this doesn't work please also run a scan of your system with the security software already in place and different tools like the free version of malwarebytes, microsoft safety scanner & kaspersky security scan.

Question owner

I tried downloading the security software, and I can't. It closes on me too. Any ideas?

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

adri123 0 solutions 1 answers

Helpful Reply

I had the same problem with the same version (19.0) and I did right-click on the installation file, then "Run as Administrator". And it worked!

I'm using windows 7 Home Premium.

For your information, I already have had similar issues with other software and Running as Administrator has fixed the issue many times.

So I guess it's a matter of permissions. I don't understand it, because I'm always connected as Aministrator, so I don't get why I should specify it to "run as as administrator".

Hope it'll work for you too.