X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I set Firefox 10.0.2 to be default browser in Windows 7, using a script or setup switch. "Firefox.exe -setDefaultBrowser" does NOT work.

Posted

I want to set Firefox as default browser for all my users.

I can do this by opening Firefox and go to Tools --> Options --> Advanced and hit the "Check now" button. That works fine, but I need to accomplish this automatically.

Running setup with the -setDefaultBrowser switch does NOT work. Running "firefox.exe -silent -SetDefaultBrowser" after setup does NOT work. Is this even possible? Or are we stuck with IE?

Chosen solution

After reinstalling the computer it seems to be working now. Must have been some sort of bug. Thank you for your help.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; Tablet PC 2.0; .NET4.0E)

More Information

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8891 answers

hello, just tested it locally here with the command you've proposed & this seems to work without an issue. maybe you can try it with adding the full file-path or probably also make sure that is executed with admin privileges...

Question owner

Thank you for your reply, however it really does not work for me.

I have Firefox installed, as well as Internet Explorer 9. If I check "Default Programs --> Set Default Programs" in Windows 7 it states that Internet Explorer is default. If I create a shortcut on my desktop that points to "www.mozilla.org" for example, and double-click that shortcut, it will open in Internet Explorer.

I now run "%ProgramFiles%\Mozilla Firefox\Firefox.exe -silent -setDefaultBrowser" with administrative privileges. I look again in "Default programs" and i still says IE is default browser. If I click on my shortcut it still opens in IE.

If I change the setting manually from within Firefox it works fine.

Please help, I really can't make this work.

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8891 answers

& when you run it without the -silent switch for testing purposes once?

Question owner

I have tested that too. Only difference is that Firefox opens, but it does not change to default.

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8891 answers

hello, i'm sorry if it doesn't work this way then personally i also don't know any other alternative than to manually change browsers.

there is a bug that might be related to the issue https://bugzilla.mozilla.org/show_bug.cgi?id=454328 but it looks like there has been no activity on it for a long time (which would be strange, since it would affect many instances where firefox is deployed in a larger environment & should certainly have seen more feedback).

Modified by philipp

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8011 answers

I do not now often use Windows, and someone else may well give you a correct answer but I am guessing that you should be looking at Windows settings not just Firefox configuration.

You surely need to set the Windows default browser. Not sure how that is done on multiple installs but it seems to be the reverse of this

Maybe these articles help

Chosen Solution

After reinstalling the computer it seems to be working now. Must have been some sort of bug. Thank you for your help.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8011 answers

jobr,
Thanks for posting back.

Glad it works now. I will mark the thread as solved.