Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why doesn't the add-on site recognise I'm using Firefox Moble browser?

  • 10 replies
  • 2 have this problem
  • 167 views
  • Last reply by James

more options

Every time I go to the add-on page to try and add an additional add-on to my moble browser it tells me I need to download Firefox Moble to add add-ons. And the add to Firefox button is not selectable. Is this some issue with my browser or is there some fault with the site itself?

Chosen solution

That makes no difference. There's a chance that a cookie is stored for AMO that you will need to clear for changes to take affect. Try clearing Cookies via Clear Private Data in Firefox for Android settings.

Read this answer in context 👍 0

All Replies (10)

more options
more options

I don't know. I'm running it on my tablet. But this is what I see every time I go to the Add-on page. Screenshot

more options

What do you see when you visit the above posted pages?

See also:

more options

Ok, here's what is shown with each of those links.

First

Second

And Third

more options

So either you are not using the mobile Firefox (using stock browser on xoom instead) or you have changed your useragent to appear to be the stock browser.

This is what you appear to be using

Mozilla/5.0 (Linux; U; Android 4.0.4; en-us; Xoom Build/IMM76) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Safari/534.30

Modified by James

more options

If you are using the Phony add-on, you will need to select 'Default' in order for addons.mozilla.org to properly recognize the browser as Firefox for Android.

more options

Changing the "Phony" setting to default, I am still having the same issue. Does it matter that I am using a HP Touchpad with a Cyanogenmod Android build?

more options

Chosen Solution

That makes no difference. There's a chance that a cookie is stored for AMO that you will need to clear for changes to take affect. Try clearing Cookies via Clear Private Data in Firefox for Android settings.

more options

That seemed to fix it. Thanks, much appreciate the help.

more options

Your welcome on helping you get on the right track on useragent being the cause.