X
Tap here to go to the mobile version of the site.

Support Forum

Why doesn't the add-on site recognise I'm using Firefox Moble browser?

Posted

Every time I go to the add-on page to try and add an additional add-on to my moble browser it tells me I need to download Firefox Moble to add add-ons. And the add to Firefox button is not selectable. Is this some issue with my browser or is there some fault with the site itself?

Every time I go to the add-on page to try and add an additional add-on to my moble browser it tells me I need to download Firefox Moble to add add-ons. And the add to Firefox button is not selectable. Is this some issue with my browser or is there some fault with the site itself?

Chosen solution

That makes no difference. There's a chance that a cookie is stored for AMO that you will need to clear for changes to take affect. Try clearing Cookies via Clear Private Data in Firefox for Android settings.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Linux; U; Android 4.0.4; en-us; Xoom Build/IMM76) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Safari/534.30

More Information

cor-el
  • Top 10 Contributor
  • Moderator
13051 solutions 119540 answers
How is your browser recognized? *http://browserspy.dk/browser.php *http://browserspy.dk/useragent.php

Question owner

I don't know. I'm running it on my tablet. But this is what I see every time I go to the Add-on page. Screenshot

I don't know. I'm running it on my tablet. But this is what I see every time I go to the Add-on page. [https://www.dropbox.com/s/czpqp3gt1adscey/2013-01-28%2021.11.09.png Screenshot]
cor-el
  • Top 10 Contributor
  • Moderator
13051 solutions 119540 answers

What do you see when you visit the above posted pages?

See also:

What do you see when you visit the above posted pages? See also: *http://browserspy.dk/mobile.php

Question owner

Ok, here's what is shown with each of those links.

First

Second

And Third

Ok, here's what is shown with each of those links. [https://www.dropbox.com/s/548hu03kl1lyvne/2013-01-28%2023.18.12.png First] [https://www.dropbox.com/s/me489ckv1l3ne8w/2013-01-28%2023.18.31.png Second] [https://www.dropbox.com/s/5l26y4kmw7igvbx/2013-01-28%2023.19.01.png And Third]
James
  • Top 25 Contributor
  • Moderator
745 solutions 5511 answers

Helpful Reply

So either you are not using the mobile Firefox (using stock browser on xoom instead) or you have changed your useragent to appear to be the stock browser.

This is what you appear to be using

Mozilla/5.0 (Linux; U; Android 4.0.4; en-us; Xoom Build/IMM76) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Safari/534.30
So either you are not using the mobile Firefox (using stock browser on xoom instead) or you have changed your useragent to appear to be the stock browser. This is what you appear to be using Mozilla/5.0 (Linux; U; Android 4.0.4; en-us; Xoom Build/IMM76) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Safari/534.30

Modified by James

AaronMT 40 solutions 268 answers

If you are using the Phony add-on, you will need to select 'Default' in order for addons.mozilla.org to properly recognize the browser as Firefox for Android.

If you are using the '''Phony''' add-on, you will need to select ''''Default'''' in order for addons.mozilla.org to properly recognize the browser as Firefox for Android.

Question owner

Changing the "Phony" setting to default, I am still having the same issue. Does it matter that I am using a HP Touchpad with a Cyanogenmod Android build?

Changing the "Phony" setting to default, I am still having the same issue. Does it matter that I am using a HP Touchpad with a Cyanogenmod Android build?
AaronMT 40 solutions 268 answers

Chosen Solution

That makes no difference. There's a chance that a cookie is stored for AMO that you will need to clear for changes to take affect. Try clearing Cookies via Clear Private Data in Firefox for Android settings.

That makes no difference. There's a chance that a cookie is stored for AMO that you will need to clear for changes to take affect. Try clearing Cookies via '''Clear Private Data''' in Firefox for Android settings.

Question owner

That seemed to fix it. Thanks, much appreciate the help.

That seemed to fix it. Thanks, much appreciate the help.
James
  • Top 25 Contributor
  • Moderator
745 solutions 5511 answers

Your welcome on helping you get on the right track on useragent being the cause.

Your welcome on helping you get on the right track on useragent being the cause.