X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why does Firefox hang when accessing SSL content on Oracle 10.3.6 WebLogic with JSSE enabled?

  • No replies
  • 2 have this problem
  • 45 views
Posted

For several weeks we have been working with Oracle support to find out why our Firefox browser hangs for 20-30 seconds when connecting to SSL content on 10.3.6 WebLogic only when JSSE is enabled. It occurs when first attempting to connect to an enterprise WebLogic deployment. When JSSE is disabled the problem does not occur but JSSE must be enabled on WebLogic for our configuration. The problem also does 'not' occur when JSSE is enabled when using IE (8). In 10.3.5 WebLogic, the issue does not occur with Firefox but 10.3.6 is our preferred version and this is a major issue for us.

For the Firefox version, we used version 18 and 17 with no difference. Thanks for your help.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; HPNTDF)

More Information

We have tried to debug the traffic on WebLogic to see where the problem is occuring and it seems WebLogic is correctly passing back the content to Firefox but it is hanging for some reason. See below.
--> request has been received at 2:04:53 PM, and the response finished at 2:04:53 PM
<Jan 17, 2013 2:04:53 PM EST> <Debug> <Http> <BEA-000000> <Request received from: /xx.xxx.113.47, Secure: true, Request: Workmanager: , Version: 0, Scheduled=false, Started=false, Wait time: 1 ms
[
GET /console HTTP/1.1
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-US,en;q=0.5
Accept-Encoding: gzip, deflate
Connection: keep-alive
]>
<Jan 17, 2013 2:04:53 PM EST> <Debug> <Http> <BEA-000000> <[HTTP:101087]xx.xx.210.18 is not a virtual host. Dispatching to default HTTP server.>
<Jan 17, 2013 2:04:53 PM EST> <Debug> <Http> <BEA-000000> <Http Server: 'HttpServer (defaultWebserver) name: AdminServer' is resolved for request: 'HttpRequest@1349337560 - /console'>
<Jan 17, 2013 2:04:53 PM EST> <Debug> <Http> <BEA-000000> <ServletContextManager: resolving VersionManager for URI : /console>
<Jan 17, 2013 2:04:53 PM EST> <Debug> <Http> <BEA-000000> <Found context: CVM[appName=consoleapp, contextPath=/console, activeServletContext={ServletContext@1478209582[app:consoleapp module:console path:/console spec-version:2.5]}, activeAdminServletContext={null}, versionIdWASCMap.size=1, sessionIdWASCMap.size=6] for: /console>
<Jan 17, 2013 2:04:53 PM EST> <Debug> <Http> <BEA-000000> <Servlet Context: ServletContext@1478209582[app:consoleapp module:console path:/console spec-version:2.5] is resolved for request: 'HttpRequest@1349337560 - /console'>
<Jan 17, 2013 2:04:53 PM EST> <Debug> <Http> <BEA-000000> <Servlet resource: weblogic.servlet.internal.ServletStubImpl@1b1ce9a - FileServlet class: 'weblogic.servlet.FileServlet' is mapped to request: HttpRequest@1349337560 - /console>
<Jan 17, 2013 2:04:53 PM EST> <Debug> <Http> <BEA-000000> <HttpRequest@1349337560 - /console: [RemoteSessionFetching] obtained workManager: null>
<Jan 17, 2013 2:04:53 PM EST> <Debug> <Http> <BEA-000000> <HttpRequest@1349337560 - /console: Servername: xx.xx.210.18>
<Jan 17, 2013 2:04:53 PM EST> <Debug> <Http> <BEA-000000> <HttpRequest@1349337560 - /console: Serverport: 7002>
..............
<Jan 17, 2013 2:04:53 PM EST> <Debug> <Http> <BEA-000000> <Response finished for request 'HttpRequest@1349337560 - /console'>