X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Howto set default save page behavior to html filename not page title?

Posted

Howto set default save page behavior to html filename (as was for <=17.0.1 )not page title (as is default for 18.0)?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202

Application

  • User Agent: Mozilla/5.0 (X11; Linux i686; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

chenc22 0 solutions 2 answers

Just updated to Firefox 18. As usual somethings changed without being able to figure out how to revert to what I have become used to. How do I change to a default setting of saving a webpage using the html filename instead of the Title of the webpage?

Gene1940 3 solutions 46 answers

I'm sure this new behavior is great for some people, and not so great for others. It totally screws up some common procedures that I use every day. It would at least be nice if someone would reply to these complaints with a suggestion.

Modified by Gene1940

nyrs 0 solutions 2 answers

Helpful Reply

This change appears to have been made without considering what the real requirement is.

For every website which has meaningless filenames but good titles, there's another website with good filenames but meaningless titles.

Issues I've encountered with the use of the page title are that they are not always unique and they are sometimes too long to use as a filename.

It appears to me that what was really needed was a switch for this. Ideally this setting could be remembered on a per-site basis (as happens with the save location).

There are several addons that allowed the title to be used in the save. Perhaps now that this is standard behaviour someone could reverse one of these addons and give us back our filenames.

nyrs 0 solutions 2 answers

Helpful Reply

I think I may have found a solution. I don't know if it's intended to do this, but the Title Save addon (which adds a menu entry to save using the title as the default) appears to revert the behaviour on the standard save (ctrl-s).

Modified by nyrs

Gene1940 3 solutions 46 answers

Thanks nyrs for finding this fix. It does work exactly as you mentioned: restoring the old default behavior to the "Save page" dialog and adding a Title Save option.

This choice should have been the way the Mozilla team did it. Instead they made a wholesale change with no user choice, and without notice.

I much prefer Firefox, but I hope they don't commit suicide by trying to be a carbon copy of other browsers.

Duwayne Engelhardt 0 solutions 1 answers

Thank you for this add-on. As a network admin, it made no sense to archive pages by title only. This helped tremendously.