X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Facebook reports that i'm using v3.5 of Firefox and Windows 2000 when running on 16.0.2 and XP (upgraded system). where is this info and how to reset?

Posted

the PC was upgraded from Win2000 to XP, and has all the XP service packs installed. it is also running Firefox 16.0.2. when i go to Facebook, and other pages, it says that i'm running an unsupported operating system (says i'm using Windows 2000), and i should upgrade my browser to the latest version (says i'm running FF 3.5, or FF 3.6, can't remember which). i' ve looked thru the registry, but haven't found anything that jumps out. where else could this info be stored that Firefox is looking at.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 1.6.0_37 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • 5.1.10411.0
  • GEPlugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Office Live Update v1.3
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6642 answers

Chosen Solution

Try to read Websites say that Firefox is outdated or incompatible even though it's the latest version

Question owner

in looking at the Troubleshooting info, i can easily see that the information presented in the User Agent string is incorrect ...

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6 FBSMTWB

going to http://useragentstring.com/, confirms that the OS is thought to be Windows 2000 and the Firefox version is 3.5.6.

where is this information stored? and how can i correct it?

Gingerbread Man
  • Top 25 Contributor
227 solutions 940 answers

pbturner wrote:

where is this information stored? and how can i correct it?

It's explained in the “Firefox is showing the wrong User Agent” section of the aforementioned article.

  1. Type about:config in the address bar and press Enter.
  2. Press the big button to bypass the warning.
  3. In the Search bar, paste general.useragent
  4. If any of the search results show “Status: user set”, right-click each one and choose Reset

You should also get rid of Fast Browser Search, which is what corrupted your user agent string. Other names to watch out for are “Fast Browser search protection”, “Fast Browser Search (MyTattoo)”.
These may appear not only in your Firefox add-ons, but also your Internet Explorer add-ons and Windows Control Panel, in the Uninstall or Add or Remove Programs category.

Question owner

completed thru step 4 above ... found that ...

general.useragent.override had the values that showed Windows 2000 and Firefox 3.5.6 ...

right clicking over the "User set" status of this one, selecting Reset, and restarting Firefox, the info is now CORRECT (XP & 17.0.1) ... confirmed with UserAgentString.com

Thanks to all!!!

pete.