X
Tap here to go to the mobile version of the site.

Support Forum

I can't reinstall Version 15.01 on my Mac. It was running earlier. Help please.

Posted

I was running Version 15.0.1 on my Mac Powerbook G4 with OS10.5.8 earlier. When I tried to upgrade to Version 17 I couldn't. So I tried to reinstall or download Version 15.0.1. I still get a message telling me that is unsupported on my architecture. How can I get Version 15.0.1 to run again?

I was running Version 15.0.1 on my Mac Powerbook G4 with OS10.5.8 earlier. When I tried to upgrade to Version 17 I couldn't. So I tried to reinstall or download Version 15.0.1. I still get a message telling me that is unsupported on my architecture. How can I get Version 15.0.1 to run again?
Michael Verdi 128 solutions 857 answers

Sadly, I don't know how you got Fx 15 to run on a PowerBook G4. The last version of Firefox that I know is able to run on a G4 is Fx 3.6.28 - more info - so I don't have an info on making Fx 15 work.

Sadly, I don't know how you got Fx 15 to run on a PowerBook G4. The last version of Firefox that I know is able to run on a G4 is Fx 3.6.28 - [[Firefox no longer works with Mac OS X 10.4 or PowerPC processors|more info]] - so I don't have an info on making Fx 15 work.