Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

home page can't be changed always is automatically setting back to : How to fix this problem?

  • 21 replies
  • 11 have this problem
  • Last reply by finitarry

more options

I have re-install fire fox several times and still was unable to change home page from :

Chosen solution

Finally get it OFF!!!!

The setting( is in file mozilla.cfg.

1. Uninstall firefox. 2. Delete everything remaining in folder "Mozilla Firefox" under Program Files or Program Files (x86). 3. Reinstall firefox. done!

Read this answer in context 👍 9

All Replies (20)

more options

Probably some toolbar or extension got added to Firefox. These unwanted things that install with some other application frequently hijack home pages.

more options

If you do not keep changes after a restart then see:

more options

I too have this problem. I have tried the suggestions above with no good result. I have also changed my preferences. Write protected prefs.js and then closed but still get when restarting.

The host is apparently in the US Reverse IP Lookup Result for | Ggle

We found 3 hostnames for IP Address [ Lookup this IP ]




I can find little or no reference to them. I welcome any constructive suggestions.

Modified by DerekESL

more options

I have reinstall older version of the firefox but that didn't help either, looks to me that this "malware" is sitting within registry and get triggered by active firefox on the computer?

more options

Yes - it looks like that and I'm concerned as it's a new Dell and I hadn't browsed any sites except to download Firefox.. I've just regoogled and followed the same link which appeared to be genuine.

I've virus scanned the PC using Kaspersky and scanned the registry looking for clues but to no avail.

I'll try and write to Kaspersky and see if they have any suggestions. I'll keep you posted.

more options

Compare the standard Google search page for UK ( with some of the other links mentioned above ( or ).

On the two latter you will see:

There is not much on the internet about any of the above, but my guess is this is at best some form of spyware/adware, at worst some much more malicious attempt at stealing your information, installed along with something that you have installed from the internet. Looks like some new search redirect crapware.

Modified by TheOldFox

more options

I tried resetting Firefox, tried the registry and tried

  • Malwarebytes' Anti-Malware
  • SuperAntispyware Portable Scanner
  • Anti-Rootkit Utility - TDSSKiller

I was concerned by the lack of progress and not knowing what was running so have rebuilt my machine.

I'm a long way back along the road and have not had a repeat. When I have a moment, I will compare the first install of Firefox that I downloaded and compare it to the one that I'm using. They have the same date-time stamps and are the same size... as the only thing that I can think of is that I hurriedly googled for the latest Firefox download and followed a dodgy (but lookalike) link - thus installing a dodgy version.

Thank you fo your help. If I discover something I'll repost.

more options

I reinstalled Firefox with deleting the profile. It is not resolved "home page" problem.

more options

DerekESL: Thanks for posting back to let us know of your progress thus far. It is always helpful to have information from users in how the problems are resolved. If only the original posters, in this case Banderasbc, would post back with information, it could help other users encountering the same problem.

sakovich: From your description of continuation of the problem after reinstalling Firefox after deleting the profile, that is a good indication that the problem is caused by something else that is installed or was installed on your system. The changes could be made by another application or through a left-over Windows registry key after uninstalling the culprit. My suggestion to you is to follow the steps that I provided above. If you are unsuccessful in resolving the problem yourself, try registering and posting on one of the three sites for assistance from malware experts listed at the bottom of the article that I posted above ( ).

more options

I have the same problem! I have a brand new ASUS computer, I pulled it out of the box, and installed Firefox right away... The problems was there, I am pretty sure from the start. If it was not immediate, it was within a few hours, and all

I did was: Install Firefox install Silverlight Install AVG free Install Comodo firewall free install Skype Surf the web

I did not find any of those names or references in my software uninstall section of windows.

I did delete a couple of references in the about:config section (entered empty string for home page a and default search engine)

as soon as I restarted it was there again...

I also noticed that it does not allow for search of any "bad" words (porn, boobs, sex, etc.).

Is this a religious malware or are we having some built in parental control taking over our computers???

I do not know windows 7, I am a linux geek, so I have no clue what I might have missed...

more options

Chosen Solution

Finally get it OFF!!!!

The setting( is in file mozilla.cfg.

1. Uninstall firefox. 2. Delete everything remaining in folder "Mozilla Firefox" under Program Files or Program Files (x86). 3. Reinstall firefox. done!

more options

Will try it tomorrow morning and let you know if that solved it... Anyone, any clue where does it comes from? who is this company??? Really bizarre...

more options


Thank you thank you thank you!!!! I was banging my head against the wall over this one for hours, and your fix did the trick!

That'll teach me not to download in haste... I had accidentally followed a fake download link that was showing up at the top of the google results for a brief period. It seems to be gone now, I guess Google got wise to them.

more options

Thank you. It is interesting that uninstalling the FireFox (with deleting the Mozilla directory after) and installation the FireFox again DOES NOT help to resolve this problem. However (!!!) after that I tried to find the mozilla.cfg file on my drive C: I find out this file in the one of the TEMP (!!!) folders. It is really that this file has string with title as "home page". I simply DELETE this file from the temp folder and after that the problem evaporates. Thank you for navigation!

more options

Well... this is becoming interesting. I had only just got my PC out of a box so it wasn't a huge investment to reinstall Windows (but not reformat the entire drive) and avoid any worries. I was concerned as to how I got the problem and like happycoder, concluded that it was the result of a hasty download - and it would have to have been either Firefox or Adobe reader.

HOWEVER... although my machine is now stable, I'm curious and when sakovich made their observation above I thought I'd have a look at the filemozilla.cfg.

I have two and they both contain the following;

//Firefox Default Settings

// set Firefox Default homepage pref("browser.startup.homepage","");

// disable default browser check //pref("", false); pref("browser.startup.homepage_override.mstone", "ignore");

// disable application updates pref("app.update.enabled", false)

// disables the 'know your rights' button from displaying on first run pref("browser.rights.3.shown", true);

// disables the request to send performance data from displaying pref("toolkit.telemetry.prompted", 2); pref("toolkit.telemetry.rejected", true);

It would be good to understand what else is going on......


more options

DerekESL writes about TWO files with name mozilla.cfg

I had one and it was problem with

I deleted this file (mozilla.cfg) and now I DO NOT HAVE mozilla.cfg on drive C:

My FireFox works without any problem after deleting.

P.S. The content of the mozilla.cfg looks like the same that was described by DerekESL in the message above.

more options

I resolved changing the mozilla.cfg file that are in the C:\Program Files\Mozilla Firefox\updated folder and C:\Program Files\Mozilla Firefox folder. 1) Edit the mozilla.cfg with Notepad and change

"" for

2) after the change is done, save it.

note. Remember to do this changes in both folder (Mozilla Firefox and Mozilla Firefox/updated

After that my Browser is ok.


more options

Goggle is some kind of survey site. The search engine is Google.

more options

Sorry I misspelled Google, but all remain valid. Thanks to indicate that.

more options

There shouldn't be a mozilla.fcg file present unless you've created it yourself to initialize some prefs.

If you have this mozilla.cfg file then best is to do a clean reinstall and delete the Firefox program folder before reinstalling a fresh copy of Firefox because this also involves the presence of a .js (JScript) file, probably in "defaults\pref" folder, that specifies to process this mozilla.cfg file.

Uninstall your current Firefox version, if possible, to cleanup the Windows registry and settings in security software.

  • Do NOT remove personal data when you uninstall your current Firefox version, because all profile folders will be removed and you will also lose your personal data like bookmarks and passwords from profiles of other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

Your bookmarks and other profile data are stored in the Firefox Profile Folder and won't be affected by an uninstall and (re)install, but make sure that "remove personal data" is NOT selected when you uninstall Firefox.

  1. 1
  2. 2