X
Tap here to go to the mobile version of the site.

Support Forum

How can I disable JavaScript in Firefox Mobile for Android?

Posted

If its not possible, when will it be?

If its not possible, when will it be?

Chosen solution

Obviously the vast majority of Firefox's settings cannot fit on the Settings page. I don't know whether this one will be added there in the future. For now, you can try changing it in Firefox's about:config preferences editor. This worked for me:

(1) In the same or a new tab, tap the address bar and type about:config and press Enter or tap the go arrow. I recommend bookmarking this for future ease of access.

(2) In the Search Settings box, type script and press Enter.

(3) Scroll down to javascript.enabled and tap Toggle to switch it to false. After a moment it should turn bold and show the change.

You're done with about:config.

Read this answer in context 15

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.1 r115

Application

  • User Agent: Mozilla/5.0 (Android; Mobile; rv:14.0) Gecko/14.0 Firefox/14.0.2

More Information

jscher2000
  • Top 10 Contributor
3235 solutions 29539 answers

Chosen Solution

Obviously the vast majority of Firefox's settings cannot fit on the Settings page. I don't know whether this one will be added there in the future. For now, you can try changing it in Firefox's about:config preferences editor. This worked for me:

(1) In the same or a new tab, tap the address bar and type about:config and press Enter or tap the go arrow. I recommend bookmarking this for future ease of access.

(2) In the Search Settings box, type script and press Enter.

(3) Scroll down to javascript.enabled and tap Toggle to switch it to false. After a moment it should turn bold and show the change.

You're done with about:config.

Obviously the vast majority of Firefox's settings cannot fit on the Settings page. I don't know whether this one will be added there in the future. For now, you can try changing it in Firefox's about:config preferences editor. This worked for me: (1) In the same or a new tab, tap the address bar and type '''about:config''' and press Enter or tap the go arrow. I recommend bookmarking this for future ease of access. (2) In the Search Settings box, type '''script''' and press Enter. (3) Scroll down to '''javascript.enabled''' and tap Toggle to switch it to false. After a moment it should turn bold and show the change. You're done with about:config.

Helpful Reply

Thanks alot! Didn't know about the about:config page.

Thanks alot! Didn't know about the about:config page.