X
Tap here to go to the mobile version of the site.

Support Forum

Firefox appends jpeg extension to jpg images

Posted

Every time I save an image through Firefox for Android, it adds a JPEG extension, resulting in FILENAME.JPG.JPEG. Since most Android apps don't recognize JPEG, I've got to go into a file manager and rename the JPEG back to JPG before it's useful.

This used to be an issue with Firefox for Windows that was fixable with a MIME type edit, but that doesn't seem to be an option with Android.

It's driving me nuts. Help?

Every time I save an image through Firefox for Android, it adds a JPEG extension, resulting in FILENAME.JPG.JPEG. Since most Android apps don't recognize JPEG, I've got to go into a file manager and rename the JPEG back to JPG before it's useful. This used to be an issue with Firefox for Windows that was fixable with a MIME type edit, but that doesn't seem to be an option with Android. It's driving me nuts. Help?

Chosen solution

It's a valid bug, and we have it on file http://bugzil.la/712748 it's just not a high-priority bug.

Read this answer in context 1

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • Shockwave Flash 11.1 r115

Application

  • User Agent: Mozilla/5.0 (Android; Mobile; rv:14.0) Gecko/14.0 Firefox/14.0.1

More Information

AaronMT 44 solutions 299 answers

Chosen Solution

It's a valid bug, and we have it on file http://bugzil.la/712748 it's just not a high-priority bug.

It's a valid bug, and we have it on file http://bugzil.la/712748 it's just not a high-priority bug.

Modified by AaronMT

Soundman2020 0 solutions 6 answers

Not sure if this works for Android, but it works fine on Windows to fix the very similar and annoying, ludicrous behavior of always saving images as ".jpe", instead of the standard ".jpg". So you might be able to modify this procedure to fix the ".jpeg" bug on Android.

- Find your Firefox Profile folder (Read this if you don't know how: http://kb.mozillazine.org/Profile_folder

- Find the file called "mimeTypes.rdf".

- Before you touch it, make a backup copy, just in case something goes wrong.

- Edit the original file with Notepad or any other pure text editor.

NOTE: DO NOT USE something like Word, which is not a text editor: make sure that whatever program you use can edit any file as pure text, without changing the format at all, regardless of the filename extension.

- Search for this string ' fileExtensions="jpe" ' (including the double quotes, but not the single quotes.

- Change the "jpe" to "jpg".

- DO NOT CHANGE ANYTHING ELSE IN THE FILE! Just change that one thing.

- Save the file.

- Completely exit from Firefox.

NOTE: Use the Windows task manager to make sure Firefox has shutdown completely.  It can take a while if you have a lot of tabs open.

- Start Firefox again

Fixed! No more annoying, non-standard ".jpe" files. From now on, everything will be saved as ".jpg".

(This seems to have been a known bug for at least two years, so I'm wondering about the "official" answer of this "not being a high priority bug": how hard can it be to fix? I know nothing at all about how Firefox works internally, but it took me all of five minutes to figure it out and fix it, with a quick Google search and a bit of logical thinking. If the guys who wrote the code can't figure out this simple bug after two years, I wonder how long it might take them to be able to fix complicated bugs?)

Not sure if this works for Android, but it works fine on Windows to fix the very similar and annoying, ludicrous behavior of always saving images as ".jpe", instead of the standard ".jpg". So you might be able to modify this procedure to fix the ".jpeg" bug on Android. - Find your Firefox Profile folder (Read this if you don't know how: http://kb.mozillazine.org/Profile_folder - Find the file called "mimeTypes.rdf". - Before you touch it, make a backup copy, just in case something goes wrong. - Edit the original file with Notepad or any other pure text editor. NOTE: DO NOT USE something like Word, which is not a text editor: make sure that whatever program you use can edit any file as pure text, without changing the format at all, regardless of the filename extension. - Search for this string ' fileExtensions="jpe" ' (including the double quotes, but not the single quotes. - Change the "jpe" to "jpg". - DO NOT CHANGE ANYTHING ELSE IN THE FILE! Just change that one thing. - Save the file. - Completely exit from Firefox. NOTE: Use the Windows task manager to make sure Firefox has shutdown completely. It can take a while if you have a lot of tabs open. - Start Firefox again Fixed! No more annoying, non-standard ".jpe" files. From now on, everything will be saved as ".jpg". (This seems to have been a known bug for at least two years, so I'm wondering about the "official" answer of this "not being a high priority bug": how hard can it be to fix? I know nothing at all about how Firefox works internally, but it took me all of five minutes to figure it out and fix it, with a quick Google search and a bit of logical thinking. If the guys who wrote the code can't figure out this simple bug after two years, I wonder how long it might take them to be able to fix complicated bugs?)

Modified by Soundman2020

jscher2000
  • Top 10 Contributor
8637 solutions 70650 answers

Hi Soundman2020, I've never seen that issue. Are there particular sites where it happened, or does it happen anytime you want to save a JPEG?

The mimeTypes.rdf file seems to accumulate settings related to your add-ons, so this issue might only affects users of particular image-related software.

Hi Soundman2020, I've never seen that issue. Are there particular sites where it happened, or does it happen anytime you want to save a JPEG? The mimeTypes.rdf file seems to accumulate settings related to your add-ons, so this issue might only affects users of particular image-related software.
Soundman2020 0 solutions 6 answers

Hi jscher2000. It happens on every website I visit, for every single .jpg file I try to save. It has been that way ever since I first installed Firefox, years ago, so I assumed it was standard. I have Firefox set up save these files, instead of trying to open them itself, and it has always added a ".jpe" extension to every single file it saves (so they end up as "<filename>.jpg.jpe"). This seems to have first been reported two years ago: https://support.mozilla.org/en-US/questions/711231

Is there any way I can figure out which add-on might have messed that up?

Hi jscher2000. It happens on every website I visit, for every single .jpg file I try to save. It has been that way ever since I first installed Firefox, years ago, so I assumed it was standard. I have Firefox set up save these files, instead of trying to open them itself, and it has always added a ".jpe" extension to every single file it saves (so they end up as "<filename>.jpg.jpe"). This seems to have first been reported two years ago: https://support.mozilla.org/en-US/questions/711231 Is there any way I can figure out which add-on might have messed that up?
jscher2000
  • Top 10 Contributor
8637 solutions 70650 answers

Hi Soundman2020, you wrote: I have Firefox set up save these files, instead of trying to open them itself, and it has always added a ".jpe" extension to every single file it saves (so they end up as "<filename>.jpg.jpe").

How did you set that up? When I look in Application Options, I have "Always Ask" for JPEG files but actually, I can't recall the last time Firefox asked me because JPEG files default to inline display unless the website explicitly adds a header indicating that they should be downloaded. Are you using an add-on to change the behavior? It probably would be an extension.

(My mimeTypes.rdf file has no entries with "jpe" either in my normal profile or one I created recently for testing.)

Hi Soundman2020, you wrote: ''I have Firefox set up save these files, instead of trying to open them itself, and it has always added a ".jpe" extension to every single file it saves (so they end up as "<filename>.jpg.jpe").'' How did you set that up? When I look in Application Options, I have "Always Ask" for JPEG files but actually, I can't recall the last time Firefox asked me because JPEG files default to inline display unless the website explicitly adds a header indicating that they should be downloaded. Are you using an add-on to change the behavior? It probably would be an extension. (My mimeTypes.rdf file has no entries with "jpe" either in my normal profile or one I created recently for testing.)
Soundman2020 0 solutions 6 answers

"How did you set that up? "

Tools -> Options -> Applications -> JPEG Images : set to "Save File"

"How did you set that up? " Tools -> Options -> Applications -> JPEG Images : set to "Save File"
jscher2000
  • Top 10 Contributor
8637 solutions 70650 answers

Hi Soundman2020, I changed "Always Ask" to "Save File" but I get the same file names as previously suggested. For example, on the following page there are two links below the image: "Show in new window" is coded for display "inline" in a browser window, and "Download" is coded to trigger a download with a specific file name ending with .jpg. That is what I get. What do you get from the two links?

http://jeffersonscher.com/photos/Maui07/AroundMaui

Hi Soundman2020, I changed "Always Ask" to "Save File" but I get the same file names as previously suggested. For example, on the following page there are two links below the image: "Show in new window" is coded for display "inline" in a browser window, and "Download" is coded to trigger a download with a specific file name ending with .jpg. That is what I get. What do you get from the two links? http://jeffersonscher.com/photos/Maui07/AroundMaui
Soundman2020 0 solutions 6 answers

Both of them do what I would expect them to do.

If I click "Show in new window", then it does indeed open a new tab showing that picture (note: a new tab, not a new window).

If I click on "Download", it opens the "save file as" dialog, with the file name shown as "NorthernCoastOfWestMaui-7559.jpg".

If I go back the previous version of my "mimeTypes.rdf" file, then clicking the "Download" link takes me to the same save-file-as dialog, but with the file name as "NorthernCoastOfWestMaui-7559.jpg.jpe".

Both of them do what I would expect them to do. If I click "Show in new window", then it does indeed open a new tab showing that picture (note: a new tab, not a new window). If I click on "Download", it opens the "save file as" dialog, with the file name shown as "NorthernCoastOfWestMaui-7559.jpg". If I go back the previous version of my "mimeTypes.rdf" file, then clicking the "Download" link takes me to the same save-file-as dialog, but with the file name as "NorthernCoastOfWestMaui-7559.jpg.jpe".
jscher2000
  • Top 10 Contributor
8637 solutions 70650 answers

Hi Soundman2020, in the old mimeTypes.rdf, do the surrounding tags provide any hint as to the source of that extension? In particular, is there a corresponding NC:description line below the NC:fileExtensions line (other than the generic "JPEG Image" description)? In the Application options for JPG or JPEG, are there any unexpected options for handling the file?

Hi Soundman2020, in the old mimeTypes.rdf, do the surrounding tags provide any hint as to the source of that extension? In particular, is there a corresponding NC:description line below the NC:fileExtensions line (other than the generic "JPEG Image" description)? In the Application options for JPG or JPEG, are there any unexpected options for handling the file?
Soundman2020 0 solutions 6 answers

Helpful Reply

From what I can figure out of this file, this seems to be the entire entry that is causing the problem:

<RDF:Description RDF:about="urn:mimetype:image/jpeg"

                  NC:fileExtensions="jpe"
                  NC:description="JPEG Image"
                  NC:value="image/jpeg"
                  NC:editable="true">
   <NC:handlerProp RDF:resource="urn:mimetype:handler:image/jpeg"/>
 </RDF:Description>
 

The entry just before that is for "gzip" files, and the one just after it is for "x-rar-compressed" files

From what I can figure out of this file, this seems to be the entire entry that is causing the problem: <RDF:Description RDF:about="urn:mimetype:image/jpeg" NC:fileExtensions="jpe" NC:description="JPEG Image" NC:value="image/jpeg" NC:editable="true"> <NC:handlerProp RDF:resource="urn:mimetype:handler:image/jpeg"/> </RDF:Description> The entry just before that is for "gzip" files, and the one just after it is for "x-rar-compressed" files
jscher2000
  • Top 10 Contributor
8637 solutions 70650 answers

Helpful Reply

Hi Soundman2020, thanks for checking. I'm not sure how that got corrupted to jpe; we'll probably never know.

Hi Soundman2020, thanks for checking. I'm not sure how that got corrupted to jpe; we'll probably never know.
Soundman2020 0 solutions 6 answers

Thanks for trying to help! Much appreciated.  :)

Thanks for trying to help! Much appreciated. :)

Modified by Soundman2020

harryg123 0 solutions 6 answers

I have the same problem. I had it once before, except FF was tacking on “.jpeg”. The problem went away. I don’t know why or how or remember what I did to make it go away. Now I’m running FF 13 on Win7Ultimate, with no SP. The problem started up again, just a couple of hours ago. Today I was editing and ePUB file’s xhtml pages using MS Word 97 in text mode. Also, I was creating jpgs by copying with a screen capture program.

After reading the posts on this page I used MozBackup to save everythiing, then completely uninstalled FF, including deleting the directories in c:\program files. Then I re-installed a clean copy of FF 15, but didn’t restore the profile. The problem persisted. I thought the problem must be in the Windows registry. Then I restored the profile.

I’m running FF 11 on a netbook, and don’t see this behavior.

BTW in both my copies of (FF-11 on the netbook, and FF15 on the desktop) the mimeTypes.rdf files contain no entries containing “image”, let alone “image/jpg”

Just now I experimented with Thunderbird and found the same behaviour on the desktop, but not on the netbook. I’m running identical versions of TBird--they get synced every day..

Any ideas? I’m at my wit’s end.

I have the same problem. I had it once before, except FF was tacking on “.jpeg”. The problem went away. I don’t know why or how or remember what I did to make it go away. Now I’m running FF 13 on Win7Ultimate, with no SP. The problem started up again, just a couple of hours ago. Today I was editing and ePUB file’s xhtml pages using MS Word 97 in text mode. Also, I was creating jpgs by copying with a screen capture program. After reading the posts on this page I used MozBackup to save everythiing, then completely uninstalled FF, ''including deleting the directories in c:\program files.'' Then I re-installed a clean copy of FF 15, but didn’t restore the profile. The problem persisted. I thought the problem must be in the Windows registry. Then I restored the profile. I’m running FF 11 on a netbook, and don’t see this behavior. BTW in both my copies of (FF-11 on the netbook, and FF15 on the desktop) the mimeTypes.rdf files contain no entries containing “image”, let alone “image/jpg” Just now I experimented with Thunderbird and found the same behaviour on the desktop, but not on the netbook. I’m running identical versions of TBird--they get synced every day.. Any ideas? I’m at my wit’s end.
jscher2000
  • Top 10 Contributor
8637 solutions 70650 answers

Hi harryg123, if you open the Page Info dialog > Media tab (either by right-clicking a page or from the Tools menu) and use the Save As button for an image you can see is a .jpg file, Firefox suggests changing the ending to .jpeg?

I wonder whether either of the tools you were using (Word or screen capture software) made itself the default for JPEG images on your system. Could you try resetting that to Preview, Paint, or another image editing program?

Hi harryg123, if you open the Page Info dialog > Media tab (either by right-clicking a page or from the Tools menu) and use the Save As button for an image you can see is a .jpg file, Firefox suggests changing the ending to .jpeg? I wonder whether either of the tools you were using (Word or screen capture software) made itself the default for JPEG images on your system. Could you try resetting that to Preview, Paint, or another image editing program?
harryg123 0 solutions 6 answers

TY, jscher2000. Tried that the first thing. I checked it with assoc, and found jpeg files associated with jpegfile. So I changed the associations:

C:\>assoc | grep -i .jp
.j2k=IrfanView.JP2
.jfif=pjpegfile
.jp2=IrfanView.JP2
.jpc=IrfanView.JP2
.jpe=IrfanView.JPG
.jpeg=IrfanView.JPG
.JPF=IrfanView.JP2
.jpg=IrfanView.JPG
.jpm=IrfanView.JPM

I logged off windows and back on. Still getting jpeg tacked on.

BTW why doesn’t my mimeTypes.rdf file contain a reference to type image/jpg?

TY, jscher2000. Tried that the first thing. I checked it with assoc, and found jpeg files associated with jpegfile. So I changed the associations: C:\>assoc | grep -i .jp .j2k=IrfanView.JP2 .jfif=pjpegfile .jp2=IrfanView.JP2 .jpc=IrfanView.JP2 .jpe=IrfanView.JPG .jpeg=IrfanView.JPG .JPF=IrfanView.JP2 .jpg=IrfanView.JPG .jpm=IrfanView.JPM I logged off windows and back on. Still getting jpeg tacked on. BTW why doesn’t my mimeTypes.rdf file contain a reference to type image/jpg?

Modified by harryg123

jscher2000
  • Top 10 Contributor
8637 solutions 70650 answers

Hi harryg123, I don't know how Firefox retrieves the "default" extension for a given content type from the system, so I'm not sure where you would need to switch it from .jpeg to .jpg.


BTW why doesn’t my mimeTypes.rdf file contain a reference to type image/jpg?

I believe that's normal. Since Firefox display JPEG images natively, there is not usually an entry for an external handler in the file.

Perhaps if you make a change using Application Options an entry would be added?

orange Firefox button or classic Tools menu > Options > Applications


I've never seen .jpe or .jpeg appended to a file name whether there is an entry in mimeTypes.rdf or not.

In my ancient legacy profile that goes back to early days for Firefox, I have a lot of image/jpeg entries in my mimeTypes.rdf file:


<RDF:Description RDF:about="urn:mimetype:image/jpeg" NC:fileExtensions="jpg" NC:description="JPEG Image" NC:value="image/jpeg" NC:editable="true"> <NC:handlerProp RDF:resource="urn:mimetype:handler:image/jpeg"/> </RDF:Description> <RDF:Description RDF:about="urn:mimetype:externalApplication:image/jpeg" NC:prettyName="" NC:path="" /> <RDF:Description RDF:about="urn:mimetype:handler:image/jpeg" NC:alwaysAsk="true" NC:saveToDisk="true" NC:useSystemDefault="false"> <NC:externalApplication RDF:resource="urn:mimetype:externalApplication:image/jpeg"/> </RDF:Description>

Although manually editing the file is messy, and the above doesn't seem to say very much, you could close Firefox, make a backup of your existing file, add the above just before the closing </RDF:RDF> tag and see whether it helps. If the sky falls, revert back to your backup file.

Hi harryg123, I don't know how Firefox retrieves the "default" extension for a given content type from the system, so I'm not sure where you would need to switch it from .jpeg to .jpg. ---- ''BTW why doesn’t my mimeTypes.rdf file contain a reference to type image/jpg?'' I believe that's normal. Since Firefox display JPEG images natively, there is not usually an entry for an external handler in the file. Perhaps if you make a change using Application Options an entry would be added? orange Firefox button ''or'' classic Tools menu > Options > Applications ---- I've never seen .jpe or .jpeg appended to a file name whether there is an entry in mimeTypes.rdf or not. In my ancient legacy profile that goes back to early days for Firefox, I have a lot of image/jpeg entries in my mimeTypes.rdf file: <br> &lt;RDF:Description RDF:about="urn:mimetype:image/jpeg" NC:fileExtensions="jpg" NC:description="JPEG Image" NC:value="image/jpeg" NC:editable="true"> &lt;NC:handlerProp RDF:resource="urn:mimetype:handler:image/jpeg"/> &lt;/RDF:Description> &lt;RDF:Description RDF:about="urn:mimetype:externalApplication:image/jpeg" NC:prettyName="" NC:path="" /> &lt;RDF:Description RDF:about="urn:mimetype:handler:image/jpeg" NC:alwaysAsk="true" NC:saveToDisk="true" NC:useSystemDefault="false"> &lt;NC:externalApplication RDF:resource="urn:mimetype:externalApplication:image/jpeg"/> &lt;/RDF:Description> Although manually editing the file is messy, and the above doesn't seem to say very much, you could close Firefox, make a backup of your existing file, add the above just before the closing &lt;/RDF:RDF> tag and see whether it helps. If the sky falls, revert back to your backup file.
the-edmeister
  • Top 25 Contributor
  • Moderator
5395 solutions 40084 answers

Locking this thread, which started out as a problem on Firefox for Android, and has gone off-topic to include a discussion of desktop Firefox for Windows.

Locking this thread, which started out as a problem on Firefox for Android, and has gone off-topic to include a discussion of desktop Firefox for Windows.