X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Need to start ff in 32 bit mode

Posted

I will begin by saying that ff "help" is ANYTHING but helpful. How pitiful it is to encounter supposedly potential solutions that are for versions of FF from many years ago. That no one even had the intelligence to segregate mac from windows help articles tells me that this is run by a bunch of jokers. I searched help articles. Began with [firefox 32 bit] got 1010 results. Went to [firefox "32 bit"] 1010 results, ["firefox 14" "32 bit"] 1010 results. Obviously help search is not sensitive to phrases. Between the primitiveness of search and the complete lack of segregation of obsolete articles, I have to say that I can't think of any program with more pathetic support.

Now that I've gotten that off my chest, ALL I FREAKIN WANNA DO IS START FF IN 32 BIT MODE, SINCE 64 IS INCOMPATIBLE WITH SIBELIUS SCORCH. I searched for 1/2 hour in google, and did encounter the question asked by someone else, but no answer had any meaning. I'm ready to delete this garbage program. And of course, now that I scan down, unlike every other support forum, I have no ability to subscribe to this thread. How consistent!

Chosen solution

Well, "officials" firefox builds are 32 bits since 64 bits versions of firefox are unstable... So you just have to go to the download page ...

Read this answer in context 0

Additional System Details

Sites Affected

http://

Installed Plug-ins

irrelevant

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.57 Safari/536.11

More Information

Shywim 3 solutions 10 answers

Chosen Solution

Well, "officials" firefox builds are 32 bits since 64 bits versions of firefox are unstable... So you just have to go to the download page ...

Modified by Shywim

Question owner

Thanks for your reply. The version of ff I downloaded from the download page is, according to about:, 64 bit. I did nothing special, just clicked download. I normally use Chrome, but Scorch doesn't support it. It's not a problem - opened IE, went to the Scorch page, Scorch installed itself, now I can see scores. FF and everything associated with it is a JOKE. I'm just sorry I wasted as much time as I did.

kazar 0 solutions 6 answers

Helpful Reply

You haven't said what OS your computer runs. The default for Firefox on Mac, anyhow, is indeed 64-bit. The way to change it on a Mac to 32-bit is to select the application in Finder, Get Info (command-I), and check the box for open in 32 bit mode.

HOWEVER, I think there is a problem with Firefox 14 on Mac not respecting that checkbox, because just today my Macbook Pro suddenly cannot play Netflix movies. I am brought to a page that indicates a Silverlight incompatibility and Silverlight requires 32-bit mode. I called Netflix support (and was shocked that they answered the phone in 2 minutes, their customer svc has vastly improved) and the rep told me that a lot of people are reporting this problem on Firefox 14 on Mac. (My version specifically is 14.0.1) She said that the setting to open in 32-bit mode is not being respected.

Question owner

sorry, windows 7 64. all irrelevant now, scorch works easily and perfectly with IE. why should I waste time with a poorly supported, thrown together mishmash of crap like FF when IE does the job effortlessly?

James
  • Top 25 Contributor
  • Moderator
437 solutions 3156 answers

If you downloaded Firefox 14.0.1 release for Windows from www.mozilla.org then is 32-bit as Mozilla has yet to have 64-bit releases for Windows.

Go to Help->About Firefox and look at your useragent. It should say WOW64 in UA which means it is a 32-bit application on 64-bit Windows.

The only way you could have 64-bit Firefox 14.0.1 on Windows is if you were to either build it yourself or use a third-party build.

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96832 answers

Helpful Reply

Do you see that plugin in the Tools > Add-ons > Plugins window? If not then try to delete the pluginreg.dat file in the Firefox Profile Folder and maybe addons.sqlite as well to reset the plugin registry databases.


You can do additional testing if you see the plugin on the about:plugins page.

You can set the plugin.expose_full_path pref to true on the about:config page to see the full path of plugins on the about:plugins page.

It is best not to leave that pref set to true as it exposes that full path to web servers, so reset that pref to false after you are done with the about:plugins page.

Question owner

No, after installing it 3 times, it does not appear in plugins. I assumed this was because it is 64 bit, but apparently it is due to some other issue. As I said, I am not the only one with this problem - someone else asked and the question was not answered. Unlike FF, IE installs the plugin automatically, and in a few seconds it was working. And yes, after searching FF help for 1/2 hour to try to determine my build, I in fact do have a 32 bit - I interpreted WOW64 as 64 bit - silly me. God forbid it, like Windows, should simply say 32 or 64 bit without being so cryptic. If FF had even dismal help, I should have been able to find that answer immediately. FF help is a confused jumble of nonsense, without even the most basic features like segregating help for old versions or even for Mac and Windows. I am only responding here to be polite to people who are trying to help, but honestly, I see absolutely no reason to have FF on my computer - my everyday needs are met better with Chrome, and for Scorch I'll use IE. What a pleasure not having to wade through the morass of FF help.

bloatee 0 solutions 1 answers

@kazar You haven't said what your OS Version is either. 10.6 ? 10.7 ? 10.8 ?

I thought MacOS was 64-bit ONLY in the latest release ? Is that your problem ?

Modified by bloatee

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96832 answers

Note that the OP that started this thread is using Windows 7 (see the system details).

If you have issues on a Mac then please start a new thread about your problem or question to avoid confusion.

As already stated, on Mac Firefox is a 64 bit application that may need to be started in 32 bit mode if a plugin needs to be used that only runs in 32 bit mode.

On all other platforms (Windows, Linux) Firefox comes as a 32 bit application by default although there are 64 bit builds available, especially for Linux. The 64 bit builds for Windows are only experimental and meant for testing the compiler and make sure that the compilation finishes properly.

kazar 0 solutions 6 answers

I'm fully conversant in how to start FF in 32-bit mode. The problem must have been on Netflix's end ... I discovered after switching my user agent (using User Agent Switcher add-on) their movies played just fine. I think they had coded the FF version check improperly and more importantly it seems that they have fixed the problem, at least for Mac, since Netflix started playing movies again in my browser (even with the actual version number of FF in my user agent string) as suddenly as it had stopped. Just the same, thanks for all the responses.

Marco91 0 solutions 1 answers

I also had trouble getting the Scorch plugin to work in Firefox 32-bit running under Windows 7 64-bit. I fixed it by creating a key named Sibelius/Scorch under MozillaPlugins, and then adding a String variable that points to the installation folder of the Scorch plugin for Firefox

HKEY_CURRENT_USER\Software\MozillaPlugins\Sibelius/Scorch Path="C:\Program Files (x86)\Sibelius Software\Scorch\Netscape\NPSibelius.dll"

The plugin now appears in Firefox->Addons. I guess this is a problem with the Scorch installer

Question owner

Thanks for your help, but I've long since moved on to IE, that works instantly and seamlessly with scorch. Someday maybe I'll try FF again, but can't think of a reason right now.