Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Updated to Firefox 14 and now some websites don't work.

  • 9 replies
  • 14 have this problem
  • 6 views
  • Last reply by Cyprian

more options

I updated to FF 14 for Android (NOT the beta version). Now schedulesource.com doesn't work after I log in. The images are broken and links on the site won't open no matter how many times I tap on them. I've included a screenshot. The site still works fine on the stock browser. I've tried the Phony add-on and changed it to Android but it doesn't help at all. Please let me know how to solve the problem. Thanks.link text

All Replies (9)

more options

Hey there,

In Firefox 14 (the brand new version from Google Play) we altered the way in which we broadcast to websites who we are (using a user-agent). It's very possible that ScheduleSource has underlying scripts that are failing to properly identify Firefox for Android and is this breaking their site.

I don't have an account to check to see if this is an issue on ScheduleSource, but there is something you might be able to try.

Can you try installing the Phony add-on for Firefox on Android by visiting the site on your phone: https://addons.mozilla.org/en-us/android/addon/phony/, downloading and installing that.

Once installed, you can change your user-agent through Phony in the browser menu to desktop Firefox or Android or even the iPhone. This tricks the site into believing that Firefox for Android is on a different platform or another browser on the same or different platform. Doing so may yield better results than what you see by visiting the site right now.

Hope that helps,

As always, we can look further into the matter should you choose by filing a bug on Bugzilla to continue investigation.

more options

I tried every user agent; desktop, android tablet, iphone, ipad and nothing works. The page looks slightly different when the user agent is changed but the images are still broken and links don't work.

more options

It's very possible that the site simply isn't optimized for mobile content whatsoever.

Have you tried using the Android Browser that comes with your phone? Are the results the same or different?

Unfortunately, as mentioned, I don't have a login to check the website.

more options

Yes like I mentioned above. The site works fine in the stock browser.

more options

Hi sweetrosie, I have similar issue with latest Firefox. My config is Android 4.0.3 Samsung Galaxy S2 and Firefox14. After update it doesn't open any site from awesome bar

more options

Cyprian, can you please add your findings to bug 769269

more options

AaronMT, thanks for that link, that bug looks familiar. Should I do something with that link? Add comment or vote somewhere?

more options

Please add a comment indicating your device, android version and what you are experiencing too please.

more options

ok, done