Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox will not load any web pages since update

  • 7 replies
  • 17 have this problem
  • 1954 views
  • Last reply by stavros27

more options

Using Galaxy Nexus, installed update today. I have ICS version 4.0.1. Pages will not load at all. Even the firefox pages on the home page will not load. I verified with using both wifi and my network, and checked the stock browser from the phone which works, but no success with Firefox. I uninstalled Firefox, restarted my phone, re-installed, and the same issues are happening. Any idea how to get this back to normal?

All Replies (7)

more options

Update..when I open firefox from scratch, the main firefox pages on the home page seem to work. But as soon as I try to go anywhere else, IE going to a website in the address bar or even trying to access the defauly bookmark links, it just sits there loading but never brings anything up.

more options

Would it be possible for you to create an account in our bug tracker at Bugzilla, and file a bug here: https://bugzilla.mozilla.org/enter_bug.cgi?product=Fennec%20Native - in the bug I'll assist with you in getting some logs that may help to determine the issue.

Modified by AaronMT

more options

I have this exact problem with ICS 4.0.4 on my Google Nexus S 4G (Sprint). Doesn't load anything, not even about:firefox. Don't think this release was tested at all.

It works fine on my friend's Google Nexus S (GSM on Tmobile). Build versions are identical.

more options

Jsheehy, can you please add your findings to bug 769269

more options

Can you please check to see wether you have the setting 'Don't keep the activities' enabled in Developer options in your Android settings? If so, please disable it and try Firefox again.

This setting should not be enabled.

more options

That did the trick. Turned the setting off and it works perfectly now. Thanks a lot Aaron!

more options

And I believe this setting you said to turn off fixed another issue I was having with a different app on my phone..I just tried it and it works properly, where beforehand it was giving the wrong location info every time. Thanks again!