Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Empty windows appear in Recently Closed Windows list

  • 8 replies
  • 4 have this problem
  • 181 views
  • Last reply by nevermind

more options

I just recently upgraded to Firefox 13.0.1. (It seems that there may have been two updates on the same day or in very short succession, but I am not sure of it. I may be recalling upgrades to multiple instances of Firefox, all to this same version. Thus, it *might* be the case that this problem cropped up with this version or with a very recent previous version.)

Since the upgrade, empty windows appear in the Recently Closed Windows list (RCWL). I try to keep the list uncluttered, so when I am finished with a window holding sites that I am sure I don't want to go back to, I close all the tabs in the window, leaving an unused New Tab***, then close the window. Such windows should not be included in the RCWL, but they are, now.

[*** I set new tabs to about:blank so that they will not load any pages automatically.]

Since this change in standard behavior comes with an upgrade, and since I can not find any reference to it elsewhere, including Mozilla Support, I suspect that it may be a new bug.

In troubleshooting, I tried clearing the Recently Closed Tabs list in such windows as well. I have never had to before, but it seemed worth trying, and like something that may have become relevant. I was thinking that perhaps a window would not "register as truly empty" if there were Recently Closed Tabs in the list. This tactic did not work.

I also tried starting Firefox in Safe Mode, reopening all of the RCWL, closing each one's only tab -- a 'New Tab' in every case -- then closing each window. They still appear in the RCWL.

Please let me know if I can (or need to) provide more information. Thanks for any help!

Modified by C.V.

Chosen solution

Try to set the browser.newtab.url pref to about:blank if you currently aren't using this setting.

Read this answer in context 👍 3

All Replies (8)

more options

Chosen Solution

Try to set the browser.newtab.url pref to about:blank if you currently aren't using this setting.

more options

Hi pootmonkey, can you find any correlation between blank windows and certain kinds of pages or downloads? For example, shift-clicking a link to a download (e.g., a DOC file, or depending on your configuration, a PDF) will open a new window. Firefox usually recognizes that it's a download, closes the blank window, and presents the Open/Save/Cancel dialog.

I misread your scenario.

Modified by jscher2000

more options

@ COR-EL: Thanks. I actually already always do this by default (in all browsers). I always like a new window/tab to be blank so that it doesn't waste time loading something I may not use. (However, this forces me to note "aloud" that I do have this instance of Firefox re-load all my open windows/tabs from the last session so that I can continue doing what I had been doing before.)

With thanks to you, I just edited my main post to reflect this information explicitly for future readers; I'd said "unused tabs", but some users might think of a new tab as "unused" if they don't do anything to it themselves, even if they have some non-blank home page come up by default :) .

Modified by C.V.

more options

Yipee! Cor-el, your suggestion solved the problem for me. I have 3 computers and use the recently closed windows feature extensively, so this little bug posted by pootmonkey was quite an annoyance for me as well. Thanks a million for the fix.

more options

COR-EL:'s answer fixed the problem, and I have both edited my replies above to reflect this, and marked this problem solved. COR-EL, thanks again!

(Thank goodness for NEVERMIND, who followed those instructions and said they fixed the same bug. That made me take a look at what I thought was unnecessary. A case of knowing a little too much for my own good, I think. I already had tabs coming up blank [or seemingly so], so I wonder if this is a new setting, or an old one that suddenly made a difference in how the RCWL behaves, or ... Well, I wonder stuff.)

more options

To all- FYI I checked my older W2K computer (i know-ewww!) and it only updated as far as FF 12, so I checked the about:config setting for "BROWSER.NEW.URL" and it is set by default to about:blank. I guess our little problem in this post was new to 13.0.1 and possibly 13.0 but (shrugs) we may never know. At least I'm glad for this post from pootmonkey that prompted the fix from Cor-l.

more options

The about:newtab page is hardly working in Firefox 12 (the coding wasn't finalized) and thus wasn't enabled by default. You can see that if you open the about:newtab page.

more options

for what it's worth, Core-el, I did that just to see. LOL! then I was stuck with a "new tab" in the "Recently closed tabs" of the open window that I couldn't get rid of by just closing the tab. the NEW "newtab" has the little enable button in the upper right hand corner to see a bunch of unwanted "saved tab pictures" which I find to be nightmarish (i.e.- open email pages, open bank pages, etc.). I like the OLD "new tab" which will just go away when you close it.

The workaround to rid myself of the new tab (about:newtab), I mouse-moved the whole tab out of the window to it's own new window, which I then successfully deleted.

I think this about:newtab is a troubling new feature and am glad for your fix mentioned in the previous posts.