Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

.swf is only working with IE, despite my posession of the flash players.What gives?

  • 17 replies
  • 5 have this problem
  • 1080 views
  • Last reply by Thurgax

more options

The application tab under Tools -> Options does not register swf.In addition, Downloaded files only recognize IE for a suitable playing platform.

Chosen solution

Oddly enough, It works when i do open file..But direct access from the folder is a no-go.Basically, I consider this irritable, But solved.I will pop up again if that stops working too.Thanks.

Read this answer in context 👍 0

All Replies (17)

more options

Try to delete the mimeTypes.rdf file in the Firefox Profile Folder to reset all file actions.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder
more options

Download Adobe Shockwave Flash player at http://get.adobe.com/shockwave/ http://get.adobe.com/shockwave/ People with 64-bit Vista experienced problems for some time when Adobe stopped supporting 64 bit Vista. They have recently updated the 64 bit player and I am currently using it on my Vista machine. I have also discovered that some Windows 7 updates work on my Vista machine when Vista plug-ins are not available. Be aware, however, that the 4/13/2012 Adobe pdf reader update is causing major trouble for my Vista machine.

more options

Do not confuse the Shockwave (Shockwave for Director) and the Shockwave Flash players.
That are two different players and the Shockwave for Director player is not much used these days (there are Shockwave games).

more options

I didn't think I had confused them -- I have both. And this is how I corrected my problems on Vista. But I really appreciate the advice and will read these support pages. Thanks cor-el; I appreciate the amount of time you spend giving us support.

more options

Okay..It also says it is not a valid win32 application when i attempt to run them.So i delete my current copies, mimetypes and redownload?

more options
more options

No luck with that.I can bring them up normally online.Issues come when i download them.

more options

It is possible that your anti-virus software is corrupting the downloaded files or otherwise interfering with downloading files by Firefox.
Try to disable the real-time (live) scanning of files in your anti-virus software temporarily to see if that makes downloading work.

See "Disable virus scanning in Firefox preferences - Windows"

more options

Attached is what the downloaded swfs look like..They seem to be recognised as shockwave flash.Should i remove that player?

more options

Edited: I googled one of them and, from the several sites that popped up with the supposed download I got porn I couldn't see and what seems to be a virus.

50 minutes later: I see now it also eliminated my Adobe Flash plug-ins although shockwave for director is still there.

You may want to also start scanning for a virus.

Modified by shelleyowens

more options

The site used in my case is swfchan.I used it on a previous computer without adverse results.The issue is playing them once downloaded.

more options

Did you try to delete the mimeTypes.rdf file?

Are you sure that you aren't saving a Flash player that needs to download additional files from the server?

more options

I deleted the sonny 2 flash file and redownloaded after deleting the mimeTypes.rdf file.There is only the swf file downloaded without extras.My problem is the error message appearing when i try to run the file offline in firefox, As the attached image shows.

more options

Can you open that file in Firefox via New Tab > Open file or File > Open File ?

more options

Sorry you're still suffering with this issue. After I undid the problems associated with the website that corrupted my flash player, I uninstalled flash and re-installed it from adobe. Although I had flash I didn't have audio so I went to my chip manufacturer site, AMD, did the driver auto-detect, http://support.amd.com/us/gpudownload/windows/Pages/auto_detect.aspx, installed the latest drivers and everything is working fine now.

in addition to corrupting my flash add-ons, the website's virus may have corrupted my drivers, too -- just guessing.

I hope this helps but, if it doesn't, maybe it will help someone else with a flash or no audio problem.

more options

My tendency is to run it from the folder..As for your suggestion shelly..I will attempt both when at my laptop again.Much thanks.

more options

Chosen Solution

Oddly enough, It works when i do open file..But direct access from the folder is a no-go.Basically, I consider this irritable, But solved.I will pop up again if that stops working too.Thanks.