X
Tap here to go to the mobile version of the site.

Support Forum

How can I STOP the TABS from Automaticly Expanding to the right?

Posted

I don't like several new features. 1) It is extremely difficult to tell which TAB belongs to the page I'm viewing. This causes me to constantly close the Wrong Page. 2) When I do close a Tab, the remaining Tabs expand to fill the "Tab Bar" leaving No Blank Space.

I don't like several new features. 1) It is extremely difficult to tell which TAB belongs to the page I'm viewing. This causes me to constantly close the Wrong Page. 2) When I do close a Tab, the remaining Tabs expand to fill the "Tab Bar" leaving No Blank Space.

Chosen solution

Hi,

You can try a different theme for Firefox that provides a greater contrast between the active and inactive tabs: https://addons.mozilla.org/en-US/firefox/themes/ Please note that some of the themes have a thinner tab bar and may diminish the height of the tab bar.

or

You can try the add-on ColorfulTabs without changing the theme. It has an option to fade the inactive tabs. Please note that ColorfulTabs may have issues when used with other Firefox themes.

You can prevent filling the tab bar to an extent by using the Pin as App Tab feature. Right-click on a tab and choose Pin as App Tab. To unpin, right-click on the pinned tab and choose Unpin Tab.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • The Adobe Reader plugin is used to enable viewing of PDF and FDF files from within the browser.
  • Shockwave Flash 11.1 r102
  • MozPlugger version 1.14.3, maintained by Louis Bavoil and Peter Leese, a fork of plugger written by Fredrik Hübinette.For documentation on how to configure mozplugger, check the man page. (type man mozplugger) Configuration file:/etc/mozpluggerrc Helper binary:mozplugger-helper Controller binary:mozplugger-controller Link launcher binary:mozplugger-linker
  • The next generation Java plug-in for Mozilla browsers.
  • mplayerplug-in 3.55Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer JavaScript Enabled and Using GTK2 Widgets

Application

  • User Agent: Mozilla/5.0 (X11; Linux i686; rv:8.0) Gecko/20100101 Firefox/8.0

More Information

Vivek 289 solutions 2084 answers

Chosen Solution

Hi,

You can try a different theme for Firefox that provides a greater contrast between the active and inactive tabs: https://addons.mozilla.org/en-US/firefox/themes/ Please note that some of the themes have a thinner tab bar and may diminish the height of the tab bar.

or

You can try the add-on ColorfulTabs without changing the theme. It has an option to fade the inactive tabs. Please note that ColorfulTabs may have issues when used with other Firefox themes.

You can prevent filling the tab bar to an extent by using the Pin as App Tab feature. Right-click on a tab and choose Pin as App Tab. To unpin, right-click on the pinned tab and choose Unpin Tab.

Hi, You can try a different theme for Firefox that provides a greater contrast between the active and inactive tabs: https://addons.mozilla.org/en-US/firefox/themes/ Please note that some of the themes have a thinner tab bar and may diminish the height of the tab bar. or You can try the add-on [https://addons.mozilla.org/en-US/firefox/addon/colorfultabs/ ColorfulTabs] without changing the theme. It has an option to [https://www.binaryturf.com/free-software/colorfultabs-for-firefox/colorfultabs-documentation-and-help/#3 fade the inactive tabs]. Please note that ColorfulTabs may have issues when used with other Firefox themes. You can prevent filling the tab bar to an extent by using the '''Pin as App Tab''' feature. Right-click on a tab and choose '''Pin as App Tab'''. To unpin, right-click on the pinned tab and choose '''Unpin Tab'''.

Modified by Vivek

Question owner

What I want is for the open Tabs, which I usually have at least 6 open at once, is to Stop the Tabs from growing wider to take up all of the space for tabs.

What I want is for the open Tabs, which I usually have at least 6 open at once, is to Stop the Tabs from growing wider to take up all of the space for tabs.
Jack 16 solutions 78 answers

Hi,

Try adding a Space(s) or a Flexible Space(s) to the right of your tabs.

How do I customize the toolbars?

Jack

Hi, Try adding a Space(s) or a Flexible Space(s) to the right of your tabs. [[How do I customize the toolbars?|How do I customize the toolbars?]] Jack

Question owner

Thanks, but how do I do that. There is no empty space to click on.

Thanks, but how do I do that. There is no empty space to click on.

Question owner

How do I stop the tabs from taking up all of the "TAB" Bar?

How do I stop the tabs from taking up all of the "TAB" Bar?
Jack 16 solutions 78 answers

Right click on thin line below the Awesome Bar (URL Bar).

Right click on thin line below the Awesome Bar (URL Bar).
Vivek 289 solutions 2084 answers

Right-click on the left edge of the Address Bar over the icon for the currently loaded web page and choose Customize.... For eg. if it's this site it would usually be the Firefox icon with the text mozilla.com on the right. In the mini window that opens, look for the item Flexible Space, left click on it and hold and drag it and release it on the Tab Bar when the circle with the slanting line turns into a small rectangle. If the Tab Bar is full, release it over the rightmost tab.

Thanks jack013 for an easy and elegant solution for the Tab Bar.

Right-click on the left edge of the '''Address Bar''' over the icon for the currently loaded web page and choose '''Customize...'''. For eg. if it's this site it would usually be the Firefox icon with the text '''mozilla.com''' on the right. In the mini window that opens, look for the item '''Flexible Space''', left click on it and hold and drag it and release it on the Tab Bar when the circle with the slanting line turns into a small rectangle. If the Tab Bar is full, release it over the rightmost tab. Thanks jack013 for an easy and elegant solution for the Tab Bar.

Question owner

When I release the "Flexible Space" Icon over the rightmost Tab, it just "Flies" back to the Customize Window. I have Firefox 3.6.24.

When I release the "Flexible Space" Icon over the rightmost Tab, it just "Flies" back to the Customize Window. I have Firefox 3.6.24.

Modified by ichido

Vivek 289 solutions 2084 answers

I'm using another version, but I think there won't be much difference in the UI. At first you'll usually see a black circle with a line. Until that changes to a small rectangle or disappears, it means that it is not ready to be placed and will fly back.

I'm using another version, but I think there won't be much difference in the UI. At first you'll usually see a black circle with a line. Until that changes to a small rectangle or disappears, it means that it is not ready to be placed and will fly back.

Question owner

Vivek.Wilfred wrote:

Right-click on the left edge of the Address Bar over the icon for the currently loaded web page and choose Customize....

There is No space on the left edge to Right-click on.

When I Right-click on the Address Bar over the icon for the currently loaded web page and choose Customize....

There is no Customize.... option.

Vivek.Wilfred wrote: Right-click on the left edge of the Address Bar over the icon for the currently loaded web page and choose Customize.... There is No space on the left edge to Right-click on. When I Right-click on the Address Bar over the icon for the currently loaded web page and choose Customize.... There is no Customize.... option.
Vivek 289 solutions 2084 answers

Hi,

I've attached a screenshot. You may be right. The options could be different between the Firefox versions.

Please also see this.

Hi, I've attached a screenshot. You may be right. The options could be different between the Firefox versions. Please also [https://support.mozilla.com/en-US/kb/how-do-i-customize-toolbars see this.]
the-edmeister
  • Top 25 Contributor
  • Moderator
5108 solutions 37660 answers

Your original posting here was using Firefox 8.0, but now you say you have Firefox 3.6.24. Which version do you actually have this problem with?

Versions before Firefox 4.0 don't have the Tab Bar as a normal toolbar, the "tab strip" occupies the entire Tab Bar. You can't add anything to the Tab Bar in those older versions, as you can with the later versions.

Your original posting here was using Firefox 8.0, but now you say you have Firefox 3.6.24. Which version do you actually have this problem with? Versions before Firefox 4.0 don't have the Tab Bar as a normal toolbar, the "tab strip" occupies the entire Tab Bar. You can't add anything to the Tab Bar in those older versions, as you can with the later versions.

Question owner

Both. I have several different Linux Distros that I use. One is Ubuntu 10.04.2, PCLinuxOS-KDE 2011 and Fuduntu 14. Thanks for the reply.

Both. I have several different Linux Distros that I use. One is Ubuntu 10.04.2, PCLinuxOS-KDE 2011 and Fuduntu 14. Thanks for the reply.