Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I stop xfce4-notify from popping up after downloads?

  • 1 reply
  • 1 has this problem
  • 87 views
  • Last reply by hvgriggs

more options

I'm running Linux with fvwm. It's not a desktop, it does not handle notifications. After downloads finish, a dialog box pops up with title xfce4-notify, and contents "Downloads Complete - All files have finished downloading" and a button "Activate". While I download, I switch windows and work on something else. This dialog box appears in the window where Firefox is running, and focus switches back to that window interrupting me. It's frustrating. How do I stop these notifications? I looked in about:config and found nothing about xfce. I edited preferences and turned off the download windows, but that doesn't stop the notifications. This behaviour started after I left Firefox version 3, and it's been on every version since. Now running 8.0.

Chosen solution

I used Google and found a great blog entry at http://ilias.ca/blog/2005/11/turn-off-the-downloads-complete-alert-in-firefox/ which shows how to turn off the alerts.

Go to about:config, search for this entry - browser.download.manager.showAlertOnComplete - and toggle it to false.

I did it, tested it, it works. Frustration level reduced to zero.

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

I used Google and found a great blog entry at http://ilias.ca/blog/2005/11/turn-off-the-downloads-complete-alert-in-firefox/ which shows how to turn off the alerts.

Go to about:config, search for this entry - browser.download.manager.showAlertOnComplete - and toggle it to false.

I did it, tested it, it works. Frustration level reduced to zero.