X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Anchor links do not work

Posted

Ever since starting with the FF4 beta (and now into the stable build), any time I click on a link that goes to a different part of the page (an anchor link), absolutely nothing happens.

From what I can tell, it looks like FF4 and up does not support anchor links? This seems to happen everywhere I try. Just inconvenient...especially with Table of Contents in emails.

Additional System Details

This happened

Every time Firefox opened

This started when...

FF4 beta was released

Installed Plug-ins

  • ActiveTouch General Plugin Container Version 105
  • Google Update
  • Shockwave Flash 10.3 r181
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.60310.0
  • Bing Bar
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0

More Information

Any link that is supposed to put you down somewhere else on the page.

David McRitchie 321 solutions 3089 answers

I have no problem coding links with a fragment-id do these fail for you?

If the problem is solved, please indicate what the problem was.

If the problem is not solved, please provide example url and where to click, and what version of IE that you are using.

Question owner

You know, I was doing some more troubleshooting on my end, and it looks like I did speak too soon on ALL anchors not working. Regular ones work fine. The ones I'm working in are actually within a web program using alot of Java.

Now, it didn't always give this issue. All versions of Firefox before 4 let these anchor links work in the page...FF4 seems to keep it from happening.

Because it's working in an a website that requires login information, I'll go ahead and abandon this thread. I'll try to solve it on my own time. But thank you for the help!

plughie 0 solutions 1 answers

I have the same problem in FF10 and FF13 when the anchor and url reference are both in the same frame. When I open the frame in a new tab, the anchor link works.