X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I make Firefox my default browser on an Android device (Motorola Atrix 4G, through AT&T)?

Posted

I have installed Firefox 4 on my Android smartphone (Motorola Atrix 4G); AT&T is the carrier. Indeed the fact that the Atrix can use Firefox as a browser is one of the main reasons I bought the Atrix. But how do I make Firefox the default browser? I don't even know what the current default browser is. Thanks. Jim [4-19-11]

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

Matt Brubeck 147 solutions 1390 answers

Helpful Reply

If you don't have a default browser set already, then Android will prompt you to set one when you open a link from another application.

If you do have a default browser set (or if you're not sure), then open Android's "Settings" app, choose "Applications: Manage Applications: All." Then tap on your current default browser (probably the built-in Browser app), and press the "Clear defaults" button.

Question owner

Thank you. Android did not prompt me to set a default browser (at least I don't remember that). When I go to Settings, there is "Applications: Manage Applications" but not "Applications: Manage Applications: All." Firefox is on the list of applications. On the home screen there is an icon (apparently the earth with a green ring around it but I cannot tell what the default browser is.

Matt Brubeck 147 solutions 1390 answers

Helpful Reply

After choosing Manage Applications, there should be four tabs across the top of the screen, which let you view different sets of apps like "Third party" (or "Downloads"), "Running," and "All." To manage the built-in Browser app, you will need to switch to the "All" tab on the Manage Applications screen.

DrewMeister 0 solutions 1 answers

I've done this and when I get to the Google Search tab and click on it the bottom says No Defaults Set, so I can't clear them. Please help

Matt Brubeck 147 solutions 1390 answers

DrewMeister, instead of choosing Google Search from the list of apps, choose "Browser" (or whatever the name of your current default browser is).