Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox isn't prompting me to save my open tabs before quitting. This is extremely frustrating. I have the setting checked off to prompt me before closing multiple tabs but it is closing without prompting me.

  • 3 replies
  • 43 have this problem
  • 186 views
  • Last reply by BethF123

more options

I just updated to Firefox 4.0. I had several tabs saved but when I installed this new version, it won't prompt me to save the tabs before quitting. When I relaunch the application, no tabs have been saved. I set my preferences to prompt me when closing multiple tabs but it isn't working.

I just updated to Firefox 4.0. I had several tabs saved but when I installed this new version, it won't prompt me to save the tabs before quitting. When I relaunch the application, no tabs have been saved. I set my preferences to prompt me when closing multiple tabs but it isn't working.

All Replies (3)

more options

One change in Firefox 4 is to by default stop Firefox displaying the warning message, but it can be turned back on by changing some preferences.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference browser.tabs.warnOnClose, if its value is set to false, double-click on it to change its value to true
  4. Repeat this for these 3 preferences browser.warnOnQuit, browser.warnOnRestart and browser.showQuitWarning

If you always open the last set of tabs, an alternative approach is this:

  1. Click the orange Firefox button, then select options to open the options window
  2. Go to the General panel
  3. Change the setting "When Firefox starts" to "Show my windows and tabs from last time"
more options

The described fix seems to work fine, and I appreciate the fast response. You might also point out that under History there is a Restore Previous Session option that will recover the bookmarks. Thank you for this!

Firefox developers, I've been a developer myself. Setting the default to not save tabs in Firefox 4 is going to make a lot of people VERY angry.

I'm a fairly educated user. After upgrading, the first thing I did was to check Preferences and try to make sure all settings were good to maintain what I've been accustomed to doing. I didn't take the Firefox 4 tour, but shut down the application to make sure caches were emptied. There was no warning about my multiple tabs, but it was too late to stop the process. When I opened it again, all my tabs were gone. As stated, Recover Previous Session brought them back, but a lot of people will not look for or find that function at once.

For everyone's sanity, please don't turn off the Preserve Tabs on Logout function without warning.

more options

Thanks, Tony! I appreciate the reply. Your suggestions worked great. Thanks also to Andrew for the further suggestion about restoring previous session. Unfortunately, I tested it a few times with new tabs after having lost my original ones so it won't restore properly. Lost a few hours of work, Firefox developers! Not cool.

Modified by BethF123