X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

i can not install userscripts

Posted

i can't create another profile through either terminal either.

i get this error

Error: uncaught exception: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIAlertsService.showAlertNotification]" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: resource://greasemonkey/GM_notification.js :: GM_notification :: line 22" data: no]

& i get this error "dyld: unknown required load command 0x80000022 Trace/BPT trap" in terminal when i try to create a new profile

Additional System Details

Installed Plug-ins

  • iPhoto6
  • DivX Web Player version 1.4.1.4
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • 3.0.40818.0
  • Reader Library Helper Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Java Plug-In 2 for NPAPI Browsers
  • Shockwave Flash 10.1 r102

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

nickolay 4 solutions 45 answers

1) It would help to know your Greasemonkey version. Do you have Growl (the notification utility) installed? I didn't find a definitive answer, but it seems that not having it installed or having it installed, but not running may cause the error you report, at least with some versions of GM: https://developer.mozilla.org/en/XPCOM_Interface_Reference/nsIAlertsService https://github.com/greasemonkey/greasemonkey/issues/1264

2) The dyld error is a known issue with Firefox 4 on Leopard. See http://asqueella.blogspot.com/2010/12/dyld-unknown-required-load-command.html for the workaround.

Modified by nickolay