X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Java does not work in Firefox 4 whereas it work fine in Firefox 3.6 which had java v. 1.4.1 embedded but Firefox 4 does not. Any suggestiions?

Posted

Firefox 4 will not run a Java app on my brokers website. It tells me I have a missing plugin and gives the option to download plugin. I try that then it says no suitable plugins were found and suggests I manual install java applet v. 1.4.1. This java version was last used in mac OS 10.4. I use OS 10.6. I note that Firefox 3.6 had this version embedded which allowed it to use the newer versions of Apple Java applets whereas Firefox 4 does not.

Chosen solution

I just found the solution! See this page: http://www.emanuelis.eu/2010/06/17/how-to-manage-firefox-plugins-in-pluginreg-dat-file/

Just add a new line for x-java-applet with version 1.4.1 (and increase the counter) to your pluginreg.dat. Now I have the TD Ameritrade Command Center running in Firefox!

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • iPhoto6
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Speed Download Plugin. Allows downloads to be redirected to Speed Download
  • 4.0.51204.0
  • Java Plug-In 2 for NPAPI Browsers
  • Shockwave Flash 10.2 r152
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

Trouble shooting does not cover this problem.

krypter 0 solutions 1 answers

Hi. Try to reintall or intall the Java Version 6 Update 24.

Question owner

I reinstalled Java Version 6 Update 24 but FF4 is still looking for version 1.4.1. This version is still available on Apple's download list and I could be wrong but I don't believe it will install on Intel Macs. It was used with Panther (OS 10.3). I reverted to FF 3.6 which has it embedded in the browser. Thanks anyway.

mathdude 0 solutions 2 answers

Helpful Reply

I found that if I install the up to date java embedding plugin that I could Java to work. I didn't even know there was a newer version. Here is the link to it http://sourceforge.net/projects/javaplugin/

This is the site Mozilla mentions in a help file concerning Java. Basically you will download it and then install two binary files. The readme that comes with the download explain it.

Question owner

Are you sure this works in Firefox 4? The readme.txt that came with the download you mentioned says "The Java Embedding Plugin currently isn't compatible with (and isn't bundled with) Firefox 4 (currently available only in pre-release builds). I'm working on a version of the JEP that will be compatible with Firefox 4."

Further, the readme.txt appears to address the replacement of older versions of the embedding plugins with the newer version. I checked the package contents of Firefox 4 and it does not have any enbedding plugins to replace.

mathdude 0 solutions 2 answers

Helpful Reply

Well, it's what I did to get my Java working in Firefox 4. I installed both binaries into my Library/Internet Plug-ins folder. The version was newer that what was previously installed (newer version is 0.9.7.5). It solved the Java problems I was having. My inital problem was that Java would not initiate and no applets would run in Firefox version 4 which I just installed a few days ago. I know the readme.txt. says it is not compatible with version 4, but the release date on 0.9.7.5 is after the release date of Firefox 4 and so that was I tried it. I figure there was nothing to lose as at worst it woud update my two plug-in files. Nothing was going to be changed otherwise. If you try it, it might work.

Question owner

I have finally found the time to try your suggestion. The binaries loaded ok in FF4 and it no longer spits out the missing plugin message. Unfortunately it still will not load my target java applet. It does load the launch page and gives a brief message that it is transferring data but that's it, nothing else. I replaced the newer version of the Java Embedding Plugin with the older version and got identical results. So I'm guessing that the newer JavaEmbeddingPlugin.bundle does not include an upgraded version of the particular plugin required by my target java applet. From previous messages I've seen during this process, I'm guessing it is v. 1.4.1.

Thanks for your suggestion, it was worth a try.

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97065 answers

Does it help if you run Firefox 4 in 32 bit mode?

  1. Close Firefox
  2. Open the Applications folder in Finder
  3. Right click or control-click the Firefox.app icon
  4. Select "Get Info"
  5. Select "Open in 32-bit mode"
  6. Close the "Firefox Info" window
  7. Restart Firefox
AliceWyman
  • Moderator
191 solutions 1969 answers

More information on cor-el's suggested workaround, from http://www.mozilla.com/firefox/4.0/releasenotes/
Firefox on Mac OS X running in 64-bit mode does not recognize that Java supports certain MIME types. Running Firefox in 32-bit mode has been found to help (see bug 638171)

From bug 638171 comment 13:

Benjamin Smedberg [:bsmedberg]      2011-03-21 13:57:15 PDT

relnote: "Firefox on Mac OS X running in 64-bit mode does not recognize that Java supports the MIME type 'application/x-java-applet;version=1.6', which may cause some sites, including skandiabanken.no to stop working or ask you to upgrade Java, even though it is already up to date. Workaround: run Firefox in 32-bit mode

Note that this bug will be fixed in an upcoming Firefox 4 update.

Question owner

I get the same results in 32 bit mode as in 64 bit mode. The target java applet still does not load. Thanks for the suggestion though.

Question owner

More info. I am trying to run TD Ameritrade's 'Command Center'. Without the 2 embedding binaries (v.0.9.7.5) installed in Library/Internet Plugins I get a missing plugins message. I click on the install button I get 'No suitable plugins were found.' followed by 'Unknown Plugin (application/x-java-applet; version = 1.4.1). I don't get these messages with the embedding binaries installed but it still does not load. I ran TD Ameritrade's trouble shooting program. It found Java enabled but not compatible and recommended installing the latest version. Of course Apple's latest version of the java plugin is already installed. I know the Apple and the embedding binary bundles include a version of 1.4.1. Some how neither FF4 nor Ameritade recognizes it. But this is just a guess on my part.

Thanks for your interest and suggestion.

emrys7 0 solutions 2 answers

I've had the same problem using Firefox 4 on my Intel Mac with OSX 10.6.7, and confirm that the issue was solved by opening in 32 bit mode. In 64 bit mode I was getting the missing plugins message and "No suitable plugins found" message.

slfirefox 1 solutions 2 answers

@sheltontx: I just found this thread. I am also trying to run TD Ameritrade's Command Center on Firefox 12 on Mac OS X 10.7.4! Based on everything I've checked, I have the latest Java installed on this machine, and the Command Center does load perfectly fine when I log in using Chrome.

But Firefox gives me the "A plugin is need to display this content" and then the error about version 1.4.1. I typed "about:plugins" into Firefox, and it showed a bunch of different Java versions, but no 1.4.1. Did you ever fix this problem?

Question owner

No I did not and I've tried all suggested solutions and the many Firefox revisions. After several revisions Mozilla has failed to fix the problem. I use Safari with no plugin problems.

Modified by sheltontx

slfirefox 1 solutions 2 answers

Chosen Solution

I just found the solution! See this page: http://www.emanuelis.eu/2010/06/17/how-to-manage-firefox-plugins-in-pluginreg-dat-file/

Just add a new line for x-java-applet with version 1.4.1 (and increase the counter) to your pluginreg.dat. Now I have the TD Ameritrade Command Center running in Firefox!

Question owner

Thanks, your solution works! I'm back on Firefox.