X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Speedbit hijack's my homepage

Posted

http://search.speedbit.com/ keeps hijacking my home page.

I have removed it from my PC but Firefox will NOT let me change it to my.yahoo.com! Once I deleted Speedbit, I was able to fix Chrome and IE. Just NOT Firefox.

Additional System Details

Installed Plug-ins

Adobe Acrobat Coupons Inc., Coupon Printer Manager DivX Player Netscape Plugin DivX Web Player DNA Plug-in Google Earth Plugin Google Update Google Updater Java Deployment Toolkit 6.0.240.7 Java(TM) Platform SE 6 U24 Microsoft® Windows Media Player Firefox Plugin Move Streaming Media Player Pando Web Plugin Picasa QuickTime Plug-in 7.6.9 RealPlayer Version Plugin RealPlayer(tm) G2 LiveConnect-Enabled Plug-In (32-bit) Shockwave Flash Silverlight Plug-In VLC Multimedia Plug-in Winamp Application Detector Windows Genuine Advantage Windows Live Photo Gallery WPI Detector 1.1 Yahoo! activeX Plug-in Bridge

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/534.16 (KHTML, like Gecko) Chrome/10.0.648.151 Safari/534.16

More Information

hehe_br 0 solutions 3 answers

Hello! This nasty thing irritated me a lot! Here is the solution!

http://www.speedbit.com/faq/#faq32

Download their browser cleaner!!! This is the only way to set your default settings!

I hope this help you too!!! Enjoy your Firefox now!!!

=]]

Question owner

That does not work... It resets your home page to search.google.com and you still can not change it to anywhere else.

zulfi24 0 solutions 1 answers

hi, i had the same problem, but its solved now.

All you got to do is: 1. go to: c:\user\'username'\appdata\roaming\mozilla\firefox\'profileName'\ 2. You will find files 'prefs.js' 'user.js' 'invalidprefs.js' 3. delete all 3 files 5. Restart firefox and you are done.

You will not lose any of your add-ons or bookmarks, but you will lose any customization which you have made to firefox like themes... Let me know if it does not work...

Modified by zulfi24

MLStrand56 0 solutions 1 answers

What OS?

In Win7 32bit there is no: c:\user\'username'\appdata\roaming\mozilla\firefox\'profileName'\

Xircal 334 solutions 3835 answers

Please do the following.

  1. In the location bar where you normally type in a web address, type about:config and hit Enter.

  2. If you see a window which says "This might void your warranty!", click the button which says "I'll be careful, I promise" so you can continue with the next step.

  3. In the filter at the top, type: keyword.URL

  4. Double click it and remove whatever's in there and replace it with http://www.my.yahoo.com/search?q= and then click OK.

  5. Close the tab

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.


To reset your home page, do the following.

  • Go to the site you want to set as your homepage.

  • Click the Firefox button, go to Options | Options | General.

  • Make sure it says "Show My Homepage" in the first dropdown menu.

  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.

If this suggestion resolves the problem for you, please click the Solved it button next to this post after you log in into the forum. This will help others searching for a solution to the same problem.

Thanks.

upk_singhm 0 solutions 5 answers

Hi All, I had tried to get my problem resolved as per your suggestions provided above, but none worked in my case and here's what worked for me:

  • In your address box type about:config.
  • Look for following settings: browser.search.defaultenginename (Keep it as the one e.g Google), browser.search.defaulturl (set this to the link of whatever is your default search engine), browser.search.order.1(Keep it as the one e.g Google)
  • Now under the Navigation bar where you have the search engine drop box click on Manage Search Engines and remove speedbit from there and chose the one as you want to keep as your default engine.

Restart your Firefox, you should be done. If not then post a reply i will try to remember if i forgot something in my solution.

Happy Surfing. Enjoy.

Uzekamanzi 0 solutions 4 answers

Helpful Reply

Nothing seems to work.

I have (a) Done precisely what upk_singhm said above

           (b) Used Regedit to get rid of all references to speedbit
           (c) Uninstalled anything and everything to do with Speedbit     

I even used speedbit's own utility - THAT WAS a disaster - should have known better - it actually renamed the Google search in the search bar to speedbit.com ... very nasty indeed.

STILL COMES BACK!

This is evil stuff ..... will never, ever have anything to do with DAP or speedbit again. Strongly suggest everyone ditches it pronto.

Modified by Uzekamanzi

scoop_321 0 solutions 1 answers

I have had this problem for ages, I followed all the instructions above and still no luck. Then I found a simple solution!

  • Un-install Firefox
  • Select the tick box to "remove all personal customizations"
  • Re-install Firefox
  • FIXED :)

Hope that helps

Dannie07 0 solutions 1 answers

Helpful Reply

These steps solved my Speedbit problem.

  1. In the address bar type about:config
  2. When the warning appears click I'll be careful, I promise!
  3. In the filter box type speedbit. I've included an image of what
     showed on my screen.
  4. Right click the first item on the list. When the menu appears 
     select reset. 
  5. Repeat step 4 for all the other items on the list.

I hope that this helped