X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox sync is not working behind enterprise proxy

Posted

I've installed Firefox 4.0 and created a new sync account but while trying to sync my data with Firefox Sync server I always get an error saying that it's impossible to connect to server.

All HTTPS web sites are working well.

I've tryed to use UltraSurf proxy instead of enterprise proxy and sync is working, so I guess that the problem is the enterprise proxy authentication of Firefox sync application. Any suggestion to solve the problem???

Chosen solution

Can you post some details about your proxy server? One useful part of your answer should be which authentication method it uses (NTLM? Basic?), if you know it.

Could you please also follow the steps here:

http://philikon.wordpress.com/2010/11/12/sync-in-firefox-4-0-beta-7/

to enable Sync logging, try a sync, and either email the contents of about:sync-log to me (see my username) or post them to a new Bugzilla bug? That will tell us what Sync thinks is happening.

If you're a really technical user, a log of the HTTP requests and responses — either received by the proxy, or from Firefox's perspective — would be useful. You can see instructions for the latter here:

https://developer.mozilla.org/En/HTTP_Logging

Thanks!

Read this answer in context 2

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

rnewman@mozilla.com 13 solutions 105 answers

Chosen Solution

Can you post some details about your proxy server? One useful part of your answer should be which authentication method it uses (NTLM? Basic?), if you know it.

Could you please also follow the steps here:

http://philikon.wordpress.com/2010/11/12/sync-in-firefox-4-0-beta-7/

to enable Sync logging, try a sync, and either email the contents of about:sync-log to me (see my username) or post them to a new Bugzilla bug? That will tell us what Sync thinks is happening.

If you're a really technical user, a log of the HTTP requests and responses — either received by the proxy, or from Firefox's perspective — would be useful. You can see instructions for the latter here:

https://developer.mozilla.org/En/HTTP_Logging

Thanks!

Question owner

Thank you for your prompt reply and for the useful suggestions about some "hidden", at least for me :-) Firefox configurations. Without reasons the Firefox sync problem disappeared after a cold reboot of the PC. May be due to the fact that enterprise proxy use the corporate domain logon credentials for automatic proxy authentication. In any way here is a TCP packet capture snapshot of the Firefox sync request:

Protocol  : TCP Local Address  : myPC IP address Remote Address  : enterprise proxy IP address Local Port  : 3230 Remote Port  : 8080 Packets  : 16 Data Size  : 3.762 Bytes Total Size  : 4.648 Bytes

CONNECT scl2-sync420.services.mozilla.com:443 HTTP/1.1 User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0 Proxy-Connection: keep-alive Host: scl2-sync420.services.mozilla.com


HTTP/1.0 200 Connection Established


00000000 16 03 00 00 73 01 00 00 6F 03 00 4D 8C 64 61 AE .............

hellfire 0 solutions 1 answers

you have to make sure ultrasurf works with firefox. to set up ultrasurf go to tool then options then advanced, after that go to the tab that says network and go to you manual proxy configuration. in the HTTPS PROXY bar type 127.0.0.1 for the server and 9666 for the port. you can ask me more at; helfire25@gmail.com

Modified by hellfire

steph.photo 0 solutions 1 answers

I exactly have the same problem, behind an entreprise proxy. I can authenticate on the website, but there is failure when I try to sync through the "plugin" Sync. I have Firefox 4.0.

Please let me know which logs I can provide to help. I don't know the authentification method of the proxy. I've activated the "sync-log" option, and here is the (long) answer:

1301582988260 Service.Main INFO Loading Weave 1.7b1pre 1301582988288 Engine.Bookmarks DEBUG Engine initialized 1301582988289 Engine.Forms DEBUG Engine initialized 1301582988291 Engine.History DEBUG Engine initialized 1301582988292 Engine.Passwords DEBUG Engine initialized 1301582988293 Engine.Prefs DEBUG Engine initialized 1301582988294 Engine.Tabs DEBUG Engine initialized 1301582988294 Engine.Tabs DEBUG Resetting tabs last sync time 1301582988295 Service.Main INFO Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0 1301582988301 SyncKeyBundle INFO SyncKeyBundle being created for 1301582991624 Net.Resource DEBUG GET success 200 https://setup.services.mozilla.com/new_channel 1301582991624 Service.JPAKEClient DEBUG Using channel hfjn 1301582991683 Net.Resource DEBUG PUT Length: 3334 1301582991870 Net.Resource DEBUG PUT success 200 https://setup.services.mozilla.com/hfjn 1301582991962 Service.JPAKEClient DEBUG Aborting... 1301582991962 Service.JPAKEClient DEBUG Reporting failure to server. 1301582991963 Net.Resource DEBUG POST Length: 0 1301582992145 Net.Resource DEBUG POST fail 400 https://setup.services.mozilla.com/report 1301582992129 Service.JPAKEClient WARN Report failed. Server responded with HTTP 400 1301582994489 Net.Resource DEBUG GET fail 304 https://setup.services.mozilla.com/hfjn 1301583003672 Service.Main INFO Logging in user 6duwi52f64ejxonn6oyptdbizteylbdc 1301583003673 Service.Main DEBUG Finding cluster for user 6duwi52f64ejxonn6oyptdbizteylbdc 1301583005061 Net.Resource DEBUG GET success 200 https://auth.services.mozilla.com/user/1.0/6duwi52f64ejxonn6oyptdbizteylbdc/node/weave 1301583005061 Service.Main DEBUG cluster value = https://scl2-sync45.services.mozilla.com/ 1301583005062 Service.Main DEBUG Caching URLs under storage user base: https://scl2-sync45.services.mozilla.com/1.0/6duwi52f64ejxonn6oyptdbizteylbdc/ 1301583006092 Net.Resource DEBUG GET fail 401 https://scl2-sync45.services.mozilla.com/1.0/6duwi52f64ejxonn6oyptdbizteylbdc/info/collections 1301583006093 Service.Main DEBUG Finding cluster for user 6duwi52f64ejxonn6oyptdbizteylbdc 1301583006275 Net.Resource DEBUG GET success 200 https://auth.services.mozilla.com/user/1.0/6duwi52f64ejxonn6oyptdbizteylbdc/node/weave 1301583006275 Service.Main DEBUG cluster value = https://scl2-sync45.services.mozilla.com/ 1301583006275 Service.Main WARN 401: login failed. 1301583006276 Service.Main DEBUG Finding cluster for user 6duwi52f64ejxonn6oyptdbizteylbdc 1301583011430 Net.Resource DEBUG GET success 200 https://auth.services.mozilla.com/user/1.0/6duwi52f64ejxonn6oyptdbizteylbdc/node/weave 1301583011430 Service.Main DEBUG cluster value = https://scl2-sync45.services.mozilla.com/ 1301583011434 Service.Main DEBUG Exception: Login failed: error.login.reason.account No traceback available 1301583014775 Service.Main INFO Service reset. 1301583014775 Engine.Clients DEBUG Resetting clients last sync time 1301583014776 Engine.Bookmarks DEBUG Resetting bookmarks last sync time 1301583014760 Engine.Forms DEBUG Resetting forms last sync time 1301583014760 Engine.History DEBUG Resetting history last sync time 1301583014761 Engine.Passwords DEBUG Resetting passwords last sync time 1301583014762 Engine.Prefs DEBUG Resetting prefs last sync time 1301583014762 Engine.Tabs DEBUG Resetting tabs last sync time 1301583014763 CollectionKeys INFO Clearing CollectionKeys...'

Modified by steph.photo