X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I stop the cursor focus from changing to the address bar when google.com loads in a new tab?

Posted

The question pretty much says it. Since I went from 3.6 to 4 RC1, cursor focus goes to the address bar instead of staying/going in the search field when google.com loads in new tabs.

Chosen solution

If your using the 'New Tab Homepage' extension then this happens when you upgrade to Firefox 4. Uninstall the official 0.4.3 extension and install the one below for a quick hack. All it does is remove the following section from the code which focuses the cursor on the urlbar.

     if (gURLBar)
       setTimeout(function() { 
         // if page is about:blank select() works just like focus, two birds one stone
         gURLBar.select();
       }, 0);

http://www.mediafire.com/?v1113g9noytswdv

(download and drag into firefox to install)

really this should be a preference as part of the extension to allow the user to choose the focus.

Read this answer in context 154

Additional System Details

This happened

Every time Firefox opened

This started when...

I "upgraded" from release to RC1

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Winamp Application Detector
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • Shockwave Flash 10.2 r152
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.615
  • iTunes Detector Plug-in
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • 4.0.50917.0
  • NPWLPG
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Version 1.1.7, copyright 1996-2011 The VideoLAN Teamhttp://www.videolan.org/

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

justme54s 1 solutions 2 answers

Chosen Solution

If your using the 'New Tab Homepage' extension then this happens when you upgrade to Firefox 4. Uninstall the official 0.4.3 extension and install the one below for a quick hack. All it does is remove the following section from the code which focuses the cursor on the urlbar.

     if (gURLBar)
       setTimeout(function() { 
         // if page is about:blank select() works just like focus, two birds one stone
         gURLBar.select();
       }, 0);

http://www.mediafire.com/?v1113g9noytswdv

(download and drag into firefox to install)

really this should be a preference as part of the extension to allow the user to choose the focus.

Modified by justme54s

Question owner

Worked like a charm. I assumed it was as simple as changing a section of code or a variable, but I figured it would have been something with the browser and not the addon.

Thanks!

ytrewq123 0 solutions 1 answers

Sorry for this absolute novice question but how exactly do i install this download?

I uninstalled 0.4.3 as stated and then tried to drag the files into an open firefox window but to no avail!

Thanks in advance

justme54s 1 solutions 2 answers

@ytrewq123 : Are you sure you dragged the downloaded file 'newTabHome_0.4.3_hacked.xpi' into any open firefox window? You should get an install addon window. Alternatively open the file by using the File>Open file from the menu (if you can't see your file menu the press alt to bring it up).

Modified by justme54s

tarma 0 solutions 1 answers

Thanks for this fix!! Hopefully it can be added to the official plugin, so I don't have to look for updates etc.

northlondon01 0 solutions 3 answers

Brilliantly simply, thanks!!

Jollyware 0 solutions 2 answers

Works a charm, thanks...

shomeo 0 solutions 1 answers

AHHHHHH :)

tabmaster 0 solutions 1 answers

Helpful Reply

I had the same problem when I updated to firefox 4. This is how i fixed it:

The problem seems to be caused by the 'New Tab Homepage' add on. So:


  1. Disable or remove the 'New Tab Homepage' add on and restart firefox.
  2. Download and install the firefox add on called 'NewTabURL' and restart firefox.
  3. Click on the Options button for NewTabURL and uncheck 'Select location bar after loading new tab'
  4. Under the 'Default URL for new tabs' heading, choose 'Home Page'
  5. Click on the Save button.

Hopefully, problem solved!

Modified by tabmaster

serutan 0 solutions 1 answers

justme54s - Thanks for posting this solution. Works great! (FF4.0.1)

Modified by serutan

mettoEnga 0 solutions 1 answers

justme54s, thank you for posting !

rmhutchins 0 solutions 3 answers

Whether the cursor goes to the Search Box or to the Address Box when you open a new tab is based on which page your browser opens when you open a new tab. If your browser is set to open http://en-US.start3.mozilla.com/firefox?client=firefox-a&rls=org.mozilla:en-US:official when a new tab is opened, the cursor will automatically go to the Address Bar. If your browser is set to open http://www.google.com/firefox?client=firefox-a&rls=org.mozilla:en-US:official when a new tab is opened, the cursor will automatically go to the Search Box. So, it just depends on which webpage opens when you select a new tab! To select which webpage opens, just go to the "Tools" Menu and select "Options." Under the "General" tab, you will see a URL (a webpage) which will open when you open your Home Page. I suppose, technically, the webpage you select in "Tabs Mix Plus" to open when you open a new tab is the important one -- but, since most people simply use their Home Page as the page to open, the Home Page in the Firefox Options is relevant. You could change the webpage to open in Tabs Mix Plus to one of the two pages noted above to determine which option you want when you open a new tab -- to have the cursor in the Address Bar or to have the cursor in the Search Box.

gav1234 0 solutions 1 answers

Thank you so much !!!!!!!!!!!!!!!! - it was so wrecking my head !!!

pariahjohn 0 solutions 1 answers

Super easy - works perfectly! Thanks justme54s!

Modified by pariahjohn

ig123 0 solutions 3 answers

If you are using NewTabURL 2.2.3 there is a preference: "select location bar after loading the new tab". After un-checking this option, the focus is in the search box after loading Google in a new tab.

oknight 0 solutions 1 answers

Your fix worked perfectly on Firefox 8, as well! Thank you!

muszyngr 0 solutions 1 answers

I actually created an account on here, just so I can say years later in version 8.0 we still have this problem or I should say annoyance, yes the fix does work, but come on Mozilla you are moving backwards, you're becoming very Microsoft like, lol

TRYER 0 solutions 1 answers

Works great with Firefox 8.0.1 Thanks for the solution.

ericdwenger 0 solutions 1 answers

That's an absolute lifesaver. Thanks for posting the solution! This problem was driving me crazy.

manishjain9 1 solutions 6 answers

I have got a super easy solution to this. Get the Featured addon 'My Homepage' from - http://www.rockyourfirefox.com This addon addresses this issue well and deserves to be Featured.