Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My laptop touchpad scroll is not working with firefox 4. It is wroking with other programs. When I attach a mouse then scroll works with mouse wheel. It is only not working with touchpad. It is/was working with firefox 3.6.x

  • 48 replies
  • 1826 have this problem
  • 3429 views
  • Last reply by CarlD

more options

I am using windows xp service pack 3 with Lenovo T60p.

All Replies (20)

more options

bsmithbrown, have you considered temporarily disabling all the add-ons? Maybe there is another add-on causing problems.

Besides, are you sure you got the latest driver? Most of the time notebook manufacturers does not keep the drivers updated on their support site and it is necessary to go to the touch-pad manufacturer's site. (If you have a Synaptics touch-pad the latest driver can be easily downloaded from their site.)

more options

Hi all!

I finally found a solution that worked for solving this problem for me. Please have a look at the below thread that might help (at least if you have an ALPS pad):

https://support.mozilla.com/en-US/questions/791829#answer-163071

Good luck!

more options

I have a Presario CQ62 - Windows 7 64 Bit - same touchpad device with same problem. Workaround to open Library window under Firefox window works - used control panel to load latest driver (later than HP website) and rebooted - didn't fix problem.

more options

I have a Dell Vostro 3400 with Windows 7 Pro, 64 bit.

Had the scrolling problem until I disabled the Adobe Acrobat 10.0.1.134 plugin. Funny thing too, I do get the up/down arrow with the center dot when scrolling, but no scroll.

Thank you all for the discovery! Works for me. Latest driver on Dell's website is from March 2010. There is a generic driver on Synaptic's website but did not need to install.

more options

Hmmm. I avoid Adobe Acrobat, and instead use Tracker PDF XChange, which also has a FF plugin. Same issue, and same solution. Is it that FF4 with any PDF plugin can't scroll with a Synaptics touchpad? Never had this issue with 3.6 or prior.

Edit: I just realized I had a PDF open in one of my tabs. I know I've had scrolling issues in PDF XChange outside of FF, and it usually has to do with the permissions with which the PDF was opened (ie, whether I opened it as admin). I figure I can re-enable the plugin and scrolling will work as long as I don't have a PDF open. This may be a Synaptics issue, really.

Edit2: Sure enough, I re-enabled the plugin, and I can only scroll EITHER a PDF OR a web page, but not both. Closing the PDF allows me to scroll all web pages. Not sure where the real issue lies, but I guess since this wasn't an issue with FF 3.6, it must be an FF 4 bug.

Modified by JimDandy

more options

What JimDandy said was the same for me--I had a pdf open in one tab, and once I closed it I was able to use the touchpad scrolling. I can live with that kind of solution...for now. Hopefully they'll fix this soon, because I have absolutely no idea why this happens.

more options

I am a toshiba qosmiso running windows 7 64 bit and had this problem which turned out to be caused by the (entirely irritating!) Synaptics Scrybe software. I just removed it, and once again I could scroll in firefox!

more options

Got my T61P running XP working....

Had to use the ThinkVantage System Update to get a new driver: Synaptics UltraNav Driver 15.2.20.0

more options

Thanks to http://support.mozilla.com/en-US/questions/801725#answer-161532

Try this :

For all who have problem with the standard ALPS touchpad driver in firefox 4; here is a quick registry fix: 1) Open registry with regedit 2) Search for following key: HKEY_LOCAL_MACHINE\SOFTWARE\Alps\Apoint 3) Set ScrMethod to 1 4) Reboot

After that scrolling in FF4 should be possible.

For me it works with a Acer Aspire

more options

I agree with bsmithbrown.

I have gone back to FireFox 3.6 - there have have been no improvements since then. FireFox developers will go on about security but issues like this and the plugin container are a step backwards.

I have not yet moved to Chrome or Opera because I use NoScript and AdBlock Plus.

Charlie

more options

Still no working solution for this failing trackpoint scrolling on Firefox 4.0.1. In my previous version of Firefox this worked fine. Today in my Google Chrome browser the trackpoint scrolling works perfectly.

This tells me the problem has nothing to do with any backdated drivers, the need to remove and re-install any drivers, or anything linked to my laptop (Lenovo SL300). If trackpoint scrolling on Chrome works... why can't Firefox?

more options

@Gonzolla - try this:
Type about:config into address bar, hit Enter.
It will ask if you want to access the settings, say yes you know the risk.

Use trackpoint in the Filter area, you will see a ui.trackpoint_hack.enabled setting, change that from -1 to 1. Now you should be able to scroll using trackpoint and middle mouse button on the trackpad again.

more options

Just "upgraded" to Firefox 4, I immediately got this problem. My laptop's touchpad scrolling works only for one "notch" at a time. Worked perfectly fine in FF 3.6 or whatever it was. I just reinstalled my touchpad drivers from Lenovo's website, no change. I have this only with FF4, other applications (even FF Foxit Reader plugin) are fine. Considering going back to old version or finally switching to Chrome.

more options

OK, it's definitely due to PDF plugin integration. If I have a PDF page open, I get that behaviour. If I close it, the problem disappears. I am using Foxit Reader Plugin for Mozilla 2.0.0.1102, but judging from other posts this affects all PDF plugins for FF4. On the other hand, I'm pretty convinced that the touchpad driver is a red herring.

Now, what is broken? Given that FF3.6 works and all PDF plugins are affected, my guess is FF4.

more options

Just upgraded the Foxit Reader Plugin to the latest 2.0.1.524, same problem.

more options

Uninstalling the Adobe add solved the problem in my Dell XPS L502x

Modified by navarretemarce

more options

Completely unacceptable that a REAL solution hasn't been found for this. I'm switching browsers and can't see myself returning to Firefox until this bug has been fixed. So disappointed.

more options

I had the same problem in FF 5.0, and disabling the Adobe PDF Plugin works for me too. The interesting thing I want to point out is that scrolling via touchpad is still working--it's just that the scrolling action takes place in your PDF tab, not in the tab you're actually looking at (try it and see!). So the Adobe PDF Plugin is "stealing the touchpad scrolling input" (to quote DragonLord at superuserdotcom who diagnosed the issue) from the active tab.

Modified by ctmckee

more options

Wow iuliand: You are AWESOME! Thanks a ton! By disabling adobe reader in FF5, i was able to use the scrolling again! :) My laptop model is Acer Aspire 5820 TG and the touchpad driver is from synaptics !

more options

This happened to me twice already, with different user accounts/FF versions, the latest is #5. In both instances the problem was with an add-on that caused it. Try to disable all your add-ons and see if it works then. If it does just try to enable one at a time and see which causes the problem. In my case it was the smooth scrolling add on and the zoom page in and out, I don't remember the exact name of the add ons, but those were their functions.

  1. 1
  2. 2
  3. 3