X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

pinch open and close zoom (mac) not working in latest beta update

Posted

Anybody know why pinch open close for the mac track pad suddenly does not zoom in the lastest beta update?

Chosen solution

The prefs that control that action have been reset to empty strings.

You can use modify the related browser.gesture prefs these values to restore the old behavior:

  • browser.gesture.pinch.in -> cmd_fullZoomReduce
  • browser.gesture.pinch.in.shift -> cmd_fullZoomReset
  • browser.gesture.pinch.out -> cmd_fullZoomEnlarge
  • browser.gesture.pinch.out.shift -> cmd_fullZoomReset
  • browser.gesture.pinch.latched -> false
Read this answer in context 65

Additional System Details

Installed Plug-ins

  • Picasa plugin.
  • iPhoto6
  • Office Live Update v1.0
  • DivX Web Player version 2.0.2.39
  • Simple plug-in that handles Citrix connection files
  • eMusic DLM 4.1.3.2
  • Java Plug-In 2 for NPAPI Browsers
  • Shockwave Flash 10.1 r102
  • Version 1.8.0.1441
  • Google Talk Plugin Video Accelerator version:0.1.43.5
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b10) Gecko/20100101 Firefox/4.0b10

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

Chosen Solution

The prefs that control that action have been reset to empty strings.

You can use modify the related browser.gesture prefs these values to restore the old behavior:

  • browser.gesture.pinch.in -> cmd_fullZoomReduce
  • browser.gesture.pinch.in.shift -> cmd_fullZoomReset
  • browser.gesture.pinch.out -> cmd_fullZoomEnlarge
  • browser.gesture.pinch.out.shift -> cmd_fullZoomReset
  • browser.gesture.pinch.latched -> false

Modified by cor-el

Question owner

That did it. Thank you!

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

You're welcome

X_Bones 0 solutions 1 answers

thanks a bunch cor-el, had the same problem, sorted, 30 mins ago didnt even know what about:config was!

zed 0 solutions 1 answers

well I tried this a while bak and it works perfectly....BUT I need to keep doing this each time I open FF which is not something I'd prefer . Doesn't the changes I do supposed to stay that way or am am I missing somthin here.

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

Quote:

BUT I need to keep doing this each time I open FF which is not something I'd prefer.

Try:

Modified by cor-el

astrobill 0 solutions 5 answers

This problem carried through to the release version, at least on my MacBook Air today when I did an upgrade install of Firefox 4 (from 3). Luckily, I found this post...fixed it. Your preferences fix "took" and is holding after doing it just once. Bad bug to let slip into a release version...a lot of non-tech-savvy Mac users are going to miss this fix and just start using Safari again....sigh.

Here's the place where users of the RELEASE version are reporting this...I cross-linked them back to THIS thread to see your solution:

https://support.mozilla.com/en-US/questions/795269

Modified by astrobill

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers
  • Bug 613909 - Disable pinch gestures by default & revert three finger vertical swipe gestures

(please do not comment in bug reports; you can vote instead)

rickfromgilroy 0 solutions 1 answers

How do you add the values? Will FF have a update that will fix this?

elehto 0 solutions 3 answers

My pinch and zoom feature still isn't working.

I've never used about:config before, but I used the values cor-el provided per the instructions on the MozillaZine site. It still isn't working and I don't know why. Any ideas?

Thanks!

olcorral 0 solutions 5 answers

Followed the instructions: about:config, entered new string as:

   browser.gesture.pinch.in cmd_fullZoomReduce
   browser.gesture.pinch.in.shift cmd_fullZoomReset
   browser.gesture.pinch.out cmd_fullZoomEnlarge
   browser.gesture.pinch.out.shift cmd_fullZoomReset 

Saved it, restarted FF4 and nothing happened. What am I missing? Thank you for your help.

kev133 0 solutions 1 answers

Helpful Reply

I am typing out easy instructions for those that are new to entering values. I myself am no expert for sure. It took me awhile to figure it out and I got it to work. I was mad when the pinch to zoom didn’t work after I updated. Thank you cor-el for posting a fix.

1. Go to a new tab, type in about:config hit enter

2. Click the “I’ll be careful, I promise!” button

3. Scroll down until you see “browser.gesture.pinch.in” right click on it and hit modify

4. A drop down that says “Enter string value” appears type in cmd_fullZoomReduce

5. Click ok

Find the other ones and do the same. After you have entered all four you should see them in bold and on the right under value you should see only this cmd_fullZoomReduce part.

6.Once you have it all entered just close the tab and it should work.

I didn’t have to quit Firefox for it to work, but you may.

I’m using a MacBook Pro and it worked great, Hope this helps.


Preference Name     /       Value

browser.gesture.pinch.in / cmd_fullZoomReduce

browser.gesture.pinch.in.shift / cmd_fullZoomReset

browser.gesture.pinch.out / cmd_fullZoomEnlarge

browser.gesture.pinch.out.shift / cmd_fullZoomReset

Modified by kev133

pezent 0 solutions 1 answers

Firstly, thank you cor-el for your primary information. Secondly, and most importantly, a big big big thank you kev133 for your vital directions. I am a 'techno peasant' and you clarified the process regarding cor-el's important information. Without you kev133 I was just about to 'throw in the towel'. Firefox... Damn shame this zoom problem for 'mac heads', like myself, cropped up. I agree with astrobill's insight regarding this matter. That being said, Firefox is still my chosen browser. Peace out!

Modified by pezent

mac_girl 0 solutions 3 answers

Kev 133,

Thank you soooooo much for explaining exactly how to enter a value!

I was thinking a value was a number. I didn't realize cor-el had already typed the values for me until you told me what they were. A big thanks to cor-el, too!

I really appreciate it. I love the zoom in feature and now I'm so happy again!

<3 Mac_girl

kmcc 0 solutions 1 answers

Thank you SO MUCH for doing this! It helped immediately (although I did have t restart FireFox).

However, I STILL ended up going back to FF 3.6 because another feature I really like is not possible in 4.0: I used to be able to type in an address without the extension (.com or .org or .net) and it would go to the site. Now it just takes me to the Google search results for the site. Bummer.

mrsjb 0 solutions 3 answers

this was the most helpful explanation and do - able solution i have seen. this really walked me thru the process and it now works.... YAY. but FF 4 is slower for me than my 3.6

suellapal 0 solutions 1 answers

The solution is correct, but it's not worded properly.

Here's one line of that code that needs to be added:

The first part of the string (eg browser.gesture.pinch.in ) is the preference name

The second part (cmd_fullZoomReduce) is the value.

In about:config you add the name in the first box that comes up, & the value in the second box.

That works!