X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I hide the Add-on Bar by default?

Posted

Whenever I disable the Add-on Bar, it returns after I restart Firefox. Is there any way to make it hidden by default? The only button in it for me is Firebug, and its already got a toolbar button and a keyboard shortcut. Thanks!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.1 r102
  • Silverlight 4.0.51204.0
  • Office Authorization plug-in (14.0.4730.1010, 14.0.4761.1000)
  • Adobe PDF Plug-In 10.0.0.396
  • QuickTime Plugin 7.6.9.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10) Gecko/20100101 Firefox/4.0b10

More Information

Application Basics
Name
Firefox
Version
4.0b10
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10) Gecko/20100101 Firefox/4.0b10
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Feedback
1.0.4
true
testpilot@labs.mozilla.com
Canadian English Dictionary
2.0.0
true
en-CA@dictionaries.addons.mozilla.org
Firebug
1.7X.0a9
true
firebug@software.joehewitt.com
Modified Preferences
Name
Value
accessibility.typeaheadfind.casesensitive
1
accessibility.typeaheadfind.flashBar
0
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20110121161358
browser.startup.homepage_override.mstone
rv:2.0b10
extensions.lastAppVersion
4.0b10
keyword.URL
http://duckduckgo.com/?q=
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1296442832
places.history.expiration.transient_current_max_pages
128801
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
NVIDIA GeForce GTS 250
Vendor ID
10de
Device ID
0615
Adapter RAM
1024
Adapter Drivers
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version
8.17.12.6099
Driver Date
10-16-2010
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7600.20781)
WebGL Renderer
NVIDIA Corporation -- GeForce GTS 250/PCI/SSE2 -- 3.3.0
GPU Accelerated Windows
1/1 Direct3D 10

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Maybe Firebug is causing that Add-on bar to appear or it is because the Add-on bar isn't empty.

You can check:

Question owner

If that's the case, it seems like this is a bug that should be fixed--what's the point of even letting people hide the add-on bar if it will always appear on startup if any installed add-on has a button? Can someone else verify that I'm not just missing something stupidly obvious (entirely possible)?

mrtn400 0 solutions 1 answers

Helpful Reply

Do you have Xmarks installed?

I was having the same issue as you. Try going to about:config and changing "extensions.xmarks.forceAddonbar" from 1 to 0. Then restart Firefox and Xmarks should ask you if you want to enable the addon bar, and click no.

Hopefully that helps.

Question owner

Thanks for the suggestion. Firebug doesn't seem to have a similar option, but I tracked down a bug report on their tracker that indicates (I think?) that Firebug is what's forcing the Add-on Bar to display at start-up, and that it will be fixed very shortly.

LighScan 0 solutions 5 answers

Thanks a lot mrtn400. This problem was annoying me too, but your Xmarks hint helped me out.

daydreams 0 solutions 1 answers

Hi, all! I was experiencing the same issue. With version 3.9.5, after resetting the "extensions.xmarks.forceAddonbar" parameter, upon next start of Firefox, Xmarks would ask if i'd like to show the Addon bar AND whether i clicked OK or Cancel, it was still showing it!

Guess, the issue is soleley with Xmarks. Now, using v3.9.8 the problem is gone.

Pedge 0 solutions 1 answers

I don't have Xmarks installed yet have the same problem. Are there any other add ons that could cause the same issue?

yeevgen 0 solutions 1 answers

In my case it was ShowIP extensions, simply try to disable them(sitting on Add-on Bar) one by one.

grahamt 0 solutions 11 answers

The problem, as Grant states, is not that there are add-ons that expect the a Add-on Bar to be present. We already know that there are developers who have lost the plot but whose add-ons still work and which we users find very useful. Mikes Kaszman's AutoContext is a case in point. The point is that we can Customise the toolbar to place the icons for these on the toolbar, alongside the Address Bar. Having done so we no longer need to see the Add-on Bar, whether or not the icons for these add-ons still appear there. However, FF insists on launching it every time it restarts. How do we stop it?

dpnolte 0 solutions 1 answers

if you want to hide the add-on bar permanently, you can add the following to userChrome.css:


#addon-bar {
    display: none !important;
}


Note that this hide the add-on bar irrespective of whether View->Toolbars->Add-on Bar is checked or not.

Modified by cor-el

grahamt 0 solutions 11 answers

Tried that mod but doesn't seem to work. userChrome.css file looks like this:

/*

* Do not remove the @namespace line -- it's required for correct functioning
*/

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */

/*

* Hide Add-on Bar by default
*/

1. addon-bar{

 display: none !important;

}

The add-on bar still appears on Firefox start.

RaZoR 3 solutions 20 answers

Greetings.

A sloppy side tracking solution might be to install Stylish extension and use some of the autohide addonbar scripts some might be able to disable it better.

Otherwise try SafeMode on firefox.

Start menu > Mozilla Firefox (Safe Mode) > temporarily disable addons and click continue. Be carefull with the options there you can reset your browser.

https://support.mozilla.com/kb/Safe+Mode


Cheers

RaZoR

grahamt 0 solutions 11 answers

Finally discovered elsewhere the solution to this issue. The example code given above by dpnolte is incorrect. It should read:

/* 
 * Hide Add-on Bar by default
 */
#addon-bar { display: none !important; }


The comments (between /* and */) are my own and optional.

(fixed the code - c)

Modified by cor-el

grahamt 0 solutions 11 answers

I see now why the example code given by dpnolte is incorrect! The comments he entered (and I entered as well in my posting) have been corrupted by the code used to maintain this log. Where is says "1. addon-bar", the "1. " should actually be the hash symbol, immediately attached to the front of "addon-bar". For some reason I can't determine, when the reply is posted the code behind this log substitutes "1. " in place of the hash symbol, so it is displayed incorrectly. I have attached a screenshot within PSPad to show how it should look

grahamt 0 solutions 11 answers

cor-el - many thanks for sorting out the problem that was causing corruption of our entries in this log. If you hadn't done that I was going to experiment to see if two successive hash symbols produced the desired effect. However, as now fixed it's working as it always should have done.

jbir359 0 solutions 21 answers

where is this userChrome.css file? (searching my computer did not discover such a file

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Helpful Reply

The file userChrome.css doesn't exist by default and needs to be in the chrome folder in the Firefox profile folder.
You need to create a chrome folder in the Firefox Profile Folder if that folder doesn't exist

You need to add thecode to userChrome.css below the @namespace line.


See also:

You can use the ChromEdit Plus or Stylish extension to have easier access to the customization files.

dvsmith 0 solutions 3 answers

What's a non-techy, non-engineer-type person to do? I have this same problem. When I go to view / toolbars / and uncheck add-on bar, shouldn't this PERMANENTLY change this setting?

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Some extensions can place data on the Add-ons bar and that can cause the Add-ons bar to get displayed.
You can either remove all elements that are placed on the Add-ons bar by extensions or uninstall the extensions that do that.

dvsmith 0 solutions 3 answers

I disabled all extensions, then rebooted. The bar is narrower now since there's no content, but it's still there at the bottom of every window  :(