X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

how t0 change "about:home" search engine

Posted

how t0 change "about:home" search engine (at the moment it is yahoo), but i want google. if i search from adress bar then it is google. but i want google on homepage to:(. thank you

Chosen solution

@cor-el: This would probably work if you want to restore the default.

I've successfully changed my search-enginge to encrypted google on "about:home" with these steps:

1. Download a sqlite-Browser. (I've used this: Website (sqlitebrowser.sourceforge.net) / direct download win)

2. extract the zip-File

3. start the "SQLite Database Browser 2.0 b1"

4. open the "chromeappsstore.sqlite" file in your Profile Folder

5. click on Tab Browse Data and doubleclick on the value in the first row. (see screenshot below)

6. Insert the value you want.

Like you will see in the example values below, you can use any search you want and you can insert "_searchTerms_" instead of the search Term. I have these values:


  • Standart (google):

{"name":"Google","searchUrl":"http://www.google.com/search?q=_searchTerms_&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a"}


  • encrypted Google:

{"name":"Google","searchUrl":"https://encrypted.google.com/search?q=_searchTerms_"}


  • yahoo:

{"name":"Yahoo","searchUrl":"http://search.yahoo.com/search?p=_searchTerms_"}


  • bing:

{"name":"Yahoo","searchUrl":"http://www.bing.com/search?q=_searchTerms_"}

Read this answer in context 72

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.1 r82
  • Version 1.1.5, copyright 1996-2010 The VideoLAN Teamhttp://www.videolan.org/
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

More Information

idoln95 0 solutions 1 answers

I don't know if this would help but it should.


go to about config, search for "search"

and change: browser.search.defaultenginename and browser.search.order.1

to "Google"

MozillaUser233 0 solutions 3 answers

Any way have about:home Google point to https://encrypted.google.com/search?q= instead of http://www.google.com/search?q=  ?

Also my keyword.URL is set to https://encrypted.google.com/search?q= so that doesn't help about:home point to Encrypted Google.

daniel123 0 solutions 1 answers

ok, but where I can find about config? I think I understand you, but I dont know where I can find it. Thank you

Sam8595 0 solutions 1 answers

It can be found at about:config, just type that into the awesome (adress) bar and click "I'll be careful I promise!"

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

You need to set another page as your home page. You can't change the search engine that is used on the about:home page.

Arihanta 0 solutions 2 answers

I'm having the same problem as well. I want the search engine at about:home to be Google instead of Yahoo. I tried idoln95's advice to change the value of browser.search.defaultenginename to Google and tested the search engine of about:home, but the search engine used was still Yahoo.

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

You can try to delete the file chromeappsstore.sqlite in the Profile Folder.

drWatson 1 solutions 1 answers

Chosen Solution

@cor-el: This would probably work if you want to restore the default.

I've successfully changed my search-enginge to encrypted google on "about:home" with these steps:

1. Download a sqlite-Browser. (I've used this: Website (sqlitebrowser.sourceforge.net) / direct download win)

2. extract the zip-File

3. start the "SQLite Database Browser 2.0 b1"

4. open the "chromeappsstore.sqlite" file in your Profile Folder

5. click on Tab Browse Data and doubleclick on the value in the first row. (see screenshot below)

6. Insert the value you want.

Like you will see in the example values below, you can use any search you want and you can insert "_searchTerms_" instead of the search Term. I have these values:


  • Standart (google):

{"name":"Google","searchUrl":"http://www.google.com/search?q=_searchTerms_&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a"}


  • encrypted Google:

{"name":"Google","searchUrl":"https://encrypted.google.com/search?q=_searchTerms_"}


  • yahoo:

{"name":"Yahoo","searchUrl":"http://search.yahoo.com/search?p=_searchTerms_"}


  • bing:

{"name":"Yahoo","searchUrl":"http://www.bing.com/search?q=_searchTerms_"}

Modified by drWatson

the-edmeister
  • Top 10 Contributor
  • Moderator
3202 solutions 24448 answers

@dr_watson

Thank you for coming up with that information.

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Helpful Reply

You can also do that with the SQLite Manager extension.
I didn't post that previously because I didn't know if such a change lasts and why there is that wrong (or not default) data in that database file.
Did an extension made that change (Google to Yahoo) or an external program?

MozillaUser233 0 solutions 3 answers

Fantastic! Posted my question 8 months ago, forgot about it, randomly came across this thread looking for something else, seen the absolute awesome solution to my question.

Thanks Watson, now I am officially using about:home with {"name":"Ixquick","searchUrl":"https://ixquick.com/do/metasearch.pl?language=english&cat=web&query=_searchTerms_"} .

Just complete awesomeness.

Would be very cool if Mozilla could make an easy way to swap search engines for about:home in a jiffy.

Modified by MozillaUser233

the-edmeister
  • Top 10 Contributor
  • Moderator
3202 solutions 24448 answers

As far as an "easy way" to change the about:home search engine, this works to change it back to Google once it gets changed by Malware, but I can't get the syntax correct for the other search engines code that dr_watson posted.

Firefox button > Web Developer -> Scratchpad -
copy and paste this script into Scratchpad > then hit Execute > Run

 
javascript:{localStorage["search-engine"]="{\"name\":\"Google\",\"searchUrl\":\"http://www.google.com/search?q=_searchTerms_&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a\"}";void(0);}
 
cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

You can check the current setting of the search-engine with this code in the Scratchpad (Shift+F4) and the about:home page on display:

alert("localStorage[\"search-engine\"] = \n\""+JSON.stringify(localStorage["search-engine"])); 

See also:


SearchEngines = {Google:{"name":"Google","searchUrl":"http://www.google.com/search?q=_searchTerms_&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a"},Yahoo:{"name": "Yahoo!","searchUrl":"http://search.yahoo.com/search?p=_searchTerms_"},Bing:{"name":"Bing","searchUrl":"http://www.bing.com/search?q=_searchTerms_"}}

localStorage["search-engine"] = JSON.stringify(SearchEngines["Google"]);
// localStorage["search-engine"] = JSON.stringify(SearchEngines["Bing"]);
// localStorage["search-engine"] = JSON.stringify(SearchEngines["Yahoo"]);

document.location.reload();

For Bing and Yahoo images, see http://forums.mozillazine.org/viewtopic.php?p=11018123#p11018123

Modified by cor-el

lithodora 0 solutions 2 answers

For whatever reason when I double clicked the window flickered by. I ended up writing a SQL query to get the job done:

INSERT INTO `webappsstore2` (`scope`, `key`, `value`, `secure`, `owner`) VALUES ('emoh.:moz-safe-about', 'search-engine', ' {"name":"Google","searchUrl":"http://www.google.com/search?q=_searchTerms_&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a"}', '0', );

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Note that this won't restore the search icon on the about:home page.

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  • Open the about:config page via the location bar
  • Type in the Filter bar: mstone
  • Right-click the browser.startup.homepage_override.mstone line and select: Reset
  • Close and restart Firefox

[locking thread due to the age]