Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google Web Font Directory - All Fonts Look The Same

more options

Shortly stated - All my Google Fonts look the same in Firefox 3 (latest build) and Firefox 4 beta 9

I have tried disabling/enabling all plugins/extensions one by one and all at once.

I have tried removing Firefox 3 completely and installing Firefox 4 Beta to no effect on Google Web Fonts.

I've also made sure that Tools > Options has Javascript enabled as well as "Allow pages to choose their own fonts, instead of my selections above" - Advanced is enabled.

I need help please, I like to do all my web development in Firefox so going between Chrome and Firefox (works in Chrome just fine) is a bit of a pain.

Here's the screenshot of how my Firefox see Google Web Fonts (btw same applies to any page with Google Fonts or Font Previewer of Google.)


http://i53.tinypic.com/2v94w0p.jpg

Here's my FF > Options > Fonts page -

http://i56.tinypic.com/30nkld2.jpg

Thank you for any assitance that you willing to provide.

Chosen solution

It is definitely a proxy issue. Changing the request to https doesn't seem to help as well.

Currently using: Firefox 8.0 on Ubuntu 10.10 System behind a NTLM Proxy with authentication.

Error as seen by Firebug: 407 Proxy Authentication Required - themes.googleusercontent.com

Read this answer in context 👍 2

All Replies (20)

more options

Is the pref gfx.downloadable_fonts.enabled set to true on the about:config page?

more options

value set to true @cor-el i've tried toggling it back and forward (true/false), yet nothing

Modified by d3vlabs

more options

You may need to close and restart Firefox after you have toggled the pref to true.

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the add-ons is causing the problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See:

more options

"You may need to close and restart Firefox after you have toggled the pref to true. "

have tried that a couple of times, still google fonts look the same

safe mode was promisng but i got same issue with google fonts

i should mention that im running firefox 4 beta and doesnt seem like there is a native way of enabling default theme during safe mode, i have it disabled. going to try a random theme off firefox addons page next.

more options

having tried another theme, no luck

more options

I'm not sure this will help, but you could disable the hardware acceleration: Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" . Trying won't hurt at least.

more options

thanks for the tip about hardware acceleration yet no luck

more options

Do you see a request for those fonts if you install the Live HTTP Headers extension and check the requets and response header?s

more options

I was having the exact same problem as originally stated. I'm using Firefox 3.6.13 on OS 10.6.6 and was basically just getting the fonts to render as Times New Roman. I enabled Live HTTP headers and it dawned on me that my network Proxy was the issue. I turned this off - went back to Wireless and BINGO - webfonts work perfectly in Firefox! For whatever reason my Proxy was blocking them. Hope this helps some of you.

more options

Modified by d3vlabs

more options

i m not exactly sure of how liveheaders extension would help my issue, i posted a pastebin above of http header returning status 304, something that was suspicious to me

i have mentioned in my first post that Google Chrome recongizes and displays Google Fonts just fine.

I have took measures to disable "proxy behavior" by shutting down firewall client (zonealarm), disabling spywareblaster adware protection and restotring windows HOSTS file. I have also tried connecting this here laptop to another network with no luck for google fonts/firefox issue

Having a multiboot ubuntu installation i have no problem loading google fonts via ubuntu os/fiefox/same laptop

more options

ive just noticed the weirdest thing, "cyrillic" web fonts are actually displaying as they meant to: http://www.google.com/webfonts?subset=cyrillic

yet Greek, Khmer, Latin are remaining as before, for this machine

Modified by d3vlabs

more options

Why behind a Proxy Google fonts rendering are blocked on firefox? ex.: http://www.google.com/webfonts/

There was a solution server or code side?

Ali

more options

See:

  • Bug 627616 – font-face fonts not loaded over authenticating proxy

(please do not comment in bug reports; you can vote instead)

more options

Having installed Firefox 4 (deleted existing pereferences and settings). The problem remains. Yet Cyrillic google web fonts are display just fine.

I should mention that I'm running a custom version of Windows XP with a lot of services removed and a lot of not so often to use stuff wiped out in order to get max speed/max space removed. Could that be a problem?Is there any Windows XP service/application that Firefox relies on to render Google Web Fonts properly? Like i mentioned before as well, Google Chrome renders these fonts just fine.

Maybe its a regional setting, I have tried switching keyboard layout and switching on advanced text services.

more options

now running firefox 4.0 stable issue remains

more options

someone suggested it, yet i disregarded it as stupid. little did i know http://www.google.com/webfonts will display any font i actuallly have installed on the local computer.

for example download font Sunshiney http://www.google.com/webfonts/family?family=Sunshiney&subset=latin#download

install it locally, for ie C:\windows\fonts

and the next visit to google web fonts directory will that have that font displayed correctly. is there deeper permission then

Options > Fonts Allow pages to choose their own fonts, instead of my selections above as i have that checkboxed.

Modified by d3vlabs

more options

Google Web Fonts DISPLAY works, but PRINTING does not.

I found a somewhat similar solution in about:config to try enabling. (Mine was off/false by default.) print.print_downloadfonts --> Set to true.

However, I tried this and although I can definitely see the fonts, they *print out* as default fonts (_serif or _sans). Google's Web Fonts work on every other browser/OS combination I can think of (Mac, PC, Linux <--> Chrome, IE, Safari)

Using Mac OS X 10.5.8 and Firefox 4.0.1, although the "non-printing webfonts" problem also occurs under Windows XP and Firefox 3.6.17

Image Related.

more options

downloadfonts --> Set to true. did nada Firefox 6.0

more options

OP: I was having the same issue until I saw this page and the comments other users have left. It definitely seems to be related to the proxy issue. I tried two solutions, and they both revealed the problem:

1. Changed the url from http://www.google.com/webfonts to https://www.google.com/webfonts ; this made the fonts show correctly.

2. Tried running my computer on a different, less secure network. This also made them show correctly. So if you haven't already, try getting your computer on the internet on a different connection and see how the page loads. If the fonts work on a different connection, it's a network security issue.

I haven't found a permanent solution yet, I'm not my network administrator, but my guess is (if the above 2 "solutions" work) something would have to be configured in your network security settings to get around this issue.

  1. 1
  2. 2