Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Sites using flash don't work on Firefox 4 beta 7, why not?

  • 20 replies
  • 2125 have this problem
  • 248 views
  • Last reply by MehmetGunduz

more options

When I use FF 4.0b7 on my Mac I try to go to a website using flash (YouTube, Hulu, etc.) and it doesn't display anything. No video, nothing. But when I use FF 3.6.12 any website using flash works just fine! I've reinstalled Firefox and flash many times over, to no avail. Flash also works in other browsers, just not Firefox 4..

All Replies (20)

more options

Flash has become even more buggy in this release of FF4b7. I get that spinning pinwheel all the time when I try to load a page with Flash, and the plug-in crashes quite often.

more options

It does not help to uninstall and reinstall Firefox or flash. it does not help to update flash. It does not help to update my mac OS software. You tube videos do not run at all. The spinning wheel is seen quite a bit on other pages--never saw that before. No trouble doing the same tasks on Safari or IE. How can I go back to 4.06?

more options

You need to update Flash. There are issues with certain older Mac Flash versions (including the version of Flash that Apple is currently shipping) that Adobe has fixed in its latest version. Go to http://get.adobe.com/flashplayer/ and follow the steps.

If that doesn't help, you may have a conflict with hardware acceleration and Flash and your graphics drivers. Try disabling hardware acceleration in Firefox (Firefox > Preferences > Advanced, uncheck use hardware acceleration when possible) and disabling it in Flash: read http://www.macromedia.com/support/doc.../help01.html for instructions.

more options

Cww Thanks for your post. I turned Hardware acceleration off in Firefox as well as in the Flash settings (described in the macromedia link you posted).

But still no luck. Just a quick sidenote: I'm relying on an old version of Flash, because I need that in order for Plex mediacenter to work. Using Flash 10.45.02 with 10.6.5.

more options

WORKAROUND

I tried opening it in 32-bit mode and that did the trick, Flash is now working again. But that let's me get rid of all the 64-bit speed enhancements. Hoping that mozilla can fix this somehow.

more options

More detail:

The simple "fix" is to run Firefox 4b7 in 32-bit mode.

Note that the above is a complete hack and far from ideal. Running Firefox in 32-bit mode means losing a lot of the performance gains of a 64-bit version (and yes, you can really tell the difference in speed between 32-bit and 64-bit on some things) and some out-of-process plugins (i.e: plugins not crashing the browser when they crash).

The real underlying problem, is that whilst 64-bit Firefox still supports 32-bit and 64-bit plugins, it will only do so if they're linked against a newer version of the NPAPI plugin (cocoa version rather than the carbon version) interface, which only flash 10.1 does! So, no flash 10.0 on 64-bit Firefox 4, ever! This is a similar problem that occured when Safari moved to a 64-bit version. 32-bit Firefox has no such limitations as it's still mostly using the old model of loading plugins. Take a look here for some stats and more details about the problem.

The more time goes on, the more this flash 10.1 thing is becoming a sticking issue. <sigh>


originally posted by "ReallyFuzzy" here: http://forums.plexapp.com/index.php/topic/20306-mac-os-x-1065-includes-flash-10110264/page__view__findpost__p__126144

more options

The "fix" is also posted here, with other reference links:

http://kb.mozillazine.org/Flash#Flash_does_not_work_in_Firefox_4_-_Mac_OS

On some Mac OS X 10.6 systems, Flash no longer works in Firefox 4 Beta 7, even though it works in Safari and previously worked in Firefox 4 Beta 6 or below. As a workaround, close Firefox, control-click the Firefox.app icon, select "Get Info", and then check the box, "Open in 32-bit mode"

P.S. For more information about Firefox 4 on Mac OS X, see this Mozilla developer's blog post, http://boomswaggerboom.wordpress.com/2010/11/10/firefox-4-for-mac-os-x-under-the-hood/


...EDIT January 17, 2011: Updated mozillazine link. aw.

Modified by AliceWyman

more options

This problem persists with Firefox 4 beta 8. Oh boy. Problem doesn't exist with Chromium or Safari. I know that Chromium is using an internat Flash in the browser, that is why this issue with old versions of Flash isn't present there. Not sure about Safari though.

more options

Tyyy,

Firefox 4 Beta 7 and above runs in 64-bit mode by default on Mac OS X 10.6 and requires at least Flash 10.1 for Flash content. The original poster already had Flash 10.1 installed but, for some reason, Flash wasn't working. You have an older Flash version but running Firefox in 32-bit mode can be a workaround in both situations. Here is a copy of my reply to you in this other topic:


If you are using an old Flash plugin (previous to 10.1) such as Flash 10.0 then yes... only Flash 10.1 or above will run in Firefox 4 in the default 64-bit mode on Mac OS 10.6 ( reference and background)

However, some Mac OS X 10.6 users <snip> are unable to view Flash content in Firefox 4 Beta 7 or above , even though they have Flash 10.1 or higher installed (such as Flash 10.1 r102). For those users, running Firefox 4 Beta in 32-bit mode seems to be the best workaround.

Note for others reading: The steps to start Firefox 4 on Mac OS in 32-bit mode are now given in the Troubleshooting section of this article (viewable for Mac OS, Firefox 4): Flash Plugin - Keep it up to date and troubleshoot problems
......and here is a screenshot I made, showing the "Open in 32-bit mode" checkbox in the "Firefox Info" window.

The "bug" that results in Flash 10.1 plugin failure in Firefox 4 Beta 7 and above occurs on some (older?) Mac 10.6 systems. I don't see the issue myself. Flash 10.1 works fine with Firefox 4 Beta 7 running in 64-bit mode on my new iMac.

P.S. Here is an (unconfirmed) bug that seems to describe the problem:

https://bugzilla.mozilla.org/show_bug.cgi?id=610526
Bug 610526 - Firefox never loads flash in "out of process" mode

more options

Firefox 4.0b9 is not working even with the latest Flash player. I have hardware acceleration turned off. FF4 without flash is not useful.

more options

got the same problem with 4.0b9 flash does not work even in 32 bit environment~

more options

To fschibilla and antukecik,

If you are havng problems with Flash and the information posted above doesn't help you, first check these articles for a solution:

If you need more help you should each ask a new question in the support forum, so that others can see your Firefox version, operating system, and other system details.

more options

Hey! After installing Firefox 4b9 flash won't work on any website, but does in 32 bit environment (mac os 10.6.6) !? Reinstalled flash and everything rebooted bla bla... still only work in 32 bit what's happening ?

more options

gabo77,

Starting in Firefox 4 Beta 7, Firefox defaults to 64-bit mode on Mac OS X 10.6.x and this requires Flash version 10.1 or above. See Flash Plugin - Keep it up to date and troubleshoot problems and http://www.mozilla.com/plugincheck/ for information about updating Flash and checking your Flash version.

If you have Flash 10.1 or above and Flash doesn't work in Firefox 4 Beta unless you set Firefox to run in 32-bit mode:
This problem affects some Mac OS X 10.6 systems but not others. The cause is unclear but you may want to add information about your Mac system specs to this thread.

You can also look over the related bug report,
https://bugzilla.mozilla.org/show_bug.cgi?id=610526
Bug 610526 - Firefox never loads flash in "out of process" mode

(See http://kb.mozillazine.org/Plugin-container_and_out-of-process_plugins for more information on "out of process" plugins.)

As I understand the problem, Firefox 4.0 Beta 7 and above in 64-bit mode is supposed to run 32-bit plugins such as Flash 10.1 in a separate "plugin container" process. For some reason, some Mac OS X 10.6 systems will not run the Flash 10.1 plugin "out of process" and will only run Flash within the Firefox process itself. Since the 32-bit Flash plugin will not load inside the 64-bit Firefox process, you have to set Firefox to run in 32-bit mode.

Another option I've seen suggested is to install the 64-bit Flash player but it's a pre-release ("test") build and should only be considered by advanced users.

Modified by AliceWyman

more options

Firefox gets worse with every update. Firefox used to be the best browser. It's useless now. The beta I installed yesterday contains a new bug: the frame flickers. I'm furious.

more options

το Adobe Flas συνεχος καταρεει

more options

I have the issue where I have to run Firefox 4 in 32 bit mode to get flash working. I've installed the latest Flash version (10.2.152.26).

I'm running Mac Os 10.6 on a Mac mini with Model Identifier Macmini2,1 (2 Ghz Intel Core 2 Duo)

more options
more options

kmfs,

Have you tried it in Firefox 4 Beta 12?

See Bug 610526 ... the issue should now be fixed.

more options

Forbidden

You don't have permission to access /cgi-bin/&radio_button=a000&text_box_BasSaat=000000&text_box_BitSaat=240000&text_box_bas_gun=23&text_box_bas_ay=06&text_box_bas_yil=2011&text_box_bit_gun=23&text_box_bit_ay=06&text_box_bit_yil=2011&sel_bas_saat=00&sel_bas_dk=00&sel_bit_saat=24&sel_bit_dk=00&text_box_min_tutar=&text_box_max_tutar=&radio_button_etip=+&submitbutton=++++Onay+&backbutton=++++Geri+&DUMMY=0.8962039116695215 on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.