Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Am I the only one that can't watch videos on Youtube, and Vkontakte on the new Firefox beta 7?

  • 27 replies
  • 505 have this problem
  • 1423 views
  • Last reply by cor-el

more options

I can't watch embedded videos on Youtube, Vkontakte, Daily Show or anywhere. I can just see the image but I can't see the video.

Modified by fernandodabdoub

Chosen solution

Hey,

go to Tools > Add-ons | Plugins tab.

Is Flash player installed?

 

Cheers,

Tobbi

Read this answer in context 👍 9

All Replies (20)

more options

Chosen Solution

Hey,

go to Tools > Add-ons | Plugins tab.

Is Flash player installed?

 

Cheers,

Tobbi

more options

Thanks for the reply.

yes, it's installed

Flash 10.0.45

more options

This is what is see, in the second image, i can just see the image but i can't click play.

more options

how to get beta 7? i am on 3.x latest one.

more options

Dear Firefox Team,

Thanks for making such a wonderful browser...

I too have the same problem. It just run any videos just fine with the previous beta 6. I'm running mac os x 10.6.4 with 64 bits kernel enabled.

more options

Make sure that you have the latest version of the Flash Player (10.1 r102).

more options

The problem is solved after I'm upgrading my OS X to 10.6.5. I wonder whether the upgrade or the restart that cure the problem since I haven't restart it for a month, ;).

more options

I'm having this problem as well. I'm fully updated to OSX 10.6.5, fully updated to flash 10.1.102.64, and running beta 7. I just get a black box when I visit sites like Youtube and no video or image at all. Every site I've visited on this machine that uses flash seems to have a problem (for example, on nvidia.com, the "Choose your location" flash intro doesn't play).

more options

Still some problem with the flash... it crash so often (The Adobe plugin has crashed ... no report available). This never happened before in beta 6 since I often put 20 tabs of youtubes open for weeks.

more options

I have 10.6.5 updated, flash updated, and also cannot see videos. Black screen where the video should play. I reinstalled 4.07 and Flash. I already had 10.6.5 and am up to date with software upgrades. It was fine with 4.06 and is not working with 4.07. How can I go back to 4.06?

more options

PS the Tools>Add-ons>Plug-Ins shows Flash is enabled,

more options

@nlkflint

Please post your problem only in one thread or better create your own thread.
Then you can post all your system details and you can get full attention.

more options

The crash that I reported before is reproduce-able when you buffer many videos at once and then close any tab (one tab is enough) that contains the flash video, then the rest is just crashed with the message I mentioned before.

more options

Can you try setting dom.storage.enabled in about:config to true?

(Go to about:config and find that setting, double click to set to true if it's false). Some people have reported that having it false affects flash videos.

more options

Hi Cww, I checked on that setting and it is already set to true for me.

more options

I'm having this problem as well. I'm fully updated to OSX 10.6.5, fully updated to flash 10.1.102.64, and running beta 7. I just get a black box when I visit sites like Youtube and no video or image at all. Every site I've visited on this machine that uses flash seems to have a problem (for example, on nvidia.com, the "Choose your location" flash intro doesn't play).
---luminoth

I have Firefox 4 Beta 7 on my new iMac computer with the latest OS X 10.6.5 and Flash 10.1.102 updates. I have no problem viewing Flash videos (including full-screen videos) like those on YouTube.com and the www.nvidia.com "Choose your location" animation you mentioned works just fine. My iMac has an ATI Radeon HD 4670 graphics display (256mb) and not nVidia, by the way.

As a workaround, try disabling Hardware Acceleration in your Flash Player settings:

  1. Control-click (right-click) on any Flash video or animation (even the "Adobe Flash Player Successfully Installed" Flash object at the top of the http://www.adobe.com/software/flash/about/ page)
  2. Click on "Settings"
  3. Clear the "Enable hardware acceleration" checkbox on the display tab.

Ref:

P.S. If the above doesn't help, there are other suggestions you can try, here:

Modified by AliceWyman

more options

Unfortunately, I can't disable hardware acceleration because the popup menu you would normally get, isn't there. For example, when I go to a youtube video and control click on the black square where a video should be, I get the firefox control click menu instead. If I go to a site like blip.tv, there isn't even the black box where the video should be for me to click on.

It may be worth noting that for me personally, I'm on a fairly old macbook (2006 I think). It has one of those awful Intel GMA 950s in it. Flash worked fine with beta 6, however.

I'll read through the flash troubleshooting document and report back if anything helps.

more options

If you get the regular Firefox right-click context menu instead of the one from the Flash player then that means that the Flash player isn't loaded.

Does the Flash player work on the Adobe test page?

more options

The test page does not work, however both about:plugins and about:addons show that it is loaded and enabled.

  1. 1
  2. 2