X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Auto complete does not work when entering a URL

Posted

firefox 3.10.6 on Fedora Linux fc13 x86_64. Show all history shows the history of visited web sites. "Remember History" is on. The auto complete was working. I did try unchecking view the bookmark toolbar, but not sure if that caused the loss of auto complete.

Chosen solution

Make sure that the Location Bar is not set to "Nothing":
Edit > Preferences > Privacy > Location Bar: When using the location bar, suggest: History,Bookmarks,History and Bookmarks

See Smart Location Bar

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • nspluginwrapper is a cross-platform NPAPI plugin viewer, in particular for linux/i386 plugins.This beta software is available under the terms of the GNU General Public License.
  • The next generation Java plug-in for Mozilla browsers.
  • Shockwave Flash 10.2 d161

Application

  • User Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.10) Gecko/20100920 Fedora/3.6.10-1.fc13 Firefox/3.6.10

More Information

I get an error of too many characters if I try to paste the troubleshooting information.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Chosen Solution

Make sure that the Location Bar is not set to "Nothing":
Edit > Preferences > Privacy > Location Bar: When using the location bar, suggest: History,Bookmarks,History and Bookmarks

See Smart Location Bar

Question owner

cor-el: Thanks for the post. Your suggestion worked fine, so the problem is solved.

Regards, Doug

masteringalchemy 0 solutions 1 answers

Helpful Reply

I tried that and it doesn't work. I have Mac OX v 10.6.4 . Anyone have a clue? It's very frustrating. thanks.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

This can be a problem with the file places.sqlite that stores the bookmarks and the history.

mattseanbachman 0 solutions 1 answers

I had this problem very recently with a firefox update. For those of you who might have the same issue, cor-el's solution works but with a slight modification. On my version of firefox (13.0.1), the steps are as follows:

1) Press 'alt,' go to 'Tools' on the upper bar.

2) Select 'Options' on the drop-down menu

3) Select 'Privacy'

4) Near the bottom, under the section 'Location bar,' select 'History and Bookmarks.'