Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

PDF printing with PDFCreator not working optimally in FireFox4. Can firefox3 printing be enable?

  • 9 replies
  • 226 have this problem
  • 942 views
  • Last reply by genericadm

more options

In Firefox 4 printing seems to have changed in a way that negatively impacts PDF printing. I use PDFCreator an open source PDF printer. Changes to Firefox 4 seem to make it impossible to pass of text to a ghostscript style PDF printer rather it hands off all the text as images which makes the PDF files much larger and none searchable. Is there a way to disable this behavior in Firefox 4 so that works like it did in 3?

PS This problem seems to impact all PS2PDF/Ghostscript based PDF printers/virtual printers including PDFCreator, CutePDF, BullZip and others

Modified by RichN

All Replies (9)

more options

Hi,

I had this problem too. I found a workaround though: Run Firefox 4 in Safe Mode, which disables all addons. The PDF when printed will be searchable and very low in size.

The key now is to find out which addon is breaking this function. Hope others can do some testing and shed some light on this.

more options

I think the problem isn't related with add-ons, but new font rendering features, as Direct2Draw and other things linked with hardware acceleration.

I wonder with "safe mode", the hardware acceleration is disable?

more options

Yes, I believe that Hardware Acceleration is disabled in the Firefox SafeMode. It can also be disabled in Tools > Options > Advanced.

more options

The problem is Hardware Acceleration. I have tested this issue extensively with FireFox 4 Beta 10. The frustrating part is disabling Hardware Acceleration in Tools > Options > Advanced only works after a restart of FireFox. I tried everything to avoid a restart, opening a new tab, reloading the page, opening a new window. Changing the Hardware Acceleration requires a restart.

I print PDFs so often I guess is just have to disable Hardware Acceleration altogether.

Here is a quick example of the page size difference. If you print this page as a PDF with PDFCreator 1.2.0 and hardware acceleration enabled the size is 892 KB. If you disable hardware acceleration the size is 177 KB.

I wish there was something the FireFox team could do to improve this situation.

more options

works for me now. Thanks for sharing

more options

Thank you!!! This was a seriously not intuitive fix: good find!!! I spent a lot of time wasted on this re-installing programs and hacking the registry paths. Who would have thought: "Hardware acceleration" ? Thanks!!!!

more options

I have facing the same issue which I didn't face with previous versions of Firefox. I use doPDF software to print a web page into a PDF file. In previous versions of Firefox, the PDF files created using this doPDF software was text searchable, but the new Firefox doesn't allow doPDF to create a text searchable PDF file, rather it makes doPDF to create a PDF file where texts are embedded as images.

It is a problem of Firefox, because I have made a PDF copy of a same webpage in Firefox and Google Chrome using the same doPDF software and I found that only the one made in Firefox was not a text searchable PDF file while the one made in Google Chrome was completely okay.

more options

Thanks !

more options

I'm having the same problem! Text is being converted to images in the resulting PDFs. It's annoying and it makes the PDFs far less useful - not text searchable and larger file sizes.

I tried turning off "hardware acceleration" (FF 7.0.1) and it didn't work. And yes, I both restarted Firefox and restarted my PC. I also tried starting in Safe Mode and that didn't resolve it, either.

I'm also experiencing the same PDF output from the same page (a website) from IE (8.x) and Safari (5.34). YES, I'm sure the page is text.

I was running PDFCreator 0.98. I upgraded to the latest version (1.2.3) hoping it would help resolve the issue, but it hasn't.

Any other ideas or tips? Are there specific settings in PDFCreator I should try?