X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox keeps creating the folder "Downloads"

Posted

Using 3.6.10

Firefox keeps creating the "Downloads" folder in my documents even though the folder I specified for the downloads is different..

C:\MyDocs\Downloads\ < keeps getting created C:\Downloads\ < is where I told FF to put downloads

It's driving me nuts! lol. Even tried installing a download manager to see if it did anything and it didn't fix the issue... :(

Chosen solution

I have been doing some checking and the folder is created automatically and there is no way to disable it.

There is a bug report concerning this behavior - Bug 474718 – Empty "Downloads" folder should not be created when opening main page of options dialog

(please do not comment on bug reports)

Read this answer in context 1

Additional System Details

This happened

Every time Firefox opened

This started when...

Installed 3.6.10 on my new harddrive XP NTFS 2 days ago...

Installed Plug-ins

  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.448
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.4"
  • Default Plug-in
  • Shockwave Flash 10.1 r85
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • 4.0.50826.0
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 (.NET CLR 3.5.30729)

More Information

Application Basics
Name
Firefox
Version
3.6.10
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Java Console
6.0.20
true
{CAFEEFAC-0016-0000-0020-ABCDEFFEDCBA}
Microsoft .NET Framework Assistant
1.1
true
{20a82645-c095-46ed-80e3-08825760534b}
Firefox Synchronisation Extension
7.3.3.42
true
{A27F3FEF-1113-4cfb-A032-8E12D7D8EE70}
Java Quick Starter
1.0
true
jqs@sun.com
Download Manager Tweak
0.9.2
true
{F8A55C97-3DB6-4961-A81D-0DE0080E53CB}
Adblock Plus
1.2.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
FlashGot
1.2.1.31
true
{19503e42-ca3c-4c27-b1e2-9cdb2170ee34}
Noise
1.2
true
noise@bootleq
New Tab Homepage
0.4.2
true
{66E978CD-981F-47DF-AC42-E3CF417C1467}
Java Console
6.0.21
true
{CAFEEFAC-0016-0000-0021-ABCDEFFEDCBA}
CuteMenus2
3.1
true
{71C54606-83ED-4ea6-9315-1AAB29466D33}
Modified Preferences
Name
Value
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://rogers.yahoo.com/
browser.startup.homepage_override.mstone
rv:1.9.2.10
extensions.lastAppVersion
3.6.10
general.useragent.extra.microsoftdotnet
(.NET CLR 3.5.30729)
network.cookie.prefsMigrated
true
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false

TonyE
  • Moderator
1041 solutions 8840 answers

Helpful Reply

Try resetting all of the preferences relating to the download directory.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. In the filter box type browser.download to bring up a small number of preferences
  4. For any preference that has a value set to a folder, right-click on it and choose Reset
  5. Now set the download folder in the Options dialog again

If it still creates the folder, try clearing the list of downloaded files in the download manager. In the Tools menu select Downloads, then click on the Clear List button.

Question owner

I'm afraid that didn't do it. The downloads folder keeps getting created, I even uninstalled the download manager completely, rebooted and tried again and this thing still happens :'(

TonyE
  • Moderator
1041 solutions 8840 answers

Chosen Solution

I have been doing some checking and the folder is created automatically and there is no way to disable it.

There is a bug report concerning this behavior - Bug 474718 – Empty "Downloads" folder should not be created when opening main page of options dialog

(please do not comment on bug reports)

Modified by TonyE

Question owner

well atleast i know im not the only one going nuts lol.

thx for the info, will wait for patch/update :)

Michael_Scolder 0 solutions 4 answers

Yeah, it's driving me nuts too. Anything that "invades" the My Documents folder is takin' a little too much liberty with disk real estate. "My" means me, myself and I.