X
Tap here to go to the mobile version of the site.

Support Forum

I am continually getting the following error message ... what happened:TypeError: Components.classes['@mozilla.org/extensions/manager;1'] is undefined

Posted

I am constantly getting the following error message ...

what happened:TypeError: Components.classes['@mozilla.org/extensions/manager;1'] is undefined

I am constantly getting the following error message ... what happened:TypeError: Components.classes['@mozilla.org/extensions/manager;1'] is undefined

Chosen solution

That is an indication of a problem with an add-on that is not compatible with Firefox 4 beta. You can try disabling your extensions until you find the one causing the problem. See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems for more details on how to fix this.

I see by your user agent string that you have the Ask toolbar, I don't think that toolbar has been updated to work with Firefox 4, try disabling that one first.

Read this answer in context 70

Additional System Details

This happened

Every time Firefox opened

This started when...

I installed beta 4

Installed Plug-ins

  • Provides additional functionality on Facebook. See our web site for details.
  • Shockwave Flash 10.1 r53
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • iTunes Detector Plug-in
  • GEPlugin
  • Picasa plugin
  • 4.0.50524.0
  • Office Live Update v1.5
  • NPWLPG
  • Google Updater pluginhttp://pack.google.com/
  • Google Update
  • Next Generation Java Plug-in 1.6.0_17 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.4"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4) Gecko/20100818 AskTbARS/3.8.0.12304 Firefox/4.0b4

More Information

this also happens when I move from site to site within Firefox

TonyE
  • Moderator
1034 solutions 8840 answers

Chosen Solution

That is an indication of a problem with an add-on that is not compatible with Firefox 4 beta. You can try disabling your extensions until you find the one causing the problem. See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems for more details on how to fix this.

I see by your user agent string that you have the Ask toolbar, I don't think that toolbar has been updated to work with Firefox 4, try disabling that one first.

That is an indication of a problem with an add-on that is not compatible with Firefox 4 beta. You can try disabling your extensions until you find the one causing the problem. See [[Troubleshooting extensions and themes]] for more details on how to fix this. I see by your user agent string that you have the Ask toolbar, I don't think that toolbar has been updated to work with Firefox 4, try disabling that one first.

Question owner

Thank you ... this worked ... I disabled the Ask toolbar

Thank you ... this worked ... I disabled the Ask toolbar
ashkee 0 solutions 1 answers

Helpful Reply

I get that same popup every time I click on notifications on facebook. Also, I do not have any toolbars installed

I get that same popup every time I click on notifications on facebook. Also, I do not have any toolbars installed

Modified by ashkee

robbe69 0 solutions 1 answers

Ask toolbar is disabled, still got the same popup error

Ask toolbar is disabled, still got the same popup error
B33JAY 0 solutions 1 answers

I keep getting an error code. It is sec_error_expired certificate, It asks me to view the certificate then it doesn't allow mew to fix the problem

I keep getting an error code. It is sec_error_expired certificate, It asks me to view the certificate then it doesn't allow mew to fix the problem
cor-el
  • Top 10 Contributor
  • Moderator
11998 solutions 111494 answers

Check the date and time in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

See Troubleshoot the "Secure Connection Failed" error message

Check the date and time in the clock on your computer: (double) click the clock icon on the Windows Taskbar. See [[Secure Connection Failed]]
fazli 0 solutions 1 answers

I got an error message while copying a text and pasting it into google translation section on Firefox 4.0 Beta. It says "Do not have enough storage space to process this command." This happened after doing some copy and paste work. I mean it didn't happen at first.

I got an error message while copying a text and pasting it into google translation section on Firefox 4.0 Beta. It says "Do not have enough storage space to process this command." This happened after doing some copy and paste work. I mean it didn't happen at first.
jleesoto 0 solutions 1 answers

There are three successive error messages before firefox starts. With the RC version the browser will load, in Beta 11 it would open but not connect to the internet. These are the messages.

[JavaScript Application] JavaScript fails to instanciate interface component!

[JavaScript Application] TypeError:_CHARTER_INST_.DTFox is undefined

[JavaScript Application] load: TypeError: Components.classes['@checkpoint.com/XPCOMTrustCheckerMozilla /TrustCheckerMozilla;1'] is undefined

These addons were recommended and I installed them, Addon Compatibility Reporter and Feedback. This is when the problem first occurred.

There are three successive error messages before firefox starts. With the RC version the browser will load, in Beta 11 it would open but not connect to the internet. These are the messages. [JavaScript Application] JavaScript fails to instanciate interface component! [JavaScript Application] TypeError:_CHARTER_INST_.DTFox is undefined [JavaScript Application] load: TypeError: Components.classes['@checkpoint.com/XPCOMTrustCheckerMozilla /TrustCheckerMozilla;1'] is undefined These addons were recommended and I installed them, Addon Compatibility Reporter and Feedback. This is when the problem first occurred.
arvan66 0 solutions 5 answers

type error:components.classes{'@mpzilla.org/manager;1']is undefined this is my problem

type error:components.classes{'@mpzilla.org/manager;1']is undefined this is my problem
arvan66 0 solutions 5 answers

type error:components.classes{'@mpzilla.org/manager;1']is undefined this is my problem

type error:components.classes{'@mpzilla.org/manager;1']is undefined this is my problem
arvan66 0 solutions 5 answers

TypeError: Components.classes['@mozilla.org/extensions/manager;1'] is undefined

TypeError: Components.classes['@mozilla.org/extensions/manager;1'] is undefined
arvan66 0 solutions 5 answers

TypeError: Components.classes['@mozilla.org/extensions/manager;1'] is undefined

TypeError: Components.classes['@mozilla.org/extensions/manager;1'] is undefined
arvan66 0 solutions 5 answers

TypeError: Components.classes['@mozilla.org/extensions/manager;1'] is undefined when i'm trying to use mozilla that happend

TypeError: Components.classes['@mozilla.org/extensions/manager;1'] is undefined when i'm trying to use mozilla that happend
chgoteddy 0 solutions 1 answers

I get similar errors. When I log onto some of my most used sites, the images don't appear and the site is almost entirely text. This does not work with bitmapped link images on sites like http://news.nnyln.net/feedback.html where I depend on the newspaper articles for genealogy research.

When I go to sides like http://www.cdcovers.cc/list/dvd/a and try to download cover art, if get a "TypeError: 0ticket undefined" message.

How do I correct this?

I get similar errors. When I log onto some of my most used sites, the images don't appear and the site is almost entirely text. This does not work with bitmapped link images on sites like http://news.nnyln.net/feedback.html where I depend on the newspaper articles for genealogy research. When I go to sides like http://www.cdcovers.cc/list/dvd/a and try to download cover art, if get a "TypeError: 0ticket undefined" message. How do I correct this?
AliceWyman
  • Moderator
193 solutions 2215 answers

Since the thread owner has marked the issue as "solved" I'm locking this thread. If anyone has other questions please start a new thread.

Since the thread owner has marked the issue as "solved" I'm locking this thread. If anyone has other questions please start a new thread.