X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

svchost.exe goes to 100% CPU as soon as Firefox 3.6.6 starts

Posted

Since upgrading to Firefox 3.x (currently 3.6.6), as soon as Firefox opens the first browser window after launch, the CPU usage goes to 100% due to a new instance of svchost.exe being opened. Firefox.exe is not using the memory, svchost.exe is using it. This is true on all of my computers running XP, the fastest one clears the 100% CPU in less than a minute and that svchost.exe disappears, the medium one in less than 2 minutes, and the slowest oldest one stays locked up by 100% CPU for 10-15 minutes. Avast antivirus and Spybot all up to date with no issues, these computers all behave normally if Firefox is not opened. This did not occur on these same machines when Firefox 2.x was running. Lots of references to this all over the internet, "memory leak" in Firefox, etc. It is not due to accessing a Flash webpage, my homepage is a JPG image with no Flash, and on the slowest computer I uninstalled Flash with no effect. What gives?

This happened

Every time Firefox opened

== Upgraded to Firefox version 3.x away from 2.x

Additional System Details

Installed Plug-ins

  • -Google Talk Plugin Video Accelerator version:0.1.43.2
  • Adobe Shockwave for Director Netscape plug-in, version 11.0
  • Adobe PDF Plug-In For Firefox and Netscape
  • 6.0.12.69
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Shockwave Flash 10.1 r53
  • Google Update
  • GEPlugin
  • 3.0.50106.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Rhapsody Player Engine Plugin
  • Java(TM) Platform SE binary
  • Next Generation Java Plug-in 1.6.0_17 for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6

More Information

see above

Question owner

continuing 98-100% CPU in svchost.exe

Question owner

Installed the latest upgrade. was good for about an hour...then when I tried to play a video, svchost.exe took all the memory

Question owner

na

Question owner

I have had the same problem with 3.6.6, also with 3.6.8 which I just upgraded to.

Question owner

If I use dialup I can load Firefox and have it connect to the net separately. Loading the program itself doesn't cause the problem, but the moment the dialup modem handshakes and Firefox connects to the internet, svchost.exe appears in Task Manager and hogs 100% of CPU usage. This prevents Firefox from even loading my homepage while svchost.exe is operating. WHEN are they going to fix this????

Question owner

Thanks for the reply. Dial-up isn't much of an option for me. I'm also surprised that the problem has been around for so long and not even been addressed / acknowledged by Mozilla.

cerepukas 0 solutions 1 answers

Go to Control Panel, Administrative Tools, Services. Then find the DNS Client on it twice with the left mouse button. It appears (C: \ WINDOWS \ system32 \ svchost.exe-k NetworkService) made the startup type - Manual. Restart your computer. The browser will run without any problems, because the same problem and have been for me.

Jaykay 0 solutions 9 answers

You might love this reply: I too had svchost.exe issues since about Apr23rd. Reading help forums and Googling (is that now officially a verb?) I found HowToGeek.com where I read a post on svchost.exe and Windows Services. It turns out they are linked big-time.

Heavy on internal-systems learning curve for my Dell XP laptop in which I had removed IE in 2009 switching to Firefox, and then deleted all traces of IE last week, using the registry 'regedit' \ Find function, ... I could not turn to MS for XP support because what was offered needed to be downloaded via IE, not Firefox (I am using Firefox ver. 4.01 ).

So I learned about the following and my CPU usage dropped from 100% and getting shut down due to overheating (happened 3 times last week - but never before) to 4% (yes 4) and purring like a cat!

Ctrl+Alt+Delete opens Windows Task Manager. The Processes tab shows real time usage. I had never seen it before so it was cool, but otherwise not so useful in my case.

I then found the HowToGeek post that provided a good explanation of what is occurring with the svchost.exe file(s) and Windows Service settings here: http://www.howtogeek.com/howto/windows-vista/what-is-svchostexe-and-why-is-it-running/.

Between the actual post and all of the comments below it, I found these 3 key FREE pieces of my puzzle.

Process Explorer by Sysinternals (which was then purchased by MS.) This eye-popper software shows you in real-time what the Windows Service component of the computer is doing. Get it here: http://technet.microsoft.com/en-us/sysinternals/bb896653.

Once you get over that thrill ... or chill, you need a tool to actually let you make choices as to what is set to Automatically run and is Running, and what could be set to Manual and Running (if needed), or even set to Stopped. You will see that the svchost.exe file was created to manage groups of system functions - so you actually have many svchost.exe files.

This awesome and sometimes hilariously witty site ('recommended by 4 out of 5 dentists) www.Mindswarm.com has a free program named 'Service Studio'. This is the key to a happy future for your computer and your patience. Here's the link: http://www.mindswarm.com/. It's even better than it looks.

Finally, the critical last link: www.blackviper.com's free Guide to Windows XP & Vista Service settings. I used the most conservative settings recommended titled "SAFE". They worked brilliantly for me yesterday. If all continues to run smoothly for another week (Process Explorer says my CPU usage is now about 1.56% to 9.3%) then I will use Service Studio again to use Black Viper's "TWEAKED" settings. If all stays well, I will try "BARE BONES" lastly. The Black Viper post is here: http://www.blackviper.com/2008/05/19/black-vipers-windows-xp-x86-32-bit-service-pack-3-service-configurations/#more-3025.

For what it is worth, I printed out the entire BV post, then checked things off as I made the Service setting changes. Twice the program stopped and closed down. I found each time that the setting changes I made stayed and were SAVED. I attributed it to the mess my XP Settings were in (I had about 48 process lined up in the Start menu as every software wants top billing, easy access, etc). As I 'Stopped' some processes, I believe that action caused the program stoppage. I chose to change all non-Windows software settings from Automatic & Running, to Manual & Stopped for things like my Adobe, Dell, Google, & Java programs. Manual gives the OS the ability to load it up on-demand vs front-loading the program and eating up CPU Usage. There were no exceptions except my 2 security programs (Avast! and AVS4You firewall) and of course, Stickies.

I restarted, completed the recommended setting changes and then restarted again. As if by magic, my XP laptop is running swiftly, smoothly and shuts down in under 33 seconds - all settings saved. Runs like a deer and slams like Pippen! I like to say.

I still have a few issues to learn about and clear-up, but I am thankfully amazed at the excellent quality of techno-geek help the above teams and programs provided. If anyone else is also helped by the above process, then I will have felt I have honored their efforts and passed along this gift. Jaykay

Modified by Jaykay