Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

i had been trying to get some personas for my mozilla but keeps showing my this.."This Persona requires Firefox 3.6. You are currently using Firefox 3.5.5." i'm already dowload and open the newest versions, what's wrong.. i have windows 7

more options

"This Persona requires Firefox 3.6. You are currently using Firefox 3.5.5." I'm already download this version ( windows 7) what's going on, why is not upgrading

All Replies (2)

more options

You posted here with Firefox 3.5.5 on Vista, is that a different PC?

more options

See also http://kb.mozillazine.org/Resetting_your_useragent_string_to_its_compiled-in_default Check the general.useragent prefs on the about:config page. You can open the about:config page via the location bar, just like you open a website. Filter: general.useragent If any general.useragent prefs are bold (user set) then right-click that pref and choose Reset.


See Find what version of Firefox you are using and Web sites or add-ons incorrectly report incompatible browser