X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I stop address bar from suggesting random sites that are incomplete (a link to a button or word, etc), i.e. typing in 'wik' suggests 'facebook.com' instead of 'wikipedia.org', and facebook seems to be dominating these non-logical choices?

Posted

In the location bar, when I begin to type in a website, It suggests a facebook link, or a link to a history/bookmarked site. This suggested link does not direct me to an actual website, but merely a button (such as "recommend this", yet there is nothing to recommend--the site is blank except for the button), or some other facet of html, such as an icon, or a word.

 In summary, when I begin to type in wikipedia, the location bar suggests bookmarks.  Yet, I did not bookmark sites such as facebook, so why does the location bar claim it is one of my bookmarks, indicating such with a gold star?  Instead of suggesting wikipedia, it always suggests facebook.  This makes no sense, thus I am forced to turn off the location bar suggestion regime to 'nothing' rather than 'history and bookmarks'.  This is very annoying, because I like this feature, yet it seems to be malfunctioning at the moment.

Thanks for any insight.

Additional System Details

Installed Plug-ins

  • -Default Plug-in
  • Shockwave Flash 10.0 r45
  • Adobe Shockwave for Director Netscape plug-in, version 11.0
  • iTunes Detector Plug-in
  • Delivery Network Acceleration by BitTorrentâ„¢
  • DivX Web Player version 2.0.0.254
  • Google Update
  • Java Plug-in 1.6.0_10 for Netscape Navigator (DLL Helper)
  • Java(TM) Platform SE binary
  • Adobe Acrobat Plug-In Version 7.00 for Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6

More Information

Application Basics
Name
Firefox
Version
3.6.6
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Java Quick Starter
1.0
true
jqs@sun.com
Google Gears
0.5.36.0
true
{000a9d1c-beef-4f90-9363-039d445309b8}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
accessibility.typeaheadfind.startlinksonly
true
browser.history_expire_days
0
browser.history_expire_days.mirror
180
browser.places.smartBookmarksVersion
2
browser.startup.homepage
www.google.com
browser.startup.homepage_override.mstone
rv:1.9.2.6
network.cookie.cookieBehavior
1
network.cookie.prefsMigrated
true
places.last_vacuum
1277699636
privacy.clearOnShutdown.cookies
false
privacy.cpd.sessions
false
privacy.cpd.siteSettings
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
security.warn_viewing_mixed.show_once
false

cor-el
  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

You can set the pref browser.urlbar.default.behavior to 33 (visited+typed) or 49 (match url+visited+typed) on the about:config page. See also: http://kb.mozillazine.org/Location_Bar_search http://kb.mozillazine.org/browser.urlbar.default.behavior

To open the about:config page, type about:config in the location (address) bar and press the Enter key, just like you type the url of a website to open a website. If you see a warning then you can confirm that you want to access that page.