Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Error message when uploading files "Attachment failed may be due to proxy or firewall"


Just recently I started getting the error message, "Attachment failed. This may be due to a proxy or firewall." when trying to upload files in Gmail using Firefox latest. Classic uploader works fine but is pain in butt one at a time. It worked fine until two days ago. My Flash player is current. Any ideas?

URL of affected sites


Additional System Details

Installed Plug-ins

  • -getplusplusadobe16263
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.2"
  • Shockwave Flash 10.1 r53
  • iTunes Detector Plug-in
  • GEPlugin
  • Picasa plugin
  • 2.0.31005.0
  • Google Updater pluginhttp://pack.google.com/
  • Google Update
  • Java(TM) Platform SE binary
  • Next Generation Java Plug-in 1.6.0_17 for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll


  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20100401 Firefox/3.6.3 (.NET CLR 2.0.50727)

More Information

hopeful77 0 solutions 1 answers

Attachment failed. This may be due to a proxy or firewall firefox 3.6

drnstvns 0 solutions 2 answers

So elsewhere I am finding that when people disable their Shockwave Plug-In they are then able to attach their files and the majority of people feel it is a Firefox Issue and not a Gmail, Shockwave or Yahoo Mail issue. (I am having the problem with both Gmail and Yahoo.)

 Everyone agrees that although this work around does fix the problem it is hardly an answer because that means constantly having to toggle your Shockwave Plug-In on and off  which, unless you time it just right, is incredibly frustrating since you need it to click "add attachment" then once you have your pop up window and browse to your file(s) you have to go to another window or tab, disable the plug in, wait for that to take effect then click "open" and then your files should attach but sometimes it catches or Gmail too quickly zips to the error message so no real help there HOWEVER  at least now we know the problem is with the Shockwave Plug-in and Firefox.   
    How to fix that?  

*Yells while walking around*

"Helllloooooo!? Confused non-technical honky here! Need to send resumes out to get a job.   Helllooo???!!     Guys if I don't get a job then I have too much time on my hands and end up writing stupid stuff all over different websites and no one wants that!!!


Maybe they're in a meeting.

I'll just wait.

Probably back any second now.

*to self* 

Didn't want to make that Circle K interview today anyway.

Yes a job is a job but I draw the line at paper hats. I have to keep a shred of self respecHELLOOO?!!

  Wow.   *looks around*
  It is SOOO white in here.   
  And ECHO-EE! echo-ee echo-ee    
 HELLO!    hellohellohello 

heh heh heh cool

  *to self* " da da da da na na if you like Pina Coladas and getting caught in the' OOOoooh! Gummi Foxes! Niiiiiicceee! MMMMmmm! Nom Nom Nom 

   *spits it out and looks in hand*    
 Tab Candy. 

HAHA! oh god not the obnoxious uncontrollable nervous laughter. Not nowHAHA!"

Umm hi! *Speaking to no one. Assumes there are security cameras and someone is watching* I, um, probably shouldn't have eaten that. Yeaaaaah. Well. HAHA! I had better get going. SO much to do when you are unemployed ya know? Sift through Craig's List ads, make appointments, write angry letters to KFC management for having better Cole Slaw than my mom,HAHA! email my resumes outtttt

Hey! *snaps finger, just remembers* Which is why I came out here because I can't uplode my resumaaaaaa . . .OH YEAH!. Shockwave. . . . Echo-ee. . . .Tab Candy. . . . yes. Of course I remember. HAHA! I mean it JUST happened HAHA!-- duh! What I mean is Yes. Thank you. I am up to speed now thank you. HAHA!

  • whispers out the side of mouth to no one really*

You know how it is buddy. That old 420. . .ya can't keep a thouGHTTTT! AH! Thought! Umm, I ummm I THOUGHT I should be going pretty soon. Didn't know it was so late.

  • looks at wrist with no watch*
WOW! HAHA 4:20 already! ShoooooWheee. Yes I had better go.
  *taps bald wrist/whispers*

"late." *very loud*


oh God please no more of the laughHAHA! thanks.


* Still to no one *       

I am just gonna sneak outta here and I can just hand deliver those resumes. I mean I really need the excersiz. . . . . . . . . .*SLAM!*

* door reopens * You guys aren't hiring are you? Yeah. No. I didn't think. . . Well here is a copy of my resume I will just set it here in case you want to, ummm, yeah, numbers on there just call whenever and if you know no big whoop. Its cool. So I'll just show myself out and ok. Cool. Oh! Could I get this validated just real quick. . . .

tonyd168 0 solutions 1 answers

I am having the same issue. And it also happens when uploading images onto wordpress and other image programs. And it is a firefox issue and apparently having to do with Shockwave Plug-In. I don;t know what this is what it does or what would happen if I was able to delete it.

moros323 1 solutions 38 answers

You guys are not going to believe this I figured out the problem it's really dumb...ok here goes the attachment uploader loads seperate so I got to thinking it's a popup so I went to options content and under block pop ups there is an option exceptions click on that and in the box type firefox.com and hit allow pow its fixed!!!!! :-)