X
Tap here to go to the mobile version of the site.

Support Forum

When I download Firefox, my computer will not install and claims it is corrupt

Posted

When i download Firefox, my computer will not run the install and claims the file is corrupt.

When i download Firefox, my computer will not run the install and claims the file is corrupt.

Additional System Details

Installed Plug-ins

  • -Netscape Navigator Default Plug-in
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • DivX Web Player version 1.4.0.233
  • Shockwave Flash 9.0 r47
  • Shockwave Flash 9.0 r16
  • Provides support for Digital Rights Management
  • Provides support for Windows Media.
  • ebrary Reader version 2.9b3 - 07/12/05
  • Java 1.3.1 Plug-in (CFM)
  • Macromedia Shockwave for Director Netscape plug-in, version 8.5.1
  • Java 1.3.1 Plug-in

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.20) Gecko/20081217 Firefox/2.0.0.20

More Information

the-edmeister
  • Top 25 Contributor
  • Moderator
5397 solutions 40140 answers

Firefox 2.0.0.20 is the last ever release for Mac OSX 10.3.9 and earlier versions. Which version of OSX do you have?

Firefox 2.0.0.20 is the last ever release for Mac OSX 10.3.9 and earlier versions. Which version of OSX do you have?
Wikiwide 14 solutions 92 answers

Firefox versions 3.0 and higher require OSX 10.4 and higher: http://www.mozilla.com/firefox/system-requirements-v3.html http://www.mozilla.com/firefox/system-requirements.html

Firefox version 2.0.0.20 is the last ever version of Firefox for OSX 10.3.9 and lower.

However, I would think about finding/creating an unofficial build of Firefox 3 for older Mac (if you cannot get next version of Mac OSX). If it's possible. I don't know.

Tiger install DVDs are in short supply. Tiger is no longer available at the Apple Store but may be available for $129 by calling Apple Phone Sales @ 1-800-MY-APPLE (1-800-692-7753).

Tiger Requirements... To use Mac OS X 10.4 Tiger, your Macintosh needs:

  • A PowerPC G3, G4, or G5 processor
  • Built-in FireWire
  • At least 256 MB of RAM (I recommend 1GB minimum)
  • DVD drive (DVD-ROM), Combo (CD-RW/DVD-ROM) or SuperDrive (DVD-R) for installation
  • At least 3 GB of free disk space; 4 GB if you install the XCode 2 Developer Tools
Firefox versions 3.0 and higher require OSX 10.4 and higher: [http://www.mozilla.com/firefox/system-requirements-v3.html] [http://www.mozilla.com/firefox/system-requirements.html] [ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/2.0.0.20/mac/en-US/Firefox%202.0.0.20.dmg Firefox version 2.0.0.20] is the last ever version of Firefox for OSX 10.3.9 and lower. However, I would think about finding/creating an unofficial build of Firefox 3 for older Mac (if you cannot get next version of Mac OSX). If it's possible. I don't know. Tiger install DVDs are in short supply. Tiger is no longer available at the Apple Store but may be available for $129 by calling Apple Phone Sales @ 1-800-MY-APPLE (1-800-692-7753). Tiger Requirements... To use Mac OS X 10.4 Tiger, your Macintosh needs: * A PowerPC G3, G4, or G5 processor * Built-in FireWire * At least 256 MB of RAM (I recommend 1GB minimum) * DVD drive (DVD-ROM), Combo (CD-RW/DVD-ROM) or SuperDrive (DVD-R) for installation * At least 3 GB of free disk space; 4 GB if you install the XCode 2 Developer Tools