X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to set FireFox pages in English? Now it is in Dutch!

Posted

I just installed Firefox. It comes with all information in Dutch (I live in Belgium) I want all the information in English . How to?

Chosen solution

Some sites automatically redirect you to a site in the local language. There is usually a link on such websites choose a language or go to an international version that allows to chose the language. .... If the Google (Firefox) or Yahoo home page is in the wrong language then see: Google: http://www.google.com/support/bin/answer.py?answer=873 Yahoo: http://help.yahoo.com/l/us/yahoo/homepage/troubleshooting/troubleshoot-02.html

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • -Default Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 3.0.40624.0
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Next Generation Java Plug-in 1.6.0_18 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

More Information

Wikiwide 14 solutions 92 answers

Do you mean Firefox is in English, while webpages are in Dutch?

Tools->Options->Content->Languages->Choose...


Do you mean Firefox itself is in Dutch?

English language pack

Install it and restart Firefox.

cor-el
  • Top 10 Contributor
  • Moderator
10779 solutions 97012 answers

Chosen Solution

Some sites automatically redirect you to a site in the local language. There is usually a link on such websites choose a language or go to an international version that allows to chose the language. .... If the Google (Firefox) or Yahoo home page is in the wrong language then see: Google: http://www.google.com/support/bin/answer.py?answer=873 Yahoo: http://help.yahoo.com/l/us/yahoo/homepage/troubleshooting/troubleshoot-02.html

Question owner

Hello, please look at the screenshot this is what I see after installing the suggested English pack and restarted Firefox.

Thanks in advance

cor-el
  • Top 10 Contributor
  • Moderator
10779 solutions 97012 answers

See my post above.

Wikiwide 14 solutions 92 answers

As cor-el said, visit http://www.google.com/support/websear.../answer.py?answer=873


You can also visit this page http://www.google.com/firefox?client=firefox-a&rls=org.moz...


Also check whether this Belgium page is set as your home page:

Tools->Options->General->Home page


Does it help you?

ivorybow 0 solutions 4 answers

I am in Turkey. I have my default homepage set to US Google, and my languages in the Firefox internet preferences set to US English. But I still get pages in Turkish, such as Myspace. Is there anything I can do to force all searches to result in English language pages?