Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When filling out my FAFSA from for governement student loans, their web site tells me I have to have 2.0 to be compatible with their form. I have 3.5 now. How and where can I download 2.0? Thanks for your help!!

  • No replies
  • 7 have this problem
  • 1 view
more options

When filling out my FAFSA government student loan info, the FAFSA web site tells me my version of Firefox does not support their form. I have the 3.5 Firefox browsers, and they said I need 2.0. Where and how can I download the 2.0 version?