Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I get Firefox to append www. and .com to my URL inputs?

  • 4 replies
  • 0 have this problem
  • 15 views
  • Last reply by cor-el

more options

For years I've been able to input a website keyword (let's say "cnn" like in an old report I ran across) and the "www." and ".com" portions would be added without my typing them. Some time ago, this started to fail. Why?

I tried about:config changes that were said to work with the old "cnn" problem report but nothing helps for me.

Also, I use the local Windows Hosts file to give my router a quick reference name to get into it. That too has worked for years but began to fail last year. Inconvenient. The best I could track this down, it has something to do with forced DNS lookups and skipping the old Hosts file. If so, any work around to get my system simplicity back?

Help is appreciated. I liked the challenge of computer geekdom 30 years ago but I'm getting too old for this, well, you know the old saying.

For years I've been able to input a website keyword (let's say "cnn" like in an old report I ran across) and the "www." and ".com" portions would be added without my typing them. Some time ago, this started to fail. Why? I tried about:config changes that were said to work with the old "cnn" problem report but nothing helps for me. Also, I use the local Windows Hosts file to give my router a quick reference name to get into it. That too has worked for years but began to fail last year. Inconvenient. The best I could track this down, it has something to do with forced DNS lookups and skipping the old Hosts file. If so, any work around to get my system simplicity back? Help is appreciated. I liked the challenge of computer geekdom 30 years ago but I'm getting too old for this, well, you know the old saying.
Attached screenshots

All Replies (4)

more options

If you press Ctrl+Enter after typing text in the address bar, instead of just Enter, then Firefox applies that "fixup" and tries to go to the site.

Helpful?

more options

Ctrl+Enter .. yes, it works. However, why isn't just ENTER allowed to work this easily. This is what I, as a old programmer (and not knowing the logic behind the change, call a kludge solution. It allows something to work but makes things more complicated and out of the ordinary than it needs to be (or used to be.) I don't consider this a solution, just a work around unless I hear the technical necessity of forcing a literal alternate action.

Thanks for the info, though.

Helpful?

more options

Here's the background:

Before Firefox 104, if you disabled searching from the address bar (by setting keyword.enabled to false), Firefox would automatically apply the "fixup" syntax to address bar input like cnn when DNS didn't return an address for the input.

Following reports of malicious sites (like https.com) getting loaded due to user typos, in Firefox 104, the developers switched to the current approach of performing DNS lookups on both the literal input and the fixed up input and presenting the error page with a link instead of proceeding to the fixed up domain automatically.

At the time, and through Firefox 118, it was possible to revert this change (by setting browser.fixup.alternate.enabled => true). However, that preference was removed in Firefox 119.


As for the hosts file, Firefox should normally fall back to Windows for domain resolution if the string isn't in the DNS over HTTPS server, and Windows will supply the address from the hosts file. See: Firefox DNS-over-HTTPS.

Helpful?

more options

Note that the Ctrl+Enter fixup is controlled by browser.urlbar.ctrlCanonizesURLs in about:config.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.