Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I run IOS 10.9.5 on an older Mac. Is Firefox 78.15 as far as I can go with updates?

more options

My bank requires Firefox version 104 now to log-in for security. I have an older Mac, running IOS 10.9.5 (can't update any further) and Firefox 78.15.0. Am I stuck buying a new Mac?

My bank requires Firefox version 104 now to log-in for security. I have an older Mac, running IOS 10.9.5 (can't update any further) and Firefox 78.15.0. Am I stuck buying a new Mac?

All Replies (1)

more options

Hi, yes, the last Firefox release for your version of Mac OS is 78.15.0esr.

Besides a new computer, you also could try using an iOS or Android tablet browser for sites that won't work with older browsers on Mac.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.