Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why all of a sudden IS FIREFOX INTERFERING WITH SITES I have gone to in the past with no problem?

  • 3 replies
  • 0 have this problem
  • 12 views
  • Last reply by cor-el

more options

I've been trying to pay Home Depot for a week and, even though I used to be ALLOWED to go to Home Depot.com now Firefox is blocking me. This is the message I get when Firefox INTERFERES with my browsing choices (I CAN'T CONTACT WEBSITE TO WARN THEM BECAUSE FIREFOX IS BLOCKING ME

Secure Connection Failed

An error occurred during a connection to www.homedepot.com. SSL peer reports incorrect Message Authentication Code.

Error code: SSL_ERROR_BAD_MAC_ALERT

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.
I've been trying to pay Home Depot for a week and, even though I used to be ALLOWED to go to Home Depot.com now Firefox is blocking me. This is the message I get when Firefox INTERFERES with my browsing choices (I CAN'T CONTACT WEBSITE TO WARN THEM BECAUSE FIREFOX IS BLOCKING ME ''Secure Connection Failed An error occurred during a connection to www.homedepot.com. SSL peer reports incorrect Message Authentication Code. Error code: SSL_ERROR_BAD_MAC_ALERT The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem.''

All Replies (3)

more options

I guess the only way to fix this is TO DISCONTINUE USING FIREFOX.

Helpful?

more options

As the first step, try clearing Firefox's web content cache. The steps are in the following article:

How to clear the Firefox cache

Next, prevent Firefox from using a system-level proxy. Open the Settings/Preferences page using either:

  • "3-bar" menu button (or Tools menu) > Settings or Firefox menu > Preferences
  • type or paste about:preferences into the address bar and press Enter to load it

In the very tiny search box at the top of the page, type proxy and Firefox should filter to the "Network Settings" section.

Click the Settings button, select "No Proxy" near the top of the dialog, and click OK near the bottom of the dialog.

Any yet difference?

Helpful?

more options

This could be a problem with the TLS 1.3 Early Data feature also known as Zero Round Trip Time Resumption (0rtt). You can try to set security.tls.enable_0rtt_data = false on the about:config page to disable this feature until this is fixed by Google or Mozilla to see if that helps.

You can open the about:config page via the location/address bar. On the warning page, you can click "Accept the Risk and Continue"to open about:config.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.