Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Top Sites missing

  • 3 replies
  • 1 has this problem
  • 9 views
  • Last reply by tao101

more options

I updated Firefox today to 100.1.1. My previous version may have been a year old. "Top Sites" on the homepage has disappeared. I can still choose "Add to top sites" from the menu, but cannot see the results of those taps, old sites or newly added sites. The rest of my bookmarks are intact...assuming there is any connection between the two. Is there a low level trick to bring them back, or is this a bug?

I noticed a very similar thread from 2020, but with no resolution:

https://support.mozilla.org/en-US/questions/1301109

I updated Firefox today to 100.1.1. My previous version may have been a year old. "Top Sites" on the homepage has disappeared. I can still choose "Add to top sites" from the menu, but cannot see the results of those taps, old sites or newly added sites. The rest of my bookmarks are intact...assuming there is any connection between the two. Is there a low level trick to bring them back, or is this a bug? I noticed a very similar thread from 2020, but with no resolution: https://support.mozilla.org/en-US/questions/1301109

Modified by tao101

Chosen solution

It's s recent bug documented here: https://bugzilla.mozilla.org/show_bug.cgi?id=1768070 . The workaround is to enable Shortcuts under Homepage.

Read this answer in context 👍 0

All Replies (3)

more options

Well, I upgraded to the January build of IceRaven, and "Top Sites" works, so I am guessing this IS a bug and whatever broke happened in the last few months. Does anybody know off the top of their head if there's an open bug ticket?

Helpful?

more options

FYI, "Top Sites" didn't sync via the Firefox sync service, so bookmarks and sites are apparently apples and oranges. But this small shortcoming might be worthy of a future tweak.

Helpful?

more options

Chosen Solution

It's s recent bug documented here: https://bugzilla.mozilla.org/show_bug.cgi?id=1768070 . The workaround is to enable Shortcuts under Homepage.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.