Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

PR_END_OF_FILE_ERROR

  • 5 replies
  • 7 have this problem
  • 383 views
  • Last reply by info7835

more options

PR_END_OF_FILE_ERROR Foxfire will not open

PR_END_OF_FILE_ERROR Foxfire will not open

All Replies (5)

more options

chiefmadison said

PR_END_OF_FILE_ERROR Foxfire will not open

Are you getting the error, or is Firefox not opening?


Web search: https://www.bing.com/search?q=pr_end_of_file_error

radi.stoyanov said Turns out the option DNS over HTTPS is what caused the problem.

jamesafuf123 said https://support.mozilla.org/en-US/questions/1264659#answer-1237475 my ISP was blocking sites like that

cor-el said This usually means that Firefox wasn't able to find a cipher suites to use to connect to this server and reached the end of the list. There can be two possibilities: one is that the server is outdated and doesn't support modern cipher suites, another might be that the server only supports a few cipher suites and Firefox doesn't support any of these.

You can check your browser and possibly compare this with the server setup. https://www.ssllabs.com/ssltest/viewMyClient.html


https://appuals.com/pr-end-of-file-error/

more options

I've been seeing this a lot in the last week, on Linux. Even got it connecting to support.mozilla.com. Often get it with Bing's outgoing links, which redirect through Bing. After a few retries, links usually work.

Firefox 105.0.3, auto-installed via snap. I'm seeing it on two Linux machines, one Ubuntu 20.04 LTS and one Ubuntu 22.04 LTS. Internet connection is hard-wired gigabit fiber from Sonic, with no proxies or middleboxes. (Sonic makes a point of not having middleboxes and being transparent.)

Turned off Firefox HTTPS DNS via Cloudflare. Now using Sonic's default DNS. DNS lookups for sites with problems. Not much change.

Pages which stall in Firefox do not stall when read with curl, so it's a Firefox problem.

Something changed recently in Firefox and broke this, it looks like. I've been using Firefox for years without this problem. (nagle@animats.com) Somehow got logged in anonymously

Modified by info7835

more options

Turned off certificate revocation check, and things seemed to improve. More later.

more options

You can try to disable DNS over HTTPS.

Are you using a proxy or VPN?

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

See also:

more options

No, that wasn't it. It's something involving connection initiation, either DNS or TLS handshakes, but haven't found it yet.