Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mozilla Firefox upgrade

  • 1 reply
  • 1 has this problem
  • 9 views
  • Last reply by Mike Kaply

more options

Hi.


I hope you can help me to figure out how to upgrade Firefox properly when not using Mozilla Maintenance Service . If I do upgrade Mozilla Firefox manually (running exe installation) or forcing upgrade for thousands computer through Central management, profiles will blow up.

It is popping for the users: 

You've launched an older version of Firefox Using an older version of Firefox can corrupt bookmarks and browsing history already saved to an existing Firefox profile. To protect your information, create a new profile for this installation of Firefox.

It is not related to central management because I've tried to install manually by executing Firefox exe executable - firstly to install Mozilla Firefox 97.0 and after that 98.0 and I've got the same error.


Thank you

Hi. I hope you can help me to figure out how to upgrade Firefox properly when not using Mozilla Maintenance Service . If I do upgrade Mozilla Firefox manually (running exe installation) or forcing upgrade for thousands computer through Central management, profiles will blow up. It is popping for the users: You've launched an older version of Firefox Using an older version of Firefox can corrupt bookmarks and browsing history already saved to an existing Firefox profile. To protect your information, create a new profile for this installation of Firefox. It is not related to central management because I've tried to install manually by executing Firefox exe executable - firstly to install Mozilla Firefox 97.0 and after that 98.0 and I've got the same error. Thank you
Attached screenshots

All Replies (1)

more options

That error only happens if you're downgrading a user. The current version of Firefox is 99, so it sounds like you're pushing 97 or 98 to users that have 98.

You can prevent this error by launching Firefox with the --allow-downgrade parameter or setting the MOZ_ALLOW_DOWNGRADE environment variable to 1.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.