Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Default action "Edit draft message"

more options

Somewhen before or with 91.2.1, the default action when opening an existing email became "Edit draft message." (W10 19043, synching to GMail) That setting is nonintuitive and just wrong. A default should NEVER be an action that commits to an irreversable behavior path. Please fix.

This extremely bad design "feature" has apparently been around quite a while and generates exactly the problems returned by a search here on "delete attachments Thunderbird." I first noticed the behavior just about the time GMail introduced two-factor authentication. Maybe no connection there, but ...

Chosen solution

There may be little or nothing to do in the account settings.

First ensure you are using the ALL folders view THe other folder views tend to be built on searches, so when fixing things start with the base all view to make sure the problem is real and not a result of the search being munged.

Check the account the folders are in (right click settings), copies and folders and ensure the correct item (folder) is set for drafts. If it is not correct it.

Then install this addon https://addons.thunderbird.net/en-US/thunderbird/addon/folderflags/?src=search

Use it to correct the flags so only one folder in the account is set as the drafts.

Once done you do not need the addon so disable it or remove it.

Read this answer in context 👍 0

All Replies (12)

more options

It may have occurred for you, but I certainly have no seen it, nor can I force it in general without changing the default drafts folder.

Are your icons on folders as shown in the image, or have they changed from that default?

Helpful?

more options

Ah, thanks @Matt. Apparently I'm still a TBird novice, despite years of use. Never paid attention to folder icons, but as you hint, several of mine have somehow become "drafts."

So, how do I go about untangling the confusion? Haven't yet found anything useful under "Settings."

Modified by c.roy.taylor

Helpful?

more options

Chosen Solution

There may be little or nothing to do in the account settings.

First ensure you are using the ALL folders view THe other folder views tend to be built on searches, so when fixing things start with the base all view to make sure the problem is real and not a result of the search being munged.

Check the account the folders are in (right click settings), copies and folders and ensure the correct item (folder) is set for drafts. If it is not correct it.

Then install this addon https://addons.thunderbird.net/en-US/thunderbird/addon/folderflags/?src=search

Use it to correct the flags so only one folder in the account is set as the drafts.

Once done you do not need the addon so disable it or remove it.

Helpful?

more options

Thanks, again, @Matt. FolderFlags did the trick (after I figured out that it merely added functionality under <folder> > Properties;-).

Now three questions:

 1) Any clues on how my flags got reset?  Something I did?
 2) Best Practice: ~One "Drafts" per account~ seems reasonable, but 
    where in the folder tree?  In my "IMAP GMail," I've got one at the 
    first level and another at level two, under "[Gmail]."  I presume 
    one of those is unnecessary, but which and how could I have
    generated "refs" under the former?
 3) How did I get "Drafts" and "Sent" under "Local Folders"?  Is  
     that latter, account-level folder considered a distinct account?

Modified by c.roy.taylor

Helpful?

more options

1. No idea. I would not worry about it unless it happens again. It is in my opinion often about things being changed but not being unchanged at the server so two "things" get the same flags. But that is just guesswork.


2. Generally the two drafts folders in a gmail account both reflecting the same contents. However, if you go to the accounts settings > Server settings > advanced button and insert [Gmail] (case sensitive) into the server directory the [Gmail] folder will no longer appear and the folders is contains will collapse the the root of the account where I at least expect such things to be.

3. Local folders is a special account and has inbox as will as drafts and sent, some of the folders can be deleted, others are created on demand. Originally I was a central account folder that could be specified for all POP accounts, so you had a global inbox without the trickery used to created folder views like unified and favorites (search folders) I still use mine for half a dozen pop mail accounts.

Nowadays it is primarily a storage location that stores mail on the local machine in a place that is independent of the mail server. Archival storage on the local machine without occupying server quota / storage space is it's primary use now I think.

Another "point" is that in account settings >copies and folders you should turn off the save a copy of sent mail. Gmail also makes a copy in the same sent folder as the outgoing mail goes through their servers, so having Thunderbird do it is really overkill. If you do want two copies, I suggest pointing the sent on the gmail account to the sent on local folders so you have clear separation between what you sent, and what gmail sent on.

Helpful?

more options

Thanks again, @Matt, the FolderFlags fix seems stable, and I'm a happy user again;-)

Several years ago a local Help Desk elf advised me to find another mail client, since TBird was obsolete and no longer maintained. Apparently that was misinformation, but I remain concerned about Google's relatively new -- and fortunately still optional -- two-factor authentication.

TBird's interim workaround for the problem seems a hack (lost cite, sorry).

 o Toad-Hall's 9/19 solution - //support.mozilla.org/en-US/questions/1269204
 o Google's explanation, cited 5/14 - //support.google.com/mail/answer/185833?hl=en

Has the situation evolved in the last 20+ months? Have you any inside knowledge of a long-term solution and schedule?

Helpful?

more options

My personal views on 2FA are not complimentary or polite. I am forced by my government to use it when interacting with them online and I don't like it, and getting a text message about every 10 minutes is no fun at all. It is a truly garbage way to try and secure anything. I have never been so frustrated in my life. Now some genius as Mozilla has decided every time I log in with a new device I have to jump through the same mindless hoops of getting a text message.

Thunderbird's "solution" is to use Googles preferred authentication method of oAuth2.0. Which is what is being talked about in the discussion you linked to with Toad Hall. This is not a hack, it is simply following the providers connection instructions. Something mail clients have always had to do. Everything from if a password is required to the level of connection encryption and the port are all set by the mail provider.

I have been using oAuth to connect to Google using Thunderbird for a number of years now. Despite the initial authentication occurring in web pages requiring cookies, I have never had to re-authenticate since the initial entry of my password. Google just keep reissuing connection tokens in the background as the old ones expire.

Helpful?

more options

Hello guys I have this same problem since about 4 months and have been desperately searching for a solution. Matt can you tell me "how" to do this: "Check the account the folders are in (right click settings), copies and folders and ensure the correct item (folder) is set for drafts. If it is not correct it." How do I "correct it?

Helpful?

more options

@mabraham825 - See Matt's 1/18/22 reply above. The "folderflags" addon did the trick for me.

Helpful?

more options

Thanks Roy, but I'm not really sure I understand his instructions.

1) ""Check the account the folders are in (right click settings), copies and folders and ensure the correct item (folder) is set for drafts. If it is not correct it""......I don't know what "the account" refers to. And I don't understand how to "correct" the folder to be set for drafts. I have the online inbox and an inbox in my offline (local) folders. It must be some setting that got changed as I have thunderbird for many years and this just suddenly happened. I don't understand "add-ons" or how how to apply them. It is the "online" inbox that has this problem. As a band-aid I have been copying all incoming emails to my offline (local) inbox folder. There they open like normal.

2) ""Then install this addon. Use it to correct the flags so only one folder in the account is set as the drafts."".... Again I don't see anything in Thunderbird that refers to "flags", so I have no clue how to use this even if I do download.

Oh and if it makes any difference I use POP not IMAP. I don't recall why exactly but it was from a fiasco long ago - probably something to do with "synching" which I don't want.

Any help greatly appreciated !

Modified by mabraham825

Helpful?

more options

I am was having the same problem. It started a couple days ago. I've tried:

DONE "First ensure you are using the ALL folders view THe other folder views tend to be built on searches, so when fixing things start with the base all view to make sure the problem is real and not a result of the search being munged."

DONE' Check the account the folders are in (right click settings), copies and folders and ensure the correct item (folder) is set for drafts. If it is not correct it.

To do this select (left-click) the account at the left column of the Thunderbird window: ex. [edited email from public] @gmail.com Then right-click to come up the menu window, select 'Settings', then select the 'Account Settings' tab at the top of the window At the left column look for the Account that is having the problem: ex. [edited email from public] @gmail.com Below the account, Select 'Copies & Folders' by left clicking At the right, look for 'Drafts and Templates' and select one of the 'Keep draft message in:' options. I recommend the '"Drafts" Folder on:' using the appropriate account. ex. [edited email from public] @gmail.com

This fixed my issue.

gregq HTH

Modified by James

Helpful?

more options

@mabraham825 -- Sounds like you may have only one account. TBird can interface with multiple mail hosts: For example, I have GMail and my employer's server, plus the default "Local." See @Matt's 1/20 post. Each account has its own, top level "Inbox" and whatever subordinate folders you create.

The little icon at each folder's left identifies its type. "Drafts" has a distinctive icon, and if you R-click, then visit Properties > Flags, you'll see the "Drafts" flag is set. However, to see the flags you may need the "FolderFlags" addon. You certainly need it to reset. Go to Tools > Extensions (puzzle icon), then search by name. Download, install, rinse & repeat.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.